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The	flow	is	making	a	corner	here,	so	it	can	be	induced	that	the	discharge,	forming	in	quiet	water,	interacted	with	the	pool	and	experienced	an	unexpected	acceleration	at	t	=	0.03	seconds.	This	optional	step	is	highly	recommended	because	it	speeds	up	the	.stl	conversion	by	a	factor	of	100-plus,	and	because	it	produces	better	output	with	fewer
artifacts	(Figure	1	below).	Unselect	the	Data	Rate	checkbox	so	that	the	quality	of	animations	is	not	limited	by	the	data	rate.	The	most	iterations	reported	is	2	per	cycle:	increasing	the	maximum	number	of	pressure	iterations	permitted	ITMAX	=	500	was	unnecessary.	The	asterisk	means	there	are	unsaved	changes	you’ve	made	to	the	simulation.
Momentum	advection	=	Second	order	monotonicity	preserving	3.	The	variables	are	written	leftto-right	in	the	same	order	that	they	are	listed	(top-to-bottom)	in	the	selection	list.	Plotting	Time	History	Results	in	Probe	1.	Figure	12.	On	the	Color	tab,	select	the	Background	color	swatch	and	make	the	background	white.	This	means	estimating	the
distributions	of	likely	input	values,	picking	values	from	the	distributions,	and	recording	and	interpreting	the	results	when	those	values	are	used.	Figure	6.	Select	Add.	Adjust	your	mesh	colors	if	necessary	to	be	able	to	visualize	both	mesh	planes	and	grid	lines.	Click	the	icon	in	the	window	toolbar.	These	are	used	to	bound	the	defined	plane.	Similarly
the	downstream	flow	over	the	topography	doesn’t	require	high	resolution	for	this	case.	It	cuts	the	torus	across	the	centerline	so	only	the	lower	half	remains.	Page	10	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Add	Mesh	Planes	to	Resolve	Flat	Geometry	Now	you’ll	add	Mesh	Planes,	which	are
user-specified	grid	lines.	There	is	no	undo	function:	after	every	major	processing	step,	export	the	mesh	with	a	new	filename.	Unity	minus	this	value	is	the	maximum	fraction	of	air	allowed	in	a	cell.	………..	See	ASCE	(2009)	and	ASME	(2009)	for	details	and	calculations.	Add	to	Component	=	New	Component	(1)	since	there	are	currently	no	components.
Select	a	saturated	porous	drag	model,	Compare	empirical	coefficients	to	project-specific	coefficients,	Calculate	FLOW-3D	drag	coefficients	from	more	common	coefficients,	Set	up	a	simulation	from	a	list	of	specifications,	Specify	a	boundary	hydrograph	so	boundary	velocity	varies	with	time,	and	Analyze	simulation	results	and	compare	them	to
experimental	data.	Make	a	Simulation	Copy	1.	Select	Units	System	=	SI.	Change	the	name	of	the	output	file	(at	the	end	of	the	path)	to	weir1_repaired2.stl.	The	model	will	move	with	the	mouse.	CloudCompare	permanent	shift	options	for	shortest	positive	coordinates	Select	Tools	>	Scalar	Fields	>	Delete	All(!)	to	eliminate	the	scalar	fields	from	the
saved	output	so	that	it	can	be	opened	in	MeshLab.	Keep	the	option	to	delete	the	individual	frame	images	after	they’ve	been	combined	into	a	movie.	Enter	the	workspace	name:	Hydraulics	Examples.	Component	2	>	Component	Properties	>	Type	of	Moving	Object	>	Edit	Moving	Object	Properties	>	Motion	Constraints	tab:	all	translations	coupled,	all
rotations	prescribed	(defaults	to	zero,	no	rotation	permitted).	Torus	Major	radius	=	0.0105	cm	4.	Now	select	the	big	hole,	this	time	using	the	Self	Intersection	repair	option.	Figure	1.	Multiple	experiments	were	conducted	with	varying	flow	rates	(0.001	to	0.020	m/s),	varying	temperatures	(9	°C	to	57	°C),	varying	porosities	(0.36	–	0.65),	and	varying
characteristic	grain	size	(0.5	mm	to	2.0	mm).		Generate,	check,	and	repair	all	.stl	files	Check	all	.stl	files	for	errors	and	repair	them	using	MiniMagics,	Admesh,	netfabb	Studio,	MeshLab,	and/or	similar	.stl	tool	programs.	Set	X	scale	=	60	and	Y	scale	=	180	(the	absolute	length	of	the	grid	sides)	per	Table	2	above.	Save	the	file	as	.obj	or	.3ds	format.
Different	.stl	tools	use	different	repair	algorithms	and	may	produce	different	results.		Check	sensitivity	to	boundary	conditions		Move	the	boundary	location	(mesh	block	extents)	away	from	the	region	of	interest	and	re-run	the	coarse	case	until	the	results	do	not	vary	significantly.	The	use	of	MeshLab	is	discussed	in	a	separate	exercise	on	topography.
Keep	the	original	data	hidden	and	turn	off	the	coloring	by	selecting	Render	>	Color	>	None.	It	means	warnings	are	2.	If	no	line	appears,	troubleshoot	by:	i.	Conv.	The	steps	will	cause	rapid	change	at	the	inlet	boundary	condition,	a	known	cause	of	pressure	problems!	This	is	why	increased	pressure	solver	overhead	was	specified	above.	They	are	also
transparent	when	viewing	results.	o	Initial	Fluid	Elevation	=	0.312	m.	Figure	17.	It’s	an	example	of	input	uncertainty.	Check	the	Messages	pane	and	carefully	review	the	details	of	the	repair.	Page	11	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	Set	the	Finish	Time	The	default	runtime	for	a
new	simulation	is	1	second,	and	this	is	not	long	enough	to	reach	steady	state.	Find	the	.avi	file	you	created	and	play	it	by	double-clicking	on	it.	Repeat	the	colorization	process	(per	vertex	quality	function	=	-z).	1966.	Deactivate	Cells	with	a	Domain	Removing	Component	Unnecessary	cells	can	be	deactivated	to	save	memory	and	time,	but	only	when
they	will	definitely	never	contain	flow.	A	second	.stl	tool,	called	qAdmesh,	is	included	with	FLOW-3D.	Select	Implicit	for	the	Moving	object	/	fluid	coupling.	Page	5	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	Assessing	Mesh	Resolution	with	FAVOR	One	of	the	most	important
aspects	of	simulation	setup	is	choosing	an	appropriate	computational	mesh.	Expand	the	Properties	>	Fluid	1	tree	and	the	sub-branches.	Page	6	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Check	Model	Resolution	Using	FAVOR	At	this	point	in	the	geometry	building	process	it	will	be	useful	to
FAVORize	determine	if	all	the	specified	geometry	is	adequately	resolved.	Close	small	holes	STEP	10	–	REPAIR	THE	BACK	FACE	Delete	the	four	non-manifold	vertices	on	the	back	corners	and	the	facets	that	share	them,	if	you	didn’t	already	in	Step	8.	Download	TOPO2STL	from	the	Utilities	section	at	users.flow3d.com.	The	prpgrf	file	was	generated
during	preprocessing	and	was	deleted	to	save	space	when	the	simulation	ran.	The	downstream	leg	of	the	pipe	is	15	cm	diameter	and	angled	at	a	10%	slope	(i.e.,	the	slope	of	the	pipe	is	10	cm/100	cm).	Page	1	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	Create	a	New	(Blank)	Simulation	File	1.	Plot	Probe	>
General	History	data	>	Component	3	GMO	Shear	Force	Magnitude	in	Space	System	to	see	the	particle	drag	magnitude.	Maximum	error	between	.stl	and	point	cloud	is	high	on	a	steep	bank	slope	e.	Find	precise	min/max	coordinates.	Run	qAdmesh	again	on	the	fixed	output	until	no	more	changes	are	made	to	make	sure	that	the	part	is	repairable.
Figure	9:	Final	time	step	(t	=	5.0	seconds)	for	drift-flux	model	version	of	problem	Calculate	as	before	to	find	the	instant	and	time-averaged	air	flow:	1.	X	=	-0.03048	and	X	=	0.3048	to	resolve	the	weir	faces,	b.	Select	OK	to	begin	importing	the	data.	Launch	the	FLOW-3D		interface	by	double-clicking	the	FLOW-3D	icon	on	your	desktop.	velocity.	When
prompted	for	the	Temperature	Unit,	select	Kelvin.	The	2-D	assumption	will	limit	the	validity	of	the	results;	the	exercise	is	for	illustration	of	the	various	approaches	rather	than	a	formal	validation.	Create	the	second	hole	as	a	copy	of	the	first	one:	a.	Page	5	of	11	FLOW-3D	Version	11	Simulation	Setup		Associate	the	subcomponents	with	components.
Page	3	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	6.	Check	that	the	values	for	fluid	Density	ρf	=	1000	kg/m3	and	dynamic	Viscosity	μf	=	0.001	kg/m/s.	5)	Pre-subsample	the	data.	Y	=	-2.37066666666667	and	Y	=	2.37066666666667	for	the	edges	of	the	fine	block,	and	d.	Page	9	of	13	Water	&	Environment	Training	on
FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	Page	10	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	Add	a	History	Probe	to	Measure	the	Approach	Depth	History	Probes	are	single	points	which	measure	the	cell-centered	flow	parameters.		Hold	the	mouse	cursor	over	selection
boxes	to	find	the	variable	code	for	unfamiliar	available	selections.	20.3	x	106	points)	Table	2.	Uses	all	loaded	available	unreliably:	memory.	There	are	many	reasons	for	decimating	a	large	point	cloud	(stability	and	run-time	of	various	meshing	algorithms,	for	example),	and	there	are	usually	ways	to	do	it	that	retain	a	high	degree	of	fidelity.	Pressure
convergence	ratio:	the	ratio	of	maximum	residual	to	epsi.	In	the	Solver	text,	scroll	up	and	find	the	total,	fluid,	and	solid	sub-domain	cell	counts.	See	if	they	make	sense	to	you.		Baffles	will	be	moved	to	the	nearest	grid	line	during	preprocessing.	where	K1	is	the	media’s	experimental	D’Arcian	permeability	and	K2	is	the	coefficient	of	non-D’Arcian
permeability.	The	interested	user	is	referred	to	ASCE	(2009)	and	ASME	(2005,	2009)	for	guidance	and	details.	9	STEP	6	–	CONVERT	THE	POINT	CLOUD	TO	.STL	WITH	TOPO2STL	.................................................................	Start	to	make	a	new	primitive	box	(Subcomponent	menu	>	Box).	A	series	of	closely-zoomed	and	careful	measurements	show	that
the	blade	crest	is	almost	exactly	0.08	units	wide	in	the	x	direction.	Page	15	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	Page	16	of	16	Exercise	3:	Meshing	&	Boundary	Conditions	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Exercise	3:	Meshing	&	Boundary
Conditions	Problem	Description	&	Objectives	In	this	exercise	a	computational	grid	will	be	created	with	boundary	conditions.	Divide	∆P	by	the	length	of	the	porous	media	(0.3	m)	to	find	the	unit	loss	∆P/∆x.	Note	that	fluid	properties	are	grayed	out	if	they	require	inactive	physics	models	(e.g.,	thermal	properties).	The	pressure	iteration	fails	if	the	max
residual	is	larger	than	epsi	after	the	maximum	number	of	pressure	solver	iterations,	otherwise	it	is	converged.	Results	should	look	like	Figure	17.	Place	the	boundary	there.	Set	Num	vertices	=	1443	and	4327	points	in	X	and	Y,	respectively,	for	½-inch	spacing.	Select	only	the	non-river	plane	faces	using	Filters	>	Selection	>	Conditional	Vertex
Selection,	with	Boolean	function	=	(z	>	99.298)	or	(z	<	97)	(see	Table	2).	Select	Diagnostics	>	Solver	Errors	from	the	menu	at	the	top	of	the	screen:	the	same	information	is	displayed.	Use	the	tabs	at	the	bottom	of	the	Component	Properties	Window	to	toggle	between	the	components.	Note	that	the	nappe	appears	subcritical.	When	used	improperly
some	of	these	options	can	cause	problems	with	the	solution.		Take	the	smallest	model	that	is	free	from	boundary	effects	as	the	working	case.	The	usual	working	method	is	to	instead	use	either	the	converged	mesh	or	the	best	possible	mesh	and	then	calibrate	component	roughness	to	whatever	value	minimizes	the	difference	between	CFD	and
experiment.	Geometry	is	always	displayed	on	2-D	plots,	so	nothing	needs	to	be	selected	to	view	it.	MAYBE.	Open	the	Initial	Conditions	Window	.	In	this	case,	although	you	will	use	the	RNG	turbulence	model	and	a	partially	full	pipe	modeled	as	a	2-D	plane,	the	empirical	estimates	below	are	derived	from	the	standard	k-e	model	and	empirical
approximations	for	full	round	pipes.	Click	the	Add	button.	Compare	your	last	output	to	Figure	7,	below.	Geometry	files	must	always	be	checked	for	errors	and	errors	must	be	repaired.	The	number	of	steps	controls	the	resolution	of	the	line,	as	well	as	the	length.	Mesh	Planes	should	only	be	used	to	define	flat	solids	that	are	parallel	to	an	axis.	16.	The
same	GDAL	library	is	included	in	FWTOOLS	for	MicroDEM.	The	meshes	have	perfect	gridline	matching	right	now.	Answer	the	following	questions:		Are	the	solver	warnings	acceptable?	Click	on	the	icon	to	switch	to	a	profile	view	from	the	side.	Take	some	time	and	experiment.	The	length	is	in	meters	since	SI	units	are	being	used.	Repeat	the	measuring
process	to	find	the	coordinates	of	the	blade	endpoints.	In	order	to	run	the	simulation	and	check	our	boundary	conditions	for	accuracy,	we	will	need	to	set	fluid	properties.	Check	the	Set	Up	Use	the	problem	specification	statement	and	the	sketches	above	and	below	to	set	up	the	simulation.	Deselect	NaN	in	grey	to	hide	the	non-maximum	points.	Output
frequency	=	1/100th	of	the	finish	time	by	default.	Plot	Selected	Data	for	Pressure,	and	then	Velocity	Magnitude,	in	2-D	with	No	Velocity	Vectors.	Start	by	defining	the	components.	Save	your	work!	Have	you	figured	out	that	this	should	happen	with	every	change?	Export	the	final	plane	in	.xyz	format	with	no	normals	in	case	MeshLab	crashes	during	the
next	step.	To	mirror	the	results	across	the	y=0	plane,	select	Tools	>	Symmetry	from	the	menu	above	the	display	and	select	the	Y	Direction	checkbox	in	the	dialog.	There	should	be	no	errors	in	that	file.	Blocks	1	and	2	will	get	Auto	Mesh…	twice	each	for	different	vertical	and	horizontal	cell	sizes.	Note	that	the	Restart	Data	Interval,	Selected	Data
Interval,	and	History	Data	Interval	can	be	forced	to	other	than	the	default	1/10th,	1/100th,	amd	1/100th	of	the	finish	time,	respectively.	Initial	Time	Step	DELT	=	1E-9	seconds	2.	Select	Materials	>	Fluids	Database...	The	boundary	pressures	and	initial	void	pressures	match	at	0	Pa.	Matching	the	void,	initial,	and	boundary	pressures	can	be	very
important	when	the	void	pressure	varies	via	bubble	physics.	The	upstream	boundary	condition	here	will	be	specified	as	pressure-type	using	total	head	H.	Notice	that	the	cell	location	and	mesh	block	are	not	given	in	this	summary.	The	goal	of	mesh	setup	is	to	use	just	enough	cells	to	resolve	the	geometry	and	the	flow	features	of	interest.	POINT
SPACING	FOR	MESHLAB	PREDECIMATION	&	TOPO2STL	SAMPLING	PRETOPO2STL	CONVERSION	STATISTICS	ESTIMATE	OF	RAW	DATA	SET:	CLEANED	DATA	SET	CLEANED	DATA	SET	TOTAL	NOT	CLEANED,	NOT	WITH	EMPTY	REGIONS	WITH	EMPTY	REGIONS	SURFACE	PRE-FILLED,	NOT	PRE-FILLED,	NOT	PREPRE-FILLED	&	POINTS
TO	BE	DECIMATED	DECIMATED	POISSON-DISK	PREGENERATED	DECIMATION	TO	BY	TOPO2STL	TARGET	TOPO2STL	SPACING	¼-inch	24.96	million	TOPO2STL	did	not	18.6	million	pts	in/	6.94	million	pts	in/	(0.0208	feet)	points	complete	the	53	minutes/	45	minutes/	conversion	within	4	21.40	million	pts	out/	21.36	million	pts	out/	days.	Did	you	set
up	the	model	correctly?	Select	Render	>	Render	Mode	>	Points	from	the	menus	or	on	the	Render	toolbar	to	display	the	points.	On	the	Model	Setup:	Physics	tab		Activate	the	relevant	physics	models	based	on	the	annotated	diagram					Be	aware	of	dependencies:	some	physics	models	can’t	be	activated	without	others.	Turn	on	point	selection.		Define
mass	source	flow	rates	and	properties	and	moving	object	motion	types	and	properties,	if	present.	Output	will	be	titled	with	this	name.	The	button	prints	the	current	view,	which	can	be	used	with	a	.pdf	printer	program	to	generate	images	of	the	mesh	and	geometry	setup	(hint:	use	the	Print	Screen	keyboard	button	and	a	Paint	program	as	an
alternative).	Changing	the	min	and	max	values	manually	equalizes	the	color,	which	will	be	useful	later.	Launch	SketchUp	Make	2014.	The	sharp	crest	of	the	weir	is	visible	and	it	appears	to	be	adequately	resolved.	Page	19	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	5.	Open	the
Time	Frame	sliders	all	the	way:	Min	=	0	and	Max	=	35	seconds.	The	weir	plate	is	0.33528	m	thick	and	has	surfaces	at	X	=	-0.03048	and	X	=	0.3048.	Click	on	Search	at	the	top	of	the	text	dialog	and	search	for	cell	summary.	Component	2	>	Type	of	moving	object	=	Prescribed	ii.	It	is	not	as	user-friendly	as	CloudCompare,	and	“Mr.	P’s”	tutorials
(www.youtube.com/user/mrpmeshlabtutorials)	are	highly	recommended	when	you	are	ready	to	learn	more.	This	can	be	checked	later	with	multiple	versions	of	the	same	simulation	set	up.	You	can	use	the	mouse	to	zoom	and	pan.	First,	you’ll	generate	the	same	display	that	was	generated	by	the	FAVORize	function.	Use	porosity	to	convert	to
macroscopic	velocity	to	microscopic	velocity,	and	then	find	the	pore	Reynolds	number	for	each	velocity	assuming	the	pore	diameter	Dp	is	equal	to	the	average	grain	diameter	(1	mm):	EXPERIMENTAL	SUPERFICIAL	VELOCITY	Umacro	(m/s)	0.001	0.002	0.003	0.004	0.005	0.006	0.007	0.008	0.009	0.010	0.011	0.012	0.013	0.014	0.015	0.016	0.017
0.018	0.019	0.020	CALCULATED	MICROSCOPIC	VELOCITY	Up	=	Umacro/ηeff	(m/s)	0.002	0.004	0.006	0.008	0.010	0.012	0.014	0.016	0.018	0.020	0.022	0.024	0.026	0.028	0.030	0.032	0.034	0.036	0.038	0.040	CALCULATED	PORE	REYNOLDS	#	ReP	(dimless)	2.0	4.0	5.9	7.9	9.9	11.9	13.9	15.8	17.8	19.8	21.8	23.8	25.7	27.7	29.7	31.7	33.7	35.7	37.6
39.6	Table	1:	Calculating	microscopic	velocity	and	pore	Reynolds	number	The	pore	Reynolds	number	ranges	from	2.0	to	39.6.	The	D’Arcian	flow	regime	is	strictly	speaking	only	valid	to	ReP	=	1,	but	is	generally	assumed	accurate	up	to	ReP	=	10.	It	does	not	yet	include	as	many	features	as	MeshLab,	but	the	features	it	includes	are	well-implemented
and	easy	to	use.	Is	the	relative	error	<	5%?	These	flow	parameters	are	communicated	into	the	domain.	Slide	the	Seeding	Plane	slider	back	and	forth	and	watch	the	green	plane	move	in	the	display.	They	should	be	removed	before	triangulation,	and	since	they	are	clearly	visible	at	this	stage	now	is	the	best	time	to	remove	them.	Gravity	and	turbulence
models	will	be	activated,	and	mass/momentum	sources	will	be	added	to	the	simulation	to	create	discharge	from	the	pipe	culverts.	Set	Header	Row	to	be	Skipped	=	2	(per	what	you	saw	in	CloudCompare)	and	deselect	Grid	Triangulation,	because	this	import	filter	won’t	work	with	non-uniform	point	distributions.	Select	Browse	under	Input	and	load
MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833.stl.	Therefore:	gx	=	980	sin	5.71059°	=	+	97.5136	cm/s2	gz	=	-	980	cos	5.71059°	=	-	975.136	cm/s2	Another	way	to	solve	for	gz	would	be	to	start	with	slope:	gx	=	gz/10,	so	[gz2	+	(gz/10)2]	=	9802.	From	the	fitted	equation,	we	see	that	A	=	421,674	B	=	19,540,327	Compare	the	fitting
equation	to	the	full	equation	with	K1	(PERM)	and	K2	(PERM2):	(	)	And	then	solve	for	K1	and	K2	using	the	known	fluid	density	and	viscosity:	K1	=	μ/A	=	2.3715E-9	K2	=	ρ/B	=	5.1084E-5	Page	9	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Problem	Specification	Set	up	the	problem	following	the	model
specifications	below:	General	and	Numeric	Tab	Options	o	Simulation	name:	Saturated	Porous	o	Simulation	units	UNITS	=	SI	o	Simulation	time	TWFIN	=	3598	seconds	o	Number	of	processors	NPROC	=	2	o	Initial	time	step	DELT	=	0.001	sec	o	Minimum	number	of	pressure	iterations	ITMIN	=	2	o	Maximum	number	of	pressure	iterations	ITMAX	=	500
o	GMRES	subspace	size	MRSTRT	=	25	Physics	o	Porous	Media	-	Permeability	Dependent	Saturated	Drag	o	Viscosity	&	Turbulence		Viscous	Flow		RNG	Turbulence	with	Dynamically-Computed	TLEN	Fluid	Properties	(Water,	measured	experimentally	@	24	–	26	°C)	o	Density	ρ	=	998.2	kg/m3	o	Viscosity	μ	=	0.001008	Pa-s	(i.e.	kg/m/s)	o	Compressibility
=	1/(ρ	W2)	=	4.55E-10	(assume	speed	of	sound	W	≈	1483	m/s)	Output	o	Selected	data	at	default	1%	time	intervals		Drag	Function		Fluid	Velocities		Pressure	Geometry	o	1	Subcomponent		Shape	=	Cylinder		Name	=	Packed	Bed		Radius	=	0.12	m		Z	Low	=	0.0	m		Z	High	=	0.3	m		Axis	along	origin	o	1	Component		Name	=	Packed	Bed		Component	Type
=	Porous	o	Properties	(Component	Properties	>	Porous	Properties)		Porosity	=	0.5		Darcian	Permeability	=	2.3715E-9		Non-Darcian	Permeability	=	5.1084E-5	Problem	specification	is	continued	on	the	next	page:	Page	10	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Mesh	Specifications	o	Cylindrical
(right-click	on	Mesh-Cartesian	and	select	Change	to	Cylindrical	Coordinates)	o	2-D	Mesh	Block	o	Domain		X	(r)	=	0	m	to	0.12	m	-----------------	#	Total	Cells	=	5		Y(θ)	=	0	degrees	to	30	degrees	---	#	Total	Cells	=	1		Z	(z)	=	-0.012	m	to	0.312	m	--------	#	Total	Cells	=	20	Boundary	Conditions	o	X	Min:	Symmetry	(S)	(r	=	0	is	a	discontinuity,	and	should	always
be	symmetry)	o	X	Max:	Wall	(W)	o	Y	Min	&	Y	Max:	Periodic	(Pd)	(flow	can	rotate	out	one	side	and	back	in	the	other)	o	Z	Min:	Gauge	Stagnation	Pressure	(P)		F=1		P	=	0	Pa	o	Z	Max:	Velocity	(V)		varies	with	time:	import	velocities	&	times	from	a	.csv	file	(described	below)	Initial	Conditions	o	Global	>	Fluid	Initialization	=	Use	Fluid	Elevation.	After
completing	the	simulation	setup	guide	(on	this	site)	you	will	have:		An	annotated	diagram	with	all	necessary	information	in	a	consistent	unit	system,		A	simulation	folder	with:	o	all	.stl	files	(checked	and	repaired)	o	a	ready-to-run	prepin	file		A	mesh	that	resolves	the	thinnest	flow	sections	with	3	or	4	cells,		A	mesh	that	follows	best-possible-practices,	
Rationales	for	all	specified	physics	models	and	coefficients.	Set	the	name	of	the	output	file	as	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833.stl.	Continue	adjusting	and	re-running	the	coarse	case	model	until	you	are	confident	in	the	simulation	and	ready	to	commit	to	longer	run	times.	The	F	=	0	Pressure	boundary	approach	eliminates
that	possibility	by	removing	any	fluid	that	splashes	the	top	of	the	domain.	Now	click	the	Render	button.	These	options	will	only	slow	down	the	solver,	and	will	not	relax	the	convergence	criteria.	You	will	have	to	re-launch	the	Fill	Hole	tool	after	each	operation	to	slowly	fill	in	the	back	side.	Only	half	of	the	weir	is	modeled,	and	symmetry	along	the
centerline	of	the	weir	is	assumed.	The	column	labels	are	a	useful	feature	when	the	raw	data	is	not	in	the	order	TOPO2STL	expects.	The	total	thickness	may	be	a	design	error.	Make	an	overlay	of	the	free	surface	with	time:	select	Overlay	from	the	dropdown	plot	type	list	in	the	upper	right:	Click	on	several	of	the	early	time	steps	to	make	an	overlay	plot:
Page	22	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	7.	This	correlates	directly	to	a	reduction	in	memory	use	and	a	substantial	runtime	efficiency	improvement.	The	stability	limit	is	the	requirement	that	fluid	packets	only	move	one	cell	per	time	step.	Still,	it	would	be	better	to
make	everything	perfect.	Select	Open	when	you’ve	selected	weir1_repaired.stl.	Assign	the	Position:	As	Last	Subcomponent.	Later	we	will	view	the	model	as	the	solver	will	see	it,	and	it	will	appear	as	half	of	a	sharp-crested	weir.	Set	STL	Minimum	Z-Coordinate	=	90	ft.	If	the	geometry	Page	17	of	24	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	isn’t	visible,	use	to	reset	the	view.	Final	Check	after	setup		Check	that	the	simulation	pre-processes	without	crashing		Check	the	pre-processed	output	in	3-D		Do	the	fluid	and	geometry	locations	and	resolutions	“look	right”?	The	.stl	is	closed	by	stitching	the	upper	and	lower	surfaces
together	with	more	triangular	facets.	If	none	of	the	available	boundary	condition	types	are	a	reasonable	approximation	of	the	physical	situation	at	a	boundary	then	that	boundary	must	be	moved	elsewhere.		Maximum	Volume	Fraction	of	Phase	1	is	the	upper	limit	fraction	of	water	permitted	in	a	cell.	2009.	Z-Max	boundary	is	an	Outflow	boundary	to
allow	fluid	to	exit	the	domain	smoothly.	Fluid	fraction,	Fluid	velocities,	Hydraulic	Data,	and	Pressure	5.	Select	the	action	to	make	the	contents	of	the	selection	polygon	a	separate	point	cloud.	Note	that	the	cell	number	J	=	2.	Name	the	copy	Air	Entrainment	Density.	Make	sure	you	moved	the	repaired	.stl	files.	CloudCompare	temporary	shift	options	for
segmented	topography	Page	5	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Use	Tools	>	Projection	>	Export	Coordinate(s)	to	Scalar	Field(s)	>	X,Y,Z	to	export	the	coordinates.	Effective	porosity	is	the	porosity	that	is	available	for	flow,	and	excludes	pores	that	cannot	be	filled	or	drained.	The	download	will
contain	all	1-degree	x	1-degree	tiles	that	Page	1	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	contain	the	region	of	interest.	Page	14	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	Also	look	at	the	solver	text	output	results	at	the	bottom
of	the	screen.	The	dialog	that	opens	lists	Approximate	Results	for	the	distance	magnitudes	between	original	points	and	the	nearest	.stl	facets.	You	will	create	four	mesh	blocks	to	resolve	the	flow	and	conform	one	of	them	to	the	weir.	Plotting	Text	Output	Text	Output	(on	the	Analyze	>	Text	Output	tab)	is	very	similar	to	the	text	which	can	be	output
from	the	Probe	tab	except	that	output	for	many	cells	in	a	3-D	rectangle	can	be	output	from	Text	Output,	while	only	one	cell	at	a	time	can	be	output	from	Probe	spatial	data.	Specify	Z	High	=	4.2	(to	match	the	upstream	boundary	condition	free	surface	elevation).	Page	14	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from
USGS	Data	STEP	12	–	CHECK	ACCURACY	Use	CloudCompare’s	Compute	Cloud/Mesh	Distances	tool	with	Octree	Level	=	10	and	compare	the	.stl	file	to	the	original	trimmed	point	cloud.	WATER	&	ENVIRONMENT	TRAINING	EXERCISES	Improving	the	world	through	accurate	flow	modeling	Guide	1:	CFD	Project	Workflow	Guide	FLOW-3D	Version	11
CFD	Project	Overview	CFD	Project	Workflow	Guide	Contents	Select	a	problem	with	known	results	for	proof-of-concept	testing	.............................................................	Initialize	fluid	regions	and	boundaries	with	velocity	and	hydrostatic	pressure,	4.	Click	Apply	to	change	the	display	without	closing	the	dialog.	The	multiplier	can	be	used	to	curvefit
existing	data,	if	needed.	A	less	certain	but	much	faster	approach	is	to	use	empirical	estimates	of	turbulent	parameters.	Page	4	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	The	information	in	the	Messages	pane	indicates	the	results.	Use	more	than	one	hole	subcomponent	to	cut	through	more	than	one
component.	The	points	and	vectors	are	recorded	in	Cartesian	coordinates.	The	error	occurred	in	Mesh	Block	4,	the	conforming	block.	Once	the	non-river	surfaces	are	selected,	apply	Filters	>	Remeshing,	Simplification	and	Reconstruction	>	Quadric	Edge	Collapse	Decimation	with	the	following	options:	Target	Number	of	Faces	=	100000,	Quality
Threshold	=	0.3,	Preserve	Boundaries	of	the	Mesh	(Boundary	Preserving	Weight	=	10),	Preserve	Normal,	Preserve	Topology,	Planar	Simplification,	Post-Simplification	Cleaning,	and	Simplify	Only	Selected	Faces	which	is	very	important	to	avoid	simplifying	the	river!	Check	that	the	non-river	facets	have	been	simplified	as	in	Figure	12	below.	On	the
Simulation	Manager	tab,	create	a	new	workspace	by	selecting	File	>	New	Workspace	from	the	menu	at	the	top.	You	can	search	to	see	how	other	users	have	modeled	the	same	type	of	problem:		www.flow3d.com	>	Resources	>	Bibliography	>	html	search	(Ctrl-F)	for	keywords		www.flow3d.com	>	Site	Search	(upper	right	input	box)	for	keywords	
users.flow3d.com	>	Conference	Proceedings,	Validations,	Example	Simulations,	Technical	Notes	(for	cases	related	to	specific	physics	models),	and	Training	(for	tutorials)		Compare	the	test	case	to	the	case	of	interest		How	were	the	test	case	experimental	results	collected?	Plot	the	flow’s	center	line	as	an	XZ	plane.	The	lower	surface	of	the	.stl	part	is
created	as	a	flat	plane	at	the	specified	z-minimum	elevation.	Repeat	the	increase	until	the	line	reaches	the	end	or	no	longer	changes.	Use	this	tab	to	get	many	cell-by-cell	numerical	values.	o	Boundaries	and	Initial	Regions	as	shown	in	Figure	4,	below.		Is	the	time	step	reasonable?	4)	Quality	control:	Compare	the	.stl	file	surface	to	the	original	point
cloud	data	to	verify	the	accuracy	and	precision	of	the	conversion.	Experiment	with	outputting	two	or	more	time	steps.	The	scripts	are	available	as	of	November	2013	at	Page	3	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	.	Turbulent	flow	in	circular	pipes	begins	at	approximately	ReD	=	4,000.	Check	again
for	outlying	points	and	record	the	precise	min/max	values	(Table	2).	New	plane	added	c.	Find	the	block	at	the	bottom	of	the	weir.		The	flow	mode	option	applies	only	to	two-fluid	problems.	Running	the	same	case	with	different	mesh	resolutions	demonstrates	that	the	solution	converges	when	the	mesh	and	time	step	are	refined.	The	problem	cell	(I	=
61)	will	be	in	the	center.	At	first	most	of	them	occur	at	i	=	46,	j	=	2,	k	=	3.	Click	the	Workspace	File	path	in	the	upper	right	of	the	screen	to	open	the	workspace	folder	or	navigate	to	it	manually	in	the	operating	system.	Figure	11.	Fill	fraction	is	the	dimensionless	ratio	of	fluid	volume	to	total	open	(non-solid)	volume	in	all	blocks	of	the	domain.	Induce
an	explanation	(or	see	the	next	page).	QV,MIX	=	FFLUX1	=	1236	cm3	air-water	mixture/s:	25%	higher	than	in	the	scalar	run!	Explain	why.	Navigate	to	the	Model	Setup	>	Meshing	&	Geometry	tab.	Page	13	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Check	the	Mesh	Aspect	Ratios	with	the	Mesh
Information	Tool	1.	%	concentration	of	air	in	the	mixture	=	QV,AIR/QV,MIX	=	6.3%	by	volume	at	t	=	5	seconds.	Measurement	locations	not	shown.	5	Calibrate	mesh-dependent	input	parameters	..............................................................................................	Now	consider	the	possibility	that	the	air	is	entrained	as	a	cloud	of	tiny	bubbles,	which	not	only
bulk	the	fluid	(volume	and	buoyancy	effects)	but	interact	with	the	flow	in	three	additional	ways:	by	drifting	at	a	different	velocity	than	the	water,	by	exerting	form	and	wake	drag	on	the	water,	and	by	escaping	to	the	atmosphere	through	the	free	surface.	Keep	the	default	Custom	option.	Keep	Fluid	Fraction	activated	instead	of	the	elevation.		Make	cells
in	finer	blocks	exactly	½,	¼,	etc.	The	file	will	take	several	minutes	to	load.	Save	your	work!	Select	Output	Options	The	solver	will	automatically	write	10	data	sets	(e.g.,	every	10	seconds)	that	can	be	used	to	generate	2-D	and	3-D	plots.	The	downstream	boundary	flow	is	expected	to	be	sub-critical	and	you	will	use	Pressure	boundaries	with	tailwater
depths.	Your	point	data	should	appear	similar	to	Figure	9	above.	The	display	show	a	full	weir	structure	as	shown	below.	In	FLOW-3D,	go	to	the	Model	Setup	>	Meshing	&	Geometry	tab.	Open	the	Initial	Conditions	Window	and	then	the	Initial	>	Global	>	Pressure	branches.	We	can	(correctly)	infer	that	the	researcher	has	already	accounted	for	static
head	before	reporting	the	results.	Common	causes	of	serious	(that	is,	numerous)	errors	include:						bad	geometry	files:	fix	with	pyAdmesh	and	netfabb	or	re-export	from	CAD,	unresolved	or	poorly	resolved	gaps	between	geometry:	use	finer	cells	or	different	geometry,	incorrect	boundaries	or	sudden	changes	in	boundary	conditions	or	mass/momentum
sources,	incorrect	initial	conditions,	and/or	flying	droplets/splashing	of	fluid.	Choose	Selected	data	as	the	Data	Source	to	access	the	more	frequent	data	specified	earlier	in	the	exercise.	Rotate	and	zoom	the	view	to	look	at	the	FAVORized	geometry	closely.	FLOW3D	uses	.stl	files	as	inputs	to	define	complex	geometry	and	as	outputs	to	describe	resolved
fluid	and	solid	surfaces.	Component	3:	Dirt:	the	particle	will	move	with	the	fluid.	Make	it	part	of	a	new	solid	Component	3,	also	named	topo.	The	first	instance	of	the	term	is	at	the	beginning	of	the	mesh	block	namelist.	There	are	many	ways	to	use	MeshLab	with	point	clouds	and	.stl	files,	a	few	of	which	will	be	detailed	below.	The	grid	(mesh)	defines
the	domain:	the	region	in	which	fluid	calculations	take	place.	Save	your	work	and	check	it	again	with	FAVORize.	Measurements	were	taken	via	ground-based	LiDAR	of	a	scale	model	of	the	Middle	Rio	Grande	River	in	New	Mexico.	Finer	meshes	(smaller	cell	sizes)	give	more	precise	results	but	require	longer	run-time	and	more	memory.	Slide	the	Max
Time	Frame	slider	(or	use	the	associated	arrow)	so	that	t	=	0	to	0.7	seconds.	The	file	size	is	445	MB:	too	large	to	work	with	in	most	text	editors.		When	the	disagreement	|E|	is	greater	than	uval,	it	suggests	that	the	model	setup	could	be	improved	(e.g.,	by	calibrating	mesh-dependent	parameters	as	described	below)	or	that	the	CFD	itself	is	of	limited
reliability	(e.g.,	turbulence	models).	To	use	the	relationship	above,	the	experimental	head	loss	∆H	needs	to	be	converted	to	pressure	loss	∆P.	5.	Now	you	will	fit	the	experimental	data	directly.	Preprocess	the	Mesh	Preprocessing	the	mesh	is	an	important	final	step.	Usually	10,000	or	100,000	integration	steps	are	sufficient	to	complete	the	line.	Page	8
of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	Add	a	Flux	Surface	Baffle	to	Measure	Weir	Flow	Baffles	are	flat	planes	along	grid	lines	that	block	or	measure	flow.	Merriam-Webster	(2013).	Params,	and	set	Distribution	=	Gauss	to	compare	the	actual	error	magnitudes	to	a	normal	distribution.
This	might	affect	the	accuracy	of	the	flow,	though	you’ll	find	with	time	that	FLOW-3D	is	both	robust	and	forgiving.	The	MeshLab	project	file	(.mlp)	file	records	mesh	file	path,	transformation,	&	camera/lighting	data.	Instead,	macroscopic	(or	superficial)	velocity	Umacro	is	measured	as	the	transit	time	across	the	media,	neglecting	tortuosity.
Experiment	with	outputting	a	single	time	step.	It	will	shortly	be	demonstrated	that	these	values	are	incorrect.	Accurate	results	often	require	10	to	12	cells	across	the	thinnest	flow	section.	Binary	format	.stl	file	size	is	about	20%	of	ASCII	format.	These	data	are	not	computed	unless	this	option	is	selected	because	they	are	secondary	parameters	derived
from	other	values.	Repeat	for	each	block	and	each	direction	as	shown	below,	clicking	OK	after	each	step.	On	the	Model	Setup:	Fluids	tab		Define	the	properties	of	fluid	1	and	(if	used)	fluid	2	Define	the	appropriate	physical	properties	for	the	active	physical	models	using	the	annotated	diagram	as	a	guide.	By	the	visible	time	steps,	however,	the	flow	is
predictable	enough	that	the	dynamically	chosen	time	step	accounts	for	the	change	in	direction.	Right-click	Mass	Momentum	Source	1	and	select	Copy.	Make	it	a	solid	Subcomponent	5	named	topo.		Viscosity	of	Phase	#2	is	the	viscosity	of	the	dispersed	phase	if	it	were	to	become	so	concentrated	as	to	be	continuous.	If	you	have	not	done	so	already,
create	a	workspace	for	this	training	titled	Hydraulics	Examples	following	the	instructions	in	Exercise	1,	p.1.	3.	The	file	can	be	made	smaller	by	recombining	facets	to	simplify	the	unused	(planar)	surfaces.	Press	Cancel	to	close	the	search	box	and	scroll	down	to	find	the	section	labeled	mesh	generated	in	x	direction:	c.	Repeat	the	process	if	necessary.	
Experimental	uncertainty	You	must	make	some	estimate	of	the	experimental	data	uncertainty	whenever	you	want	to	compare	CFD	results	to	experimental	results.	A	more	thorough	approach	would	spatially	average	the	inlet	and	output	pressures,	but	this	step	is	skipped	here.	This	will	fill	the	entire	domain	to	the	level	of	the	downstream	boundary
condition.	output	time	t	(usually	in	seconds,	refers	to	time	elapsed	in	the	model)	2.	Page	7	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	Preprocessing	the	Simulation	The	FAVORize	process	gave	you	some	good	information,	but	there	is	more	you	want.	The	notch	is	open	from	y	=
-5	to	5	(10	units	wide),	and	begins	at	z	=	12	and	continues	to	the	top	of	the	plate	at	z	=	17	(5	units	tall).	If	no	results	file	is	currently	loaded	you	will	be	prompted	to	select	a	file.	The	image	below	illustrates	the	idea.	Generate	a	table	in	a	spreadsheet	program,	starting	with	the	fastest	velocity	and	working	down,	with	a	header	row,	and	save	it	as	a	.csv
file.	Still	on	the	Meshing	&	Geometry	tab,	open	the	History	Probes	Window	2.	o	Can	all	solids	be	treated	as	having	a	“lumped”	(spatially-uniform)	temperature?	Compare	your	output	to	that	shown	below	at	t	=	3.9E-5	seconds.	SIGNED	ERROR	STANDARD	MEAN	DEVIATION	ERROR	MAGNITUDE	STANDARD	MEAN	±	DEVIATION	2.44	m	~2.3	m
(RMSE)	(1/2	95th	percentile)	NED	(USGS	2003)	-0.32	m	2.42	m	(NED	vs.	0.95	has	been	demonstrated	to	be	accurate	for	buoyant	spheres	(ρS	<	900	kg/m3),	where	the	rising	sphere	exhibits	a	corkscrew	motion	due	to	pressure/buoyancy	effects	that	causes	more	drag;	see	Karamenev	(1992).	Close	the	Global	tree	branch,	then	right-click	Fluid	Regions
and	select	Add	a	Fluid	Region.	Empirical	equations	have	limits	of	validity	that	affect	their	accuracy:	does	the	modeled	situation	match	the	experiments	that	provided	the	data?	Set	Z-Axis	=	99.3	and	Freeze	Page	8	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	Matrix	to	actually	change	the	point
coordinates.	Select	Extrude	Edges	by	Vector	from	the	Extrusion	Tools	toolbar.	X	=	2.98704	for	the	edge	of	the	fine	block,	c.	The	example	problem	is	of	flow	over	a	bench-scale	sharp-crested	weir.	Page	14	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Make	a	Conforming	Mesh	Block	This	exercise
includes	a	lot	of	steps	that	might	not	be	necessary	to	run	the	case,	but	are	meant	to	show	you	your	way	around	the	software.	The	goal	here	is	to	maintain	the	1/3-arcsec	resolution	of	the	source	data.	This	is	because	Hydraulic	Data	is	depth-averaged	along	z,	so	the	Froude	number	includes	the	depth	and	velocity	of	the	pool	beneath	the	nappe.	At	the
right,	under	Additional	Output,	select	the	checkbox	for	Hydraulic	Data	as	shown	below.	Create	a	New	Workspace	1.	The	inter-block	area	fraction	differences	seems	high,	but	most	of	them	misleadingly	apply	to	a	conforming	block	(#4),	while	Block	1	and	Block	2	only	interface	directly	with	each	other	across	the	solid	sides	of	the	weir	plate.	Leave	it
blank,	and	it	will	default	to	Fluid	1	Viscosity,	that	of	water.	Using	these	rules	of	thumb,	the	simplified	size	of	the	output	file	will	be	141	MB	with	30-m	resolution	and	565	MB	with	15-m	resolution.	Check	your	work	by	2-D	plotting	Dynamic	Viscosity	and	Volume	Fraction	of	Entrained	Air	as	contour	variables	using	Selected	data.	Launch	FLOW-3D®,	go
to	the	Simulation	Manager	tab,	and	select	the	Hydraulics	Examples	workspace.	Use	left-click	to	add	a	point	to	the	selection	polygon	and	right-click	to	close	the	polygon.	No	holes	should	be	marked	as	non-manifold	(thanks	to	the	previous	step).	Now	there	is	a	second,	identical	block	on	top	of	the	fine	one.	Add	flux	surface	baffles	for	flow	rate
measurement.	The	second	option	adds	a	link	path	to	the	prepin	file	to	tell	it	where	to	look:	the	.csv	file	is	required	to	stay	with	the	prepin	file,	but	can	have	more	than	500	points.	All	other	boundaries	are	or	Symmetry-type.	There	is	a	limit	to	how	fine	the	mesh	should	be;	beyond	this	limit	(called	the	converged	mesh)	reducing	the	cell	size	does	not
improve	results.	Find	Drag	Coefficients	With	the	correlated	variables	known,	there	are	two	ways	to	find	the	drag	coefficients:			Fit	literature	drag	coefficients	from	empirical	relations	to	the	superficial	equation,	or	Fit	case-specific	experimental	data	to	the	superficial	equation.	Page	3	of	7	FLOW-3D	Version	11	CFD	Project	Overview		Compare	results
from	indicated	implicit	methods	to	results	from	explicit	methods.	Ctrl+Alt+left	click	and	drag	to	add	only	visible	faces	in	the	box	to	the	group.	Epsi	&	Maximum	Pressure	Residual:	The	maximum	residual	is	always	below	epsi,	so	the	pressure	solver	converged	to	a	solution	in	every	time	step.	On	the	Model	Setup:	Numerics	tab	The	numerical	options	in
FLOW-3D	are	intended	for	advanced	users	and	give	significant	control	over	numerical	methods	used	to	solve	the	governing	equations.	Page	11	of	11	Exercise	11:	STL	Topography	from	USGS	Database	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Making	.STL	Files	from	USGS	Data	TABLE	OF	CONTENTS
INTRODUCTION	.............................................................................................................................................	volume	of	fluid	in	the	simulation	domain,	9.	Use	the	Conditional	Vertex	Selection	filter	to	pick	the	facets	that	have	all	three	vertices	above	570.9	m.	Describe	the	selection	of	boundary	conditions	and	their	locations.	Is	geometry	well-resolved?
Zoom	in	very	close	to	the	upper	edge	of	the	blade	and	identify	the	flat	crest	bevel.	Like	flux	surfaces,	the	history	probe	output	is	labeled	with	it’s	name.	If	just	a	few	locations	are	of	interest,	it	is	easier	to	place	History	Probes	before	the	run	and	get	their	output	from	the	Probe	tab.	Create	a	solid	cylinder	subcomponent	with	the	following	dimensions.
Right-click	Mesh	–	Cartesian	and	select	Change	to	Cylindrical	Coordinates.	Statistical	measures	that	will	be	demonstrated	in	this	exercise	include	the	mean	error	(ME),	mean	absolute	error	(MAE),	signed	and	unsigned	minimum	and	maximum	errors	(EMIN,	EMAX,	|EMIN|,	|EMAX|),	standard	deviations	(σE	and	σ|E|),	and	chi-squared	tests	of



continuous	probability	functions	(χ2NORMAL	and	χ2WEIBULL).	X	low	=	-31,	X	high	=	0.3048.	Pre-decimating	the	data	set	after	filling	in	the	empty	regions	gives	additional	speed	improvements.	Try	a	large	turbulence	intensity	(e.g.,	5%)	at	the	boundary	to	see	if	it	has	an	effect.	Plot	the	Mesh.	They	must	be	in	open	areas,	not	solids.	If	you	made
mistakes	rotating	or	translating,	use	the	Transformations	branch.	Set	the	ceilings:	a.	The	Y	mesh	planes	now	need	to	be	shifted	slightly	so	all	distances	are	even	multiples	of	0.16933333	m.		Masch,	F.D.	&	K.J.	Denny.		Report	any	additional	calculated	verification	and	validation	results	(e.g.,	GCI).	Y,	and	coord.	Click	the	Render	button	to	generate	a
series	of	11	plots	between	t	=	0.0	and	1.25	seconds	which	contain	the	weir	and	fluid	surfaces,	with	the	fluid	surface	colored	by	pressure.	Free	for	noncommercia	l	use	only.	Girardeau-Montaut,	D.,	Bey,	A.,	and	Marc,	R.		If	a	fluid	varies	in	density	(e.g.,	due	to	temperature	gradients,	salinity	gradients,	contaminants,	or	entrained	air),	consider	variable
density	physics.	More	frequent	output	can	be	added	as	Selected	data;	the	default	frequency	adds	100	data	sets	(e.g.,	every	1	seconds)	containing	only	the	variables	you	select.	FLOW-3D	will	do	the	math.	If	you	have	any	questions,	please	ask	one	of	your	instructors.	Page	1	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,
Physics,	and	Initial	Conditions	Activate	the	Gravity	Physics	Model	1.	Implicit	solvers	are	iterative,	while	explicit	solvers	are	direct	(one	step).	Terminate	the	simulation:	select	it	in	the	Queue	on	the	Simulation	Manager	tab	and	click	.	1	STEP	2	–	USE	MicroDEM	TO	CONVERT	DATA	TO	POINT-CLOUD	FORMAT	...................................................	Click	OK
to	begin	the	compression	process.	Viscosity	and	turbulence	a.	When	you	are	done,	select	Reset,	then	change	the	Background	to	White,	and	then	click	OK	to	close	the	dialog.	Load	the	Results	File	The	starting	point	for	this	exercise	is	the	output	generated	at	the	end	of	Exercise	4.	Page	9	of	11	FLOW-3D	Version	11	Simulation	Setup	On	the	Model	Setup:
Output	tab		Choose	the	basis	for	output	frequency	(time,	fill,	or	solidified	fraction)		Choose	additional	output	of	interest		Choose	selected	data	to	output	more	frequently		Define	output	intervals	for	all	data	types	The	default	intervals	are	fractions	of	the	finish	time:	data	and	for	restart	and	long	print	for	selected,	history,	and	short	print	data.	Locate	the
Momentum	Advection	options	on	the	righthand	side.	An	“ideal”	solution	maintains	res/epsi	less	than	one	at	all	times.	The	pressure	in	the	simulation	can	either	be	gauge	(atmospheric	pressure	=	0)	or	absolute	(atmospheric	pressure	~	101	kPa).	The	initial	fluid	pressure	(the	color	variable)	and	velocity	(the	vectors)	are	shown.	4	On	the	Model	Setup:
Physics	tab	..................................................................................................................	The	remainder	of	the	exercise	will	use	MiddleRioGrande_MLASCtxt.xyz.	Perform	one	by	reducing	all	cell	sizes	by	2x,	running,	and	repeating	until	Q	varies	less	than	2	–	3%.	Simplify	unnecessary	regions	to	reduce	file	size.	Fluid	Elevation	=	1.5	m.	For	each	step:	a.	Page
4	of	10	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	Now	add	Component	Properties	to	the	Piston	and	Dirt	components:	2.	The	GMO	location	is	always	output	in	any	time	step,	so	adding	any	Selected	Data	will	give	101	GMO	visualizations.	This	reduces	the	active	cell	count,	and	makes	the	simulation	faster.	Get
precise	magnitude	statistics	and	map	them	into	color.	Time:	Click	and	drag	the	Left	(Min)	Time	Frame	Slider	so	that	Min	=	0	and	Max	=	1.25	seconds.	Page	12	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	3.	Then	double-click	the	object	to	select	it	with	edges.	Do	the	results	look	right?	Using
what	you	already	know,	Open	the	results	file	and	analyze	the	flow	in	2-D.		Translate	the	mass-momentum	source	to	the	desired	location	in	the	domain.	You	could	launch	a	Restart	Simulation	from	the	end	of	this	one	to	see	if	TKE	levels	off	later,	or	maybe	it’s	just	because	of	the	splashing	on	the	topography	under	the	nappe.	Save	your	work!	Page	3	of	21
Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	The	settings	shown	above	define	the	three	mesh	blocks	that	appear	on	the	next	page.	Add	a	new	simulation	called	Air	Entrainment	Scalar.	Y	=	-1.524	and	Y	=	1.524	for	the	weir	corners.	Go	to	the	Model	Setup	>	Numerics	tab.	19.	Set	the	upstream	boundary:
a.	Navigate	to	the	Model	Setup	>	Output	tab.	Type	/2	or	*2	after	each	value	in	the	highlighted	inputs	below.	Select	z-minimum	elevation.	All	the	reported	warnings	involve	Block	4,	which	has	the	same	extents	as	Block	3	but	only	half	the	resolution.	Practice	what	you	remember	from	the	first	exercise.	Repeat	b	through	d	to	put	a	second	plane	at	X	=
-0.03048	(the	weir)	in	Block	1.	The	degree	of	friction	appearing	in	the	model	depends	on	the	water	velocity,	the	roughness	height	of	the	component,	and	the	mesh	resolution	near	the	bed.	The	unspecified	limits	default	to	the	domain	extents.	The	value	entered	is	correct	for	clear	water	at	20°C	and	standard	pressure.	You	have	already	set	the	unit
system,	so	the	only	units	available	are	SI.	Holes	can	only	be	made	as	subcomponents.	Select	the	model	by	clicking	it,	then	right-click	and	select	Unlock	from	the	context	menu.	tool	(see	Figure	7.	Click	to	highlight	the	Hydraulics	Examples	>	Weir	Finish	simulation	that	you	ran.	The	pressure	loss	∆P	across	the	media	is	determined	by	subtracting	the
outlet	pressure	(I	=	2,	K	=	2)	from	the	inlet	pressure	(I	=	2,	K	=	22)	at	each	output	time.	Do	the	results	follow	the	expected	trends?	Are	geometry	files	checked	and	repaired	and	well-resolved	by	the	mesh?	Note	at	the	bottom	of	the	screen	that	the	number	of	vertices	(points)	is	15,010,488,	as	before.	Page	6	of	16	Water	&	Environment	Training	on
FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Figure	9.	Mesh	dependent	data:	time-dependent	parameters	computed	at	mesh	boundaries.	Check	the	Maximum	Aspect	Ratios	(ZY,	YZ,	and	ZX):	they	are	<	3.	If	yes,	decide	which	turbulence	model	to	use,	estimate	the	roughness	Reynolds	number	k+,	and	decide	if	surfaces	should	be	hydraulically
smooth	(ROUGH	=	0)	or	rough	(ROUGH	>	0).	The	solids	will	appear	in	post-processing.	Select	Options	=	Activate	Plain	Streamline	Seeding.	o	Cons:	Must	assume	axially	and	radially	symmetric	flow	about	z-axis.	QV,AIR	=	FPSCL1	=	78	cm3	air/s.	Groundwater.	All	automated	triangulation	algorithms	create	minor	errors:	disconnected	edges	between
triangles,	missing	triangles	(holes),	and	reversed	or	incorrectly-computed	facet	normal	vectors.		Compare	the	results	against	the	default	1st-order	method,	and	if	the	results	are	significantly	different	use	the	higher-order	method.	This	value	was	entered	on	the	Air	Entrainment	physics	dialog,	and	changes	made	here	will	change	the	value	there.	Move
the	slider	so	that	it	is	located	at	the	minimum	X	value	-6.0655	m.		Go	through	the	list	of	Component	Properties	for	each	component	and	identify	the	available	selections.	The	velocity	of	the	water	falling	under	gravity	though	a	distance	H	of	2.7	m	(the	drop	height)	is	V	=	(2	g	H)1/2	=	(2*9.81	m/s2*2.7	m)1/2	=	7.3	m/s.	This	is	the	x-min	mesh	plane	of	the
downstream	block	and	the	x-max	mesh	plane	of	the	upstream	block.	Add	the	hole	subcomponent.	Fix	the	normals	with	qAdmesh	and	save	the	output.	Activate	Signed	Distances	under	Precise	Results	and	Compute	the	error	to	map	it	into	the	scalar	field	of	the	point	cloud.	in	the	lower-right	corner.	Select	Add	.	The	total	adjustment	is	less	than	0.06%	of
the	total	volume:	an	insignificant	loss	of	accuracy	for	a	probable	efficiency	gain.	Deactivate	Signed	Distances	and	click	Compute.	Even	at	t	=	0.35	and	0.7	seconds	you	can	still	see	where	the	recirculating	pool	flow	accelerates	from	the	downward	direction	to	the	horizontal	direction	as	it’s	caught	by	the	pipe	discharge.	Figure	2:	Experimental	head	loss
vs.	Click	and	hold	the	middle-mouse	button	or	wheel	while	moving	the	mouse	vertically,	or	rotate	the	wheel,	to	zoom.	Plot	all	4	mesh	blocks.	Extents	(limits)	can	be	applied	both	in	space	and	in	time.	Use	netfabb	Basic	for	repair	&	format	conversion.	Select	Specified	Velocity	as	the	Boundary	Type.	This	step	is	sometimes	called	solution	verification	and
is	discussed	at	length	in	ASME	(2009)	and	(ASCE)	2009.	Scale	model	LiDAR	data	DETAILED	EXAMPLE	OF	THE	BASIC	PROCESS	We’ll	follow	the	basic	process	outlined	above.	To	do	this,	each	velocity	must	be	held	constant	long	enough	for	the	results	to	become	steady.	This	is	a	general	guideline,	and	not	always	appropriate.	Page	3	of	24	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	8.	Review	the	results	as	before,	but	use	Auto	contour	limits	this	time.	1–	this	value	is	the	irreducible	minimum	air	permitted	in	a	cell.	Enter	the	values	shown	below	and	click	OK.		Pressure	type	boundaries	are	appropriate	when	the	flow	is
subcritical.	Check	the	assumption	that	flow	in	the	media	will	be	laminar:	as	will	be	calculated	below,	the	pore	Reynolds	numbers	(Reynolds	number	within	a	pore	of	the	media)	will	be	less	than	40.	The	most	useful	plane	to	view	results	for	this	simulation	is	the	centerline	of	the	weir.	Page	14	of	16	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	2:	Setting	Up	Geometry	4.	They	are	related	by	density	ρ	and	gravity	g:	Figure	2	and	Table	2,	below,	show	the	experimental	head	loss	data	(∆H/∆x),	digitized	using	EnGauge	freeware,	and	the	calculation	of	unit	pressure	loss	(∆P/∆x)	for	use	in	the	coefficient	fitting	equations.	Page	4	of	24	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	Mesh	Planes	(user-specified	grid	lines)	are	displayed	in	a	different	color	and/or	weight	than	the	regular	Grid	Lines,	which	are	generated	automatically	by	FLOW-3D.		Define	the	mesh		Following	your	diagram,	create	the	mesh	blocks	and	specify	their	extents.	Set	Direction	=	Y	and	add	two
planes:	Y	=	-1.524	and	Y	=	1.524	for	the	blade	corners.	Set	the	Output	type	=	Binary	STL,	and	name	the	output	file	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833_admesh.stl.		Drag	Coefficient	is	the	fully-turbulent	limit	of	the	drag	coefficient	CD.	Notes:	1)	Tested	on	Intel	Core	i7-3930K	3.20	GHz	CPU	w/	16.0	GB	RAM,	Windows	7
Professional	64-bit	OS	2)	MiddleRioGrande.txt,	courtesy	of	Colorado	State	University	and	US	Bureau	of	Reclamation.	5	On	the	Model	Setup:	Meshing	&	Geometry	tab	...........................................................................................	See	the	Tech	Note	for	the	full	equation.	Page	4	of	11	FLOW-3D	Version	11	Simulation	Setup		Define	the	finish	condition(s)	Set
the	finish	time.	For	presentations	it	would	be	helpful	to	show	both	halves	of	the	weir	and	explain	the	assumption	of	symmetric	flow.	Finally,	add	two	planes	in	Direction	=	Z:	Z	=	1	to	match	the	channel	bed,	and	Z	=	3.6576	to	match	the	weir	crest.	It	tends	to	diffuse	momentum	(and	kinetic	energy)	when	the	flow	is	curving.	Page	11	of	11	Exercise	1:
Running	&	Post-Processing	an	Example	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	Exercise	1:	Running	&	Post-Processing	an	Example	In	this	exercise,	you	will	learn	how	to	use	FLOW-3D®	and	its	native	post-processor	to:	1.		Note	the	rationale	for	each	initial	condition,	including
default	values.	Save	your	work	after	each	operation:	there	is	no	Undo	command	in	MeshLab!	Select	File	>	Export	Mesh	and	save	the	cleaned	data	in	.xyz	format	with	no	normals	as	MiddleRioGrande_MLASCtxt_clean.xyz.	These	will	deactivate	cells	even	if	heat	transfer	is	on.	This	note	adds	instructions	for	data	sets	from	the	U.S.	Geological	Survey
(USGS)	National	Elevation	Dataset	(NED).	Esc	to	toggle	between	navigation	mode	and	the	selection	tool.	Recombine	the	bounding	surface	facets	to	reduce	them	by	90%	Page	11	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	STEP	8	–	DELETE	NON-MANIFOLD	VERTICES	Select	Render	>	Show	Non-
Manifold	Vertices	to	mark	vertices	with	connecting	facets	that	do	not	adjoin	perfectly.	Are	the	active	physics	models	appropriate?	View	the	geometry	and	mesh,	3.	Only	available	on	the	Probe	sub-tab.	Plot	limits	can	be	applied	both	spatially	and	in	time.	Set	the	Mesh	Block	=	1	and	the	Direction	=	X.	Right-click	the	selection	and	select	Intersect	Faces
>	With	Selection.	Therefore	select	the	Permeability	Dependent	Saturated	Drag	model,	which	is	accurate	for	the	D’Arcian	region	and	outside	of	it.	Page	9	of	10	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	There	are	a	few	viscous	stress	iteration	failures,	but	they	are	not	consecutive	and,	unlike	pressure	iteration
failures,	they	do	not	affect	the	time	step	dt.	Figure	4.	The	default	name	for	animations	is	out.avi.	Examples	include	integrations	over	the	whole	domain,	over	a	solid	surface,	or	over	the	plane	of	a	baffle.	One	way	to	use	the	air	entrainment	model	is	to	find	a	mesh	that	you	can	live	with	and	then	use	it	to	model	a	known	air	entrainment	experiment	with
similar	Reynolds	and	Froude	numbers	as	the	target	model.	All	cells	should	show	values	with	no	white	space.	At	t	=	0.03	seconds,	a	packet	of	fluid	tried	to	move	more	than	one	cell	at	a	time.	Surface	Tension	physics	can	be	used	outside	of	porous	media	where	there	are	free-surfaces.		Check	for	trends	This	helps	reduce	the	amount	of	guesswork	that
goes	into	selecting	the	next	calibration	value.	Bos	(1989)	and	others	recommend	bevel	thickness	between	1	and	2	mm	(0.03	to	0.08	feet).	Converts	whole	file	into	some	memory.	Note	that	initial	Velocities,	Pressure,	and	Turbulent	Kinetic	Energy	can	also	be	specified,	but	do	not	need	to	be	here.	Select	Tools	>	Options	from	the	menu	above	the	display
pane.	Set	Global	=	0.3048	to	scale	the	subcomponent	to	meters.	The	GDAL	library	can	be	downloaded	from	and	must	be	installed	and	included	in	the	PATH	environment	variable	before	running	the	scripts.	Page	4	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	Figure	3:	Volumetric	fraction	of	entrained	air	and	jump
shape	at	3	seconds	as	a	function	of	upstream	boundary	turbulence	(top	to	bottom:	kT	=	80,	660,	4400	cm2/s2,	εT	=	140,	3600,	61500	cm2/s3)	Page	5	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	Problem	Specification	(Run	1:	Scalar	Air	Entrainment)	General,	Physical,	and	Numeric	Specifications	o	Simulation
name:	Air	Entrainment	Scalar	o	Simulation	units	=	CGS	o	Simulation	time	=	5.0	seconds	o	Number	of	processors	=	2	o	Initial	time	step	=	none	needed	Physics	o	Air	Entrainment		rate	coefficient	=	0.5,		surface	tension	coefficient	=	73,		air	density	=	1.2E-3	g/cm3,	o	Gravity		gx	=	97.5136	cm/s2,		gz	=	-	975.136	cm/s2,	o	Viscosity	&	Turbulence		viscous
flow,		renormalized	group	(RNG)	turbulence	model,		dynamically-computed	TLEN	Fluid	Properties	(generic	properties	for	water)	o	Density	ρ	=	1.0	g/cm3	o	Viscosity	μ	=	0.01	poise	(i.e.	g/cm/s)	o	Compressibility	=	1/(ρ	w2)	=	4.653E-11	cm-s2/gm	Output	o	Additional	Output	=	Hydraulic	Data	o	Selected	data	at	1%	time	intervals		dynamic	viscosity	
hydraulic	data	(add	to	Additional	Output)		volume	fraction	of	entrained	air	Geometry,	Initial,	and	Boundary	Specifications	o	No	geometry.	Specify	the	boundaries	as	follows:	10.	View	layers.	Click	the	Mesh	Block	button	at	the	lower	right	and	select	Mesh	Block	4	only.	You	can	toggle	the	axis	and	control	its	location	by	selecting	the	options	in	View	>
Draw	Axis	on	the	toolbar	menu	above	the	view	pane.	o	Check	Mesh	Information	for	each	block,	especially	total	number	of	cells,	maximum	adjacent	cell	size	ratio,	and	maximum	aspect	ratios.	It	is	easy	to	show	that	θ	is	also	the	angle	between	gravity	and	the	vector	normal	to	the	flow	direction.	Convert	the	.stl	to	binary	format.		Define	particle	counting
bins	for	sampling	volumes	(see	flux	surfaces	section	above).	Define	components	so	that	all	their	subcomponents	share	the	same	material	properties	(e.g.,	surface,	solid,	and	motion	properties).	The	Clustered	Vertex	cubic	grid	method	tends	to	concentrate	points	near	contour	lines	(see	Figure	10	below).	Mesh	Planes	should	always	be	used	to	match
nested	and	overlapping	block	extents.	Page	9	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	3.	Figure	13.	Fixing	and	converting	the	format	of	the	.stl	is	always	required.	Use	the	Transparency	slider	to	increase	transparency	until	you	can	see	the	blade	edge.	Choose	the	X-Z	radio	button	in	the	Plane	group	and	set
both	of	the	Y	Limits	sliders	=	0.25	cm,	which	is	Page	21	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	the	location	of	the	cell	centers	closest	to	the	centerline	at	Y	=	0.	11	STEP	8	–	DELETE	NON-MANIFOLD	VERTICES	..............................................................................................
Recommended	MicroDEM	Save	options	If	you	are	computer-savvy	you	can	choose	to	download	.bat	scripts	from	USGS	instead	of	using	MicroDEM.	The	min	and	max	values	reported	are	the	inverse	of	the	min	and	max	z-elevations	(97.2	and	99.3	feet)	because	the	quality	was	set	to	the	negative	of	z-elevation.	FLOW-3D	includes	databases	of	solid	and
fluid	properties	for	a	number	of	materials.	The	preprocessed	simulation	results	should	give	you	a	good	idea	of	how	the	run	will	start.	Follow	the	steps	below	to	install	it.	Note	that	the	units	are	still	incorrectly	reported	as	g/s:	when	baffle	scalar	flux	FPSCL1	is	entrained	air	its	units	are	cm3/s.	Right-click	Mesh	Block	3:	FINER	WEIR	BLOCK	and	select
Copy…	Keep	Translations	=	0	and	click	OK.	On	the	Model	Setup:	General	tab		Add	some	notes	Notes	help	explain	what	was	done	and	why	for	future	users	or	for	later	reference.	Each	line	gives:	1.	Pan	and	zoom	to	view	the	weir.	Make	a	copy	of	Air	Entrainment	Density	and	name	it	Air	Entrainment	DriftFlux.	Typical	quantities	are	flow	rate	and	fluid
height.	Solver	Messages:	convective	flux	exceeded	stability	limit	at	t=	3.0009E-02	cycle=	1	iter=	51	delt=	3.0009E-02	mesh	block	4	restarting	cycle	with	smaller	time	step	maximum	failure	ratio	=	2.26944E+00	is	in	x-coordinate	direction	at	cell	(	82,	34,	17)	mesh	block	4	3.	Practice:	make	a	Copy	of	both	holes	by	right-clicking	either	the	tree	or	the
shape.	See	User	Manual	>	Troubleshooting	for	more	information	on	adjusting	numerical	methods	for	specific	problems.	If	yes,	consider	using	shallow	water	physics	in	one	or	more	mesh	blocks		Does	a	fluid	have	a	sharply-defined	interface	(free	surface)?	Subtract	the	internal	angle	from	90°	to	find	the	external	angle	=	~	66°.	Render	the	streamlines
and	adjust	the	display	(global	and	streamline-entity)	as	before.	Load	the	file	on	the	Simulation	Manager	tab:	a.	Launch	FLOW-3D®,	go	to	the	Simulation	Manager	tab,	and	right-click	the	Hydraulics	Examples	>	Weir	Mesh	simulation	that	you	just	finished.	Global	>	Void	Initial	State	>	Pressure	=	0	g/cm/s2	Page	8	of	10	Water	&	Environment	Training
on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	Set	Output	Options	The	default	output	rates	are	acceptable.	Open	the	Air	Entrainment	physics	dialog.	Page	6	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	X-min	=	0	cm	Boundary	=	Velocity	U	=	210	cm/s	FSE	=	5	cm	TKE	=	16	cm2/s2	DTKE	=	30	cm2/s3	z	X-
Direction	Total	Cells	=	200	Y-Direction	Total	Cells	=	1	Z-Direction	Total	Cells	=	30	Y-min	=	0,	Y-max	=	1	Z-max	=	15	cm	X-max	=	100	cm	Boundary	=	Wall	X-Low2	=	40	cm	Z-Low2	=	5	cm	U2	=	0	cm/s	Boundary	=	Stagna.	Save	and	Run	Simulation.	Additional	information	such	as	velocity	vectors,	particles	(if	present),	and	streamlines	can	be	added.
Take	multiple	readings	to	estimate	the	uncertainty	of	your	mouse	location.	Now	take	a	look	at	the	Pressure	Iteration	Count	plot.		Check	sensitivity	to	the	momentum	advection	method	Higher-order	momentum	advection	methods	are	generally	more	accurate,	but	may	be	less	stable	and/or	generate	more	noise	in	the	solution.	The	image	above	on	the
right	shows	the	weir	structure.	Several	of	these	approaches	are	incorporated	into	FLOW-3D	as	Porous	Media	physics	options.	Right-click	the	model	again	and	select	Explode.	Finally,	note	that	the	upstream	depth	(as	shown	for	Fluid	Depth	and	Free	Surface	Elevation)	does	not	vary	much.	Keep	Create	subdirectory	using	workspace	name	checked	so
that	the	workspace	and	all	its	simulations	will	be	under	the	same	directory.	So	what	is	the	measure	of	“amount”	for	the	scalar	Air	Entrainment	model?	You	may	need	to	adjust	transparency	and/or	rotate	the	view	to	see	the	piston	inside	the	cavity.	Because	fitting	experimental	data	to	empirical	equations	is	a	detailed	process,	it	is	important	to	first
identify	the	model	which	best	represents	the	physical	case.	The	experiment	consisted	of	recirculating	clean	water	through	parallel	columns	of	packed	media	and	measuring	head	loss	vs.	Right-click	in	the	folder	and	select	New	>	Folder	to	create	a	third	folder.	Select	the	Segment	tool	from	the	menu	bar	to	cut	out	the	region	of	interest.	Page	2	of	13
Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	1.	The	air	now	rises	to	the	surface,	but	cannot	leave	the	water,	even	at	free	surfaces	(a	limitation	that	will	be	addressed	in	the	next	run).	Three-dimensionalize	the	terrain.	The	correct	value	should	be	Page	11	of	13	Water	&	Environment	Training	on
FLOW-3D	v11	Exercise	6:	Air	Entrainment	some	small	number	that	reflects	the	thin	film	of	water	between	bubbles,	but	this	value	is	not	known,	so	use	0	as	a	reasonable	approximation.	Identify	the	relative	error	as	e	=	(QCFD	–	Qphysical)/Qphysical.	Click	to	check	the	Enabled	box	to	activate	the	first	source.	Fluid	1	Surface	Area:	the	water	surface
area	comes	to	quasi-steady	state	around	10	seconds.	If	you	have	not	successfully	completed	Exercise	3,	you	may	download	or	copy	the	file	prepin.Weir_Mesh_Completed	and	the	geometry	files	to	a	new	simulation	folder	and	import	it	as	an	existing	simulation.	The	bottom	of	the	part	should	now	be	closed	(Figure	14	below).	The	resulting	histogram
contains	all	the	information	that	has	already	been	determined:	the	maximum	and	minimum	errors	are	the	ends	of	the	abscissa,	and	the	mean	and	standard	deviation	are	summarized	(and	rounded)	above	the	chart.	It	is	included	here	because	it	results	in	95%	and	standard-deviation	confidence	intervals	which	are	more	defensible	than	simple	error
comparisons.	Page	7	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	Figure	5.		Estimate	the	Weber	number.	Close	the	dialog	and	repeat	for	Mesh	Block	2	and	Mesh	Block	3.	Repair	data	for	TOPO2STL	output	of	pre-cleaned,	pre-filled,	and	pre-decimated	point	sets	SPATIAL	RESOLUTION	¼-inch	(0.0208
feet)	qAdmesh	repair	netfabb	Basic	repair	MeshLab	simplification	&	repair	w/	qAdmesh	finish	1E5	target	facets/	Fixed:	4	vertices,	1	hole,	21618	normals/	1	shell	output/	Too	many	facets	to	fix	in	qAdmesh	and	951	MB	binary	.stl	netfabb	Basic	without	prior	simplification.	Ignore	this	message	(click	OK	to	close	it)	and	repeat	the	process	by	re-launching
the	tool.	A	dialog	will	appear	allowing	the	animation	to	be	named.	Unreliable.	3)	“Enwiki9.txt”,	courtesy	of	Matt	Mahoney	and	the	Large	Text	Compression	Benchmark	project	(	accessed	Nov	19,	2012).	Velocity	vectors	and	particles	(if	present)	can	be	displayed.	Then	highlight	Subcomponent	1	and	Subcomponent	3	to	see	the	solid	part	of	the
geometry.	Use	the	Select	Non-Manifold	Vertices	filter	to	select	and	then	delete	these.	You're	Reading	a	Free	Preview	Pages	61	to	76	are	not	shown	in	this	preview.	This	is	one	criterion	for	steady-state.	o	All	solid	cross-sections	should	be	resolved	by	at	least	2	or	3	cells.	Go	back	to	the	Model	Setup	>	Meshing	&	Geometry	tab	and	open	the
Mass/Momentum	Source	Window	.	Arrange	them	as	shown	in	Figure	2.	Multiplier	for	Convergence	Criteria	EPSVIS	=	0.9	5.	Note	the	negative	values	mean	the	velocity	vector	is	pointing	toward	the	z-min	boundary.	The	model	will	take	even	longer	to	run	than	the	last	one,	due	again	to	the	added	physics.	The	tank	will	primarily	be	defined	using	the
mesh	boundaries,	but	the	filling	tube	and	valve	will	be	components.	Recommended	filters	include	Poisson-disk	subsampling	for	predecimation	and	quadric	edge	collapse	decimation	for	post-conditioning	simplification.	Select	Render	in	the	lower	right	corner	of	the	screen.	Check	the	Maximum	Adjacent	Cell	Size	Ratios	(X,	Y,	and	Z):	they	are	close	to	1
and	<	1.25.	Page	2	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	c.		Record	values	their	rationales/sources/citations	As	before,	note	any	values	on	the	diagram	that	you	are	uncertain	of.	This	indicates	very	minor	head	loss	due	to	friction.	staff	gauge:	flow	depth	(around	#14).	Return	to	the	Analyze	>	3-D	tab
and	select	the	Global	radio	buttons	under	Contour	Limits.	Therefore	the	liquid	flow	rate	through	the	plane	QV,WATER	=	1055	cm3	water/s.		Draw	the	axes.	Set	the	color	saturation	maximum	slider	value	box	=	0.06	feet.	Subscripts	A	and	E	are	energy	added	or	removed	by	hydraulic	machinery,	f	is	the	energy	lost	due	to	friction,	and	1	and	2	are	two
points	along	a	streamline.	If	in	doubt,	skip	this	step.	Physical	test	data	may	be	scaled	incorrectly,	especially	for	turbulent	effects.	It	should	complete	within	a	few	seconds,	and	a	message	will	appear	in	the	Solver	text	indicating	“Preprocessor	Done”.		Draw	the	computational	domain	on	the	diagram	Computational	domains	(mesh	blocks)	are	3-D
rectilinear	or	axisymmetric	cylindrical	wedges.	Leave	the	Create	Subdirectory	Using	Simulation	Name	checked	to	keep	files	organized.	The	starting	point	for	this	exercise	is	the	simulation	created	in	Exercise	3.	13th	International	Water	Technology	Conference:	Hurghada,	Egypt.	When	the	maximum	residual	is	much	lower	than	epsi,	it	means	that	the
solution	is	converging	very	quickly	(the	solution	is	“easy”).	are	the	vertex	Cartesian	coordinates	(single	precision	float)	and	may	not	be	negative.	An	Experimental	Model	for	Flow	Through	Porous	Media	Using	Water	Filter.	FLOW-3D	uses	a	smooth	function	that	gives	Stokes	settling	in	the	laminar	regime	and	drag	defined	by	CD	in	the	fully	turbulent
regime.	Page	16	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Analyze	2-D	Results	1.	Run	the	simulation:	it	should	take	minutes	or	less.	Page	25	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	APPENDIX	C	–	A	BRIEF	GUIDE	TO	KEYBOARD	AND	MOUSE
COMMANDS	IN	MESHLAB	Navigation	commands										Left	click	and	drag	to	rotate	the	part	and	coordinate	system	around	the	trackball	center.	Enter	Xaxis	=	1	for	translation	and	repeatedly	click	Apply	until	the	grid	has	shifted	so	that	it	just	encloses	the	point	cloud	extents.		If	all	of	the	above	considerations	have	been	checked	carefully	and	the
problem	is	not	resolved,	refer	to	the	User	Manual	>	Troubleshooting	chapter.	If	the	line	terminates	at	a	free	surface,	try	a	different	starting	location.	Enter	Size	of	Cells	as	shown	below.	Load	Fluid	Properties	from	the	Fluids	Database	Thus	far,	we	have	not	specified	which	fluid	we	want	to	model.	1958.	Select	All	the	points	in	the	topography	layer	and
use	the	Vertex	Attribute	Transfer	filter,	with	Transfer	Radius	as	close	to	290	m	as	possible.	Right-click	the	Streamlines	entity	there	to	get	display	options.	Repair	the	part.	Open	and	view	the	point	cloud	in	MeshLab.	Ideally	the	time	step	dt	is	the	same	as	the	stability	limit	but	it	may	be	smaller	when	there	are	too	many	pressure	iterations	or	a	stability
limit	is	unexpectedly	exceeded	(e.g.,	due	to	splashing).	Shift+mouse	wheel	to	change	camera	field-of-view.	These	are	two	more	indicators	of	the	steadiness	of	the	flow.	The	holes	will	only	be	“drilled”	through	the	weir	plate	(Component	1).	Z	low	=	undefined,	Z	high	=	0.002	cm	2.	Does	the	test	case	have	similar	physical	and	time	scales	as	the	case	of
interest?	When	the	compression	is	complete,	the	following	dialog	will	appear.	Sphere	outer	radius	=	0.001	2.	Select	the	point	cloud	layer	and	run	the	Tools	>	Statistics	>	Compute	Stat.	Cells	that	do	not	have	any	original	points	in	them	are	assigned	a	coordinate	based	on	the	elevations	of	the	points	in	nearby	cells.	Select	the	Analyze	tab.	There	is	air
above	the	print	head,	liquid	ink	inside	it,	and	a	solid	object	in	the	ink.	They	are	at	the	four	lower	corners	of	the	box.	If	yes,	consider	uniform	component	temperatures.	Make	a	new	project	folder:	a.	Visualize	and	check	the	data.	Nield.	c.	Some	errors	report	additional	information	to	the	Solver	Errors	file,	so	it	should	always	be	checked.	This	particular
data	set	contains	a	highly	precise	measurement	record.	TOPO2STL	and	other	converters	create	artifacts	in	the	output.	Page	3	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	2.	There	are	two	types	of	solvers:	implicit	and	explicit.	Zoom	and	pan	the	view	so	the	crest	fills	the	screen	as	shown
below.	∆P/∆x	is	the	pressure	loss	per	unit	distance	traveled	superficially,	ρ	is	fluid	density,	and	μ	is	the	fluid	dynamic	viscosity.	Mass/momentum	sources	are	ideal	when	fluid	must	be	added	somewhere	inside	the	domain.	Compare	the	coefficients	from	both	options:	Empirical	Correlations	Without	Experimental	Data	The	Ergun	(1952)	equation	for
packed	spheres	and	a	relation	for	crushed	angular	materials	(sand)	by	Idelchik	(1986)	are	plotted	below	along	with	the	experimental	data.	2)	Non-cubic	cells	should	be	shortest	in	the	direction	of	the	greatest	gradient.		Freeze,	R.A.	&	J.A.	Cherry.	In	the	upper	left	corner,	enter	Finish	Time	=	35	seconds.	Use	the	Transparency	slider	above	the	view	pane
to	set	transparency	to	about	75%	so	you	can	see	the	cylinder.	It	helps	you	keep	track	of	your	progress,	revert	to	earlier	data	states,	and	compare	different	stages	and	approaches.	Although	all	sub-tabs	are	available,	typically	only	2-D	and	3-D	plots	are	necessary	to	check	the	model	setup.	We	should	include	viscosity	at	the	least	so	that	wall	effects	are
not	neglected.	Stagnation	pressure	is	required	for	upstream	pressure	boundaries,	because	it	is	stable.	Select	the	X-Z	radio	button	in	the	Plane	group.	Select	Domain	Removing	as	the	Type.	Under	SF	Scale,	slide	the	displayed	minimum	slider	all	the	way	to	the	right	(or	set	the	minimum	value	box	to	the	same	as	the	maximum).	3-D:	Both	fluid	and	solid
surfaces	can	be	visualized	together	or	separately.		Check	that	the	initial	conditions	are	good	approximations	of	reality.	Select	Extras	>	Repair	Part.	The	simulation	will	run	more	slowly	with	the	added	physics,	but	will	still	finish	quickly	due	to	the	small	number	of	cells	(6000	total).		Define	locations	and	coupled	motion	parameters	for	history	probes.
The	transformations	will	be	applied	in	the	order	just	described.	Two	methods	are	introduced.	Check	your	work	against	the	image	below.	Find	the	maximum	error	magnitude.	Select	the	General	History	radio	button	under	Data	Source.	When	the	fraction	is	higher	the	mixture	should	include	bulking	and	density	effects.	Select	Filters	>	Create	New	Mesh
Layer	>	Mesh	Generator.	Normals	before	(left)	and	after	(right)	Use	the	Recompute	Face	Normals	and	Normalize	Face	Normals	filters.	Page	8	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	The	Scalar	model	should	only	be	used	without	Density	Evaluation	physics	when	the	volume	of	air	is	less	than	1%	or	2%.	Page
20	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	8.	Becomes	briefly	unresponsive	during	scrolling	operations	due	to	piecewise	loading	method.	There	is	no	Temperature	Unit,	and	none	are	needed	since	there	are	no	Heat	Transfer	physics	models	activated	on	the	Physics	tab.
Download	and	install	the	latest	version	from	.	Select	Automatic	Repair	at	the	bottom	of	the	Context	Area.	o	If	necessary	to	get	these	resolutions,	add	mesh	planes,	mesh	plane	cell	counts,	and	mesh	plane	cell	sizes.	The	disagreement	is	about	13%.	Select	Fraction	of	Fluid	to	plot	the	fluid	free	surface.	Note	that	the	new	box	has	been	added	as
Subcomponent	2:	the	subcomponents	are	numbered	in	the	order	they	appear	in	the	tree,	regardless	of	which	component	they	are	part	of.	Move	the	mouse	over	the	plot	to	find	that	the	time	step	size	oscillates	about	0.005	seconds	per	step.	Set	the	Min	Time	Slider	all	the	way	to	the	left	(t=0.0)	8.	Note	before	you	save	that	there	is	an	asterisk	following
the	simulation	title	at	the	very	top	title	bar	of	the	screen.		Define	domain-removing	components	to	block	off	open	regions	where	flow	will	never	occur,	and	where	the	open	void	does	not	need	to	vent	to	a	boundary	condition.	Go	to	the	Model	Setup	>	General	tab.	Activate	Centered	On	Origin,	and	click	Apply.	(2012).	In	the	author’s	experience,	all	CAD
packages	always	add	errors	and	artifacts	during	.stl	creation.	This	is	output	from	the	Flux	Surface	you	put	at	the	weir.	The	3-D	FAVORize	view	is	not	precise	because	the	iso-surface	fitting	is	imperfect	and	approximate.	Activate	Strict	Face	Selection	to	avoid	picking	up	any	river	data.	For	best	accuracy,	set	Octree	Depth	=	9	or	10.	superficial	velocity
Page	6	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	SUPER.	These	particles	are	used	to	define	the	Mass/Momentum	sources	in	the	pipes	(as	point	fluid	sources)	and	do	not	move	with	the	flow.	The	completed	diagram	should	be	an	sketch	of	the	physical	problem	that	includes	all	of	the	relevant	engineering
information.		Idelchik,	I.E.	1986.	The	fluid	surface	can	be	colored	by	flow	quantities,	which	show	the	state	at	that	surface.	Unlock	the	terrain	model	in	SketchUp.	Page	3	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	Figure	5.	Deactivate	empty	cells	with	domain	removing	components	to
improve	simulation	speed,	and	7.	Surface	tension	coefficient	=	73	g/s2	ii.	In	this	case,	halving	the	cell	sizes	in	each	direction	twice	for	a	total	of	three	runs	on	three	meshes	changes	the	time-average	air	concentration	from	6.6%	to	9.8%	and	then	to	4.0%.	Handbook	of	Hydraulic	Resistance.	Assuming	a	2x	safety	factor	for	pressure,	the	table	of	time	and
velocity	values	looks	like	this:	POROUS	MEDIA	LENGTH:	MODEL	DOMAIN	LENGTH:	STEADY	STATE	TIME	MULTIPLE:	0.300	0.324	2	m	m	SUPER.	Try	giving	the	solver	more	overhead	to	converge:	go	to	Numerics	>	Pressure	Solver	Convergence	Controls	and	set	Minimum	Number	of	Iterations	ITMIN	=	2,	Maximum	Number	of	Iterations	ITMAX	=
500,	and	GMRES	Subspace	Size	MRSTRT	=	50.		Flow	Science.	Check	to	see	if	there	are	any	FAVOR	issues;	there	should	be	none.	The	flow	may	be	turbulent	at	the	maximum	velocity,	but	will	be	laminar	at	lower	velocities.	Import	an	existing	simulation,	2.	A	common	checklist	is	given	below.	Select	Add	Simulation	Copy…	2.	Compare	Estimates	of
Upstream	Turbulent	Kinetic	Energy	and	Dissipation	Boundary	conditions	have	zero	turbulent	kinetic	energy	(TKE)	by	default.	Importing	the	data	as	file	type	.asc	works	correctly	but	importing	as	.xyz	type	produces	an	incorrect	extra	point	at	coordinates	0,	0,	0	at	the	beginning	of	the	file.	Inter-block	gridline	mis-match	may	cause	momentum	diffusion
before	or	at	the	weir.	Still	on	the	Meshing	&	Geometry	tab,	open	the	Baffles	window	and	select	Add	.	Click	the	background	to	deselect	the	triangulated	surface.	Click	Update	and	note	how	the	number	of	holes	is	changed	to	zero.	Open	the	results	file.	The	permeability	and	Forcheimer	models	are	different	formulations	of	the	same	quadratic	drag	curve.
Use	the	small	X	in	the	upper	right	corner	of	the	dialog	to	close	the	Warnings	&	Errors.	All	subcomponents	of	domain-removing	components	deactivate	cells	regardless	of	whether	they	are	solids	or	holes.	Toggle	the	Boundary	Condition	Display	button	to	return	to	the	normal	mesh	block	view.	STEP	1	–	DOWNLOAD	USGS	DATA	FOR	THE	REGION	OF
INTEREST	The	region	of	interest	is	the	inundation	map	of	the	St.	Francis	dam	break	flood	of	1928,	from	the	California	coastline	near	Ventura	up	to	and	including	the	St.	Francis	dam	and	reservoir	(Figure	1).	Assign	a	per-vertex	attribute	=	–z	on	Filters	>	Quality	Measure	and	Computations	>	Per	Vertex	Quality	Function	and	manually	equalize	the
colors	with	Filters	>	Color	Creation	and	Processing	>	Colorize	by	Vertex	Quality	to	Min	=	-99.3	and	Max	=	-97.2.	Check	that	the	new	grid	color	is	red,	meaning	it	is	higher	than	the	maximum	elevation	of	the	original	data.	To	check,	you	will	need	a	case	that	is	representative	of	the	problem	of	interest	and	that	has	known	results.	Different	pressure
solvers	have	different	“best”	values.	h.	Select	the	Size	of	Cells	radio	button	c.	TOPO2STL	creates	.stl	facets	that	are	about	the	same	size,	regardless	of	location.	Contact	angle	=	15	degrees.	Select	and	delete	remaining	plane	points	that	overlap	river	data	Figure	9.	Note	that	the	variation	is	mostly	due	to	the	effect	of	the	cell	size	on	the	hydraulic	jump
itself:	the	jump	location	experiences	significant	boundary	effects	from	the	nearby	downstream	pressure	boundary,	and	so	it’s	a	poorly-posed	problem	to	begin	with.	Run	#2:	Add	Density	Evaluation	Physics	When	the	entrained	air	exceeds	some	volumetric	concentration,	bulking	begins	to	increase	the	mixture	volume	and	decrease	the	mixture	density.
Right	Button	–	Pan.	Page	10	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	Figure	14.	Review	the	information,	which	should	appear	as	it	does	below.	Now	use	Probe	>	General	History	Data	to	plot	text	for	fluid	1	volume	flow	rate	@	flux	surface	1	(FFLUX1)	and	mass	flow	rate	@	flux
surface	1	(MFLUX).	These	holes	will	represent	outflow	pipes;	you	will	specify	the	flow	rate	later	using	Mass/momentum	sources.	Launch	FLOW-3D®.	Alt+left	click	and	drag	to	select	only	visible	faces	or	vertices	in	the	box.	Many	of	the	methods	in	this	note	are	described	in	more	detail	in	that	exercise.	VELOCITY	Up	=	Umacro/ηeff	(m/s)	0.000	0.002
0.004	0.006	0.008	0.010	0.012	0.014	0.016	0.018	0.020	0.022	0.024	0.026	0.028	0.030	0.032	0.034	0.036	0.038	0.040	PORE	REYNOLDS	ReP	(dimless)	0.0	2.0	4.0	5.9	7.9	9.9	11.9	13.9	15.8	17.8	19.8	21.8	23.8	25.7	27.7	29.7	31.7	33.7	35.7	37.6	39.6	HEAD	LOSS	(∆H/∆x)	(m/m)	0.000	0.048	0.089	0.189	0.215	0.267	0.315	0.390	0.482	0.564	0.631	0.720
0.809	0.902	0.991	0.991	1.191	1.314	1.496	1.588	1.607	PRESS.	“CloudCompare	User’s	Manual	for	Version	2.1.”	Le	Faive,	R.,	translator.	Check	visually	that	all	grid	lines	match.	Increase	the	number	of	Integration	Steps	by	a	factor	of	10	(add	a	zero)	and	Render	again.	Solids	are	always	displayed,	and	fluid	is	colored	by	selected	flow	parameters.	Now
all	error	magnitudes	larger	than	about	1.8	cm	appear	in	red,	illustrating	the	regions	of	greater	error.	Click	the	button	to	reset	the	view	and	then	toggle	the	button	until	the	x-axis	points	to	the	right	and	the	z-axis	points	up.	It	suggests	that	one	of	the	nested	blocks	has	its	boundary	in	a	region	of	high	gradients.	Original	point	cloud,	colored	by	distance
from	15-m	resolution	.stl	surface	(blue	=	0	m,	red	=	±7.6	m	i.e.	mean	+	2	standard	deviations)	Page	15	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Figure	24.	The	model	results	will	be	compared	to	the	experimental	results.	Use	the	equation:	Page	12	of	13	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	6:	Air	Entrainment	The	percentage	of	air	calculated	from	the	density	is	the	same	as	was	determined	by	dividing	entrained	air	flux	@	flux	surface	1	(FPSCL1)	by	fluid	1	volume	flow	rate	@	flux	surface	1	(FFLUX1).	Click	on	the	Velocity	button	above	the	X,	Y,	and	Z	velocity	components.	This	may	be	too	fast	for	some	simulations,	so	enter	frame
rate	=	5.	Z	low	=	0,	Z	high	=	6.	Check	and	repair	the	.stl,	including	the	normals,	which	will	be	slightly	re-adjusted	from	MeshLab’s	orientation.	Install	the	TIG	Extrude	Tools	v2.5	extension	in	SketchUp	Make	2014	Page	1	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	GET	TOPOGRAPHY
FROM	GOOGLE	EARTH	USING	SKETCHUP	Getting	topography	is	simple	in	SketchUp.	The	resolution	may	not	be	as	fine	as	that	from	national	or	regional	DEM	databases,	but	it	is	often	adequate	for	general	modeling.	Loads	NO.	Note	that	some	parameters	only	report	the	specified	value	(like	fluid	height),	while	others	report	the	computed	value	(like
flow	rate).	Activate	and	specify	parameters	for	the	gravity	and	viscosity	&	turbulence	physics	models,	3.	The	adjustment	(if	any)	depends	on	(1)	how	long	it	took	the	coarse	case	to	reach	steady	state	and	(2)	if	the	new	simulation	is	a	restart.	Repeat	steps	3	–	5	using	the	values	on	the	right	side	of	the	image	below	to	add	the	DOWNSTEAM	block	2.
Statistical	fitting	of	the	error	magnitude	distribution:	normal	(left)	and	Weibull	(right)	g.	Show	both	layers,	then	right-click	one	of	the	layers	in	the	Layer	Dialog	and	select	Flatten	Visible	Layers.	Gradients	exist	in	all	directions	for	the	nappe.	Grain	size	distribution	and	its	effects	on	the	permeability	of	unconsolidated	sands.	Install	and/or	launch	netfabb
Basic	(	.	Select	Color	Variable	=	Velocity	Magnitude.	Notice	that	even	though	the	minimum	number	of	iterations	was	specified	ITMIN	=	2,	the	solver	does	not	always	iterate	twice.	Apply	Filters	>	Sampling	>	Poisson-disk	Sampling.	It	is	often	useful	to	visualize	the	results	early	to	ensure	that	it	is	running	correctly.		Specify	baffle	heat	transfer
coefficients	(when	heat	transfer	physics	are	active)		Activate	the	flux-surface	option	for	baffles	that	will	measure	flow	properties.	Use	Probe	plots	to	quantify	flow	rate	and	depths.	Page	13	of	13	Exercise	7:	Intro	to	General	Moving	Objects	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	Hydraulics	Exercise:
General	Moving	Objects	This	is	a	simple	example	to	illustrate	the	general	moving	object	model	in	FLOW-3D.	Min/max	coordinates	(mapped	into	scalar	fields	in	CloudCompare)	LIMIT	X	(feet)	Y	(feet)	Z	(feet)	Minimum	coord.	Locate	the	Warnings	&	Errors	button	present.	Set	Max	Search	Distance	=	0.5	(absolute	world	units).	In	the	next	step	you	will
find	the	problem	cell	and	identify	why	the	problem	occured.	Figure	16.		Check	3-D	and	2-D	plots.	Check	mesh	quality	with	FAVORize,	mesh	block	summary	tool,	mesh	information	tool	and	preprocessor	output	files,	4.	Move	both	of	the	Y-direction	sliders	to	the	left-most	position.	10.	It’s	a	good	first	test,	though,	and	so	far	the	mesh	resolution	looks
adequate.	Repeat	steps	4	and	5	for	Mesh	Block	2:	FINE,	which	shares	Z-boundaries	with	the	containing	block.	Stability	Limit	&	Time	Step	Size:	the	time	step	size	is	very	close	to	the	stability	limit,	matching	it	in	most	cases.	Does	final	line	#	not	complete	changes	on	within	½	hour.	Visualize	the	error	magnitude	distribution.	This	exercise	uses	open
source	freeware	and	FLOW3D’s	TOPO2STL	utility.	14	STEP	12	–	CHECK	ACCURACY.......................................................................................................................	For	details	of	the	NED	error	estimation,	see	USGS	(2006)	“Vertical	Accuracy	of	the	National	Elevation	Dataset”,	online	as	of	04/29/2014	at	.	In	general,	less	than	ten	is	a	desirable	value.	18.
Piston	i.	Familiarize	yourself	with	the	various	runtime	diagnostic	plots	available	in	the	dropdown	list	above	the	plot	window:	The	plots	are	generated	at	every	History	Data	output	step,	which	is,	by	default,	1/100th	of	the	simulation	finish	time.	Rule	of	Thumb	Only	specified	selected	data	variables	will	be	written	to	the	results	file.	On	the	right-hand	side
you	will	see	a	group	box	named	Units.	4	STEP	4	–	USE	MeshLab	TO	PREPARE	THE	TOP	SURFACE...............................................................................	A.	The	simulation	will	appear	with	the	old	name	(which	is	stored	as	text	in	the	prepin	file	itself).	Fill	holes	and	repair	the	.stl	bottom	with	MeshLab	If	a	smaller	.stl	file	size	is	desired,	repeat	Steps	7
through	9	until	the	desired	size	is	achieved.	Select	Yes.	They	represent	a	design	storm	or	are	derived	from	field	measurements.	The	simulation	folder	should	already	be	open	in	Windows;	look	at	the	address	bar	at	the	top	of	that	window	to	guide	your	browsing.	Requesting	Additional	Output	Detail	from	the	Solver	Before	running	the	simulation,	there
are	a	few	details	that	should	be	checked	and	added:				Check	the	Simulation	Units	are	specified	to	allow	labels	on	output	plots	Request	Hydraulic	Data	(includes	Froude	number,	fluid	depth,	free-surface	elevation,	near-bottom	and	depth-averaged	velocity)	Specify	Selected	Data	output	for	more	frequent	plots	to	see	details	and	make	movies	1.	These
include	the	properties	for	surface	tension	physics,	phase	change	physics,	and	two-fluid	diffusion.	Quantify	the	validation	uncertainty	This	step	quantifies	input,	numerical,	and	experimental	uncertainty	for	cases	that	involve	experimental	data.	fluid	1	volume	flow	rate	@	weir	flux	(around	#59).	Do	so,	and	copy	the	geometry	files	weir1.stl	and
Topo_Example_04_fixed.stl	to	the	new	Weir	Geometry	simulation	folder.	Now	the	baffle	will	measure	flow	rates,	depth,	and	hydraulic	energy	and	head.	Right-click	the	name	Subcomponent	2:	Outfall	1	in	the	tree	and	select	Copy…	b.	Turn	off	contour	smoothing.	If	necessary,	refer	to	troubleshooting.	Animations	are	movies	created	from	the	frames	in
the	Available	Time	Frames	list.	Time-step	size:	A	simple	plot	of	the	dynamically-selected	time	step	over	time.		Add	and	define	fluid	and	void/gas	initial	conditions	Initial	conditions	prescribe	the	solution	everywhere	in	the	domain	at	t	=	0,	and	set	up	the	entryvalues	for	all	equations:	flow	velocity,	heat	transfer,	electric	potential,	contaminant
concentration,	etc.	Mesh-resolution	studies	address	many	potential	sources	of	error.	Set	Contour	Variable	=	X-Velocity	and	Vector	Type	=	Plain	Velocity	Vectors.	It’s	recommended	(but	not	required	except	in	this	exercise)	that	you	keep	your	.stl	files	in	your	project	folder.	You're	Reading	a	Free	Preview	Page	37	is	not	shown	in	this	preview.	Make	sure
that	Add	to	Subcomponent	=	2:	channel.	The	end	result	is	a	more-or-less	rectangular	grid	of	coordinate	points	that	are	called	vertices.	Open	Properties	>	Fluid	1	>	Density	Properties.	Page	1	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	5.		What	solution	is	limiting	the	time	step?	Instead,	choose	Part	>	Export	Part	>	as
STL.	This	prevents	loss	of	precision	due	to	machine	rounding.	This	free	software	can	be	downloaded	from	.	Select	and	close	holes	with	fewer	than	10	edge	facets	Page	12	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Figure	19.	Use	MeshLab’s	Grid	Generator	filter	to	create	a	plane	with	extents	slightly
larger	than	those	in	Table	1:	use	78,240	m	x	39,600	m	with	15-m	spacing.	Click	the	Contour	Options	button	in	the	bottom	central	portion	of	the	tab.	Postprocessing	Visualization	1.	Page	20	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	The	white	line	represents	a	normal	distribution	(based	on	the
mean	and	standard	deviation).	5	On	the	Model	Setup:	Fluids	tab	....................................................................................................................	Hints	and	suggestions	will	be	included	after	the	specifications.	The	way	to	do	this	will	be	to	make	the	cell	sizes	such	that	the	distances	between	all	mesh	planes	and	solid	surfaces	in	each	direction	(X,	Y,	Z)	are	even
multiples	of	the	largest	cell	size	in	that	direction,	and	then	to	make	the	smaller	cell	sizes	in	that	direction	exactly	½	of	the	larger	cell	sizes.	Preprocess	and	run	the	simulation	and	interpret	the	runtime	output,	5.	Once	the	rendering	is	complete,	the	following	dialog	will	appear.	You're	Reading	a	Free	Preview	Pages	8	to	30	are	not	shown	in	this	preview.
The	model	will	rotate	accordingly.	Instructions	will	appear	to	explain	the	next	step;	select	OK	to	continue.	The	packet	probably	accelerated	unexpectedly,	which	is	why	the	solver	didn’t	predict	the	velocity	of	the	packet.	Numerical	options	that	were	justified	in	previous	steps	should	stay	fixed.	Appendix	C	introduces	useful	MeshLab	keyboard	and
mouse	commands	for	making	additive	and	subtractive	selections.	Probe:	Displays	values	for	individual	cells	as	well	as	non-cell	data	like	integrated	global	values,	boundary	condition	values,	and	component-specific	integrated	output.	Explode	the	terrain	to	create	a	triangulated	surface	from	the	terrain	model	in	SketchUp.	Page	4	of	11	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	4.	The	media	was	packed	as	homogenously	as	possible	using	a	constant-height-of-fall	pluviation	method.	Simplification	of	the	non-river	surrounding	box	in	MeshLab	Page	15	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting
Topography	to	.stl	Apply	Filters	>	Selection	>	Select	None	to	deselect	the	faces.	The	X-max	and	Y-max	boundaries	should	be	placed	farther	from	the	nappe	to	avoid	this	difficulty.		Describe	the	case-of-interest	&	report	results					Report	model	options,	whether	they	were	the	same	or	different	as	in	the	test	case.	For	example,	if	one	design	option	causes
much	less	air	entrainment	than	the	other,	you	can	pick	the	better	design	without	worrying	much	about	the	input	and	numeric	uncertainty!	References	Brethour,	J.M.	and	C.W.	Hirt	(2009).	Namelists	are	sections	of	the	prepin	file;	the	preprocessor	goes	through	the	namelists	in	order	and	interprets	them.	This	method	is	useful	when	receiving	a
simulation	via	email.	Turn	off	cell	blanking.	Why	not?	Errors	should	be	addressed	when	they	are	repetitive.	Solids	will	deactivate	cells	unless	solid	heat	transfer	physics	are	active.	You	can	use	this	approach	for	any	density	scalar	to	determine	if	the	reported	units	are	correct.	Page	5	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:
Saturated	Porous	Media	Review	the	Permeablity-Dependent	Saturated	Drag	Equation	You	need	to	determine	two	coefficients:	D’Arcian	Permeability	(PERM)	and	Non-D’Arcian	Permeability	(PERM2)	for	the	porous	media	component.	Turbulence	model	assumptions	may	affect	results.	The	next	step	is	checking	that	the	topography	looks	right,	locating
any	bad	data	points,	and	making	note	of	the	minimum	and	maximum	data	extents.	Under	some	conditions,	.stl	tools	may	have	difficulty	fixing	a	file.	The	normal	distribution	is	not	a	good	fit!	Repeat	the	process	and	select	Weibull	as	the	distribution	type.	Let	Umacro	=	the	average	of	the	inlet	and	outlet	velocities	at	each	output	time.	Otherwise	select
No.	9.	Take	a	few	moments	to	look	over	the	available	runtime	plots	for	the	simulation.	Cylinder	inner	radius	=	0.0105	cm.		Boundary	types	should	be	appropriate	for	the	situation.	Results	should	always	be	checked	to	make	sure	that	large	quantities	of	fluid	aren’t	accidentally	removed	this	way!	14.	Values	entered	here	will	change	Fluid	1	Density	on
the	Fluids	tab.	Params	tool	first	for	Distribution	=	Gauss	and	then	for	Weibull.	%	concentration	of	air	in	the	mixture	=	QV,AIR/QV,MIX	=	7.2%	by	volume	at	t	=	5	and	6.6%	by	volume	averaged	over	the	final	2.5	seconds,	about	the	same	as	the	density-only	model.	Add	the	Upstream	Channel	as	Primitive	Boxes	The	upstream	channel	will	be	added	using
box	primitives.	Specify	Fluid	Fraction	=	1.		Each	expansion	should	be	an	even	multiple	of	the	cell	size	in	that	direction.	Select	flsgrf.Weir_Finish.	1	On	the	Model	Setup:	General	tab	.................................................................................................................	Subsampling.	o	If	some	solids	must	have	temperature	that	vary	in	space	due	to	initial	condition	but
are	constant	in	time,	consider	the	non-uniform,	constant	temperature	option.	When	the	fraction	and	velocity	are	integrated	over	the	area	of	the	flux	plane,	the	result	is	a	volumetric	flow	rate	(despite	what	FLOW-3D	reports).	The	areas	outside	of	this	region	are	“blank”:	there	is	no	data	there.	Go	to	the	Model	Setup	>	Fluids	tab.	Set	Numerics	Options
There	are	some	numerical	options	that	will	help	make	this	simulation	run	well.	Willmott,	C.J.,	Ackleson,	S.G.,	Davis,	R.E.,	Feddema,	J.J.,	Klink,	K.M.,	Legates,	D.R.,	O’Donnell,	J.,	and	Rowe,	C.M.	(1985).	Do	initial	fluid	values	match	the	boundary	conditions?	The	scripts	use	the	GDAL	library	to	convert	the	data	without	a	software	user-interface.	Hold
Ctrl+left-click	to	select	prepin.Weir_Geometry,	weir1_repair2.stl,	and	Topo_Example_04_fixed.stl.	Do	this	now.		Consider	adding	initial	fluid	regions	to	minimize	splashing	on	solid	surfaces.	Page	6	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	11.	The	cell	size	that	goes	evenly	into	both
distances	is	0.0024	m,	which	is	far	too	small.	QV,MIX	=	FFLUX1	=	1141	cm3	mixture/second	at	t	=	5	seconds.	Note	that	the	floor	will	be	part	of	a	new	subcomponent,	so	it	can	have	a	different	surface	roughness	than	the	weir.	One	way	is	to	run	the	preprocessor,	and	this	gives	the	most	information	short	of	running	the	simulation.	Page	8	of	13	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	6.	This	approach	minimizes	the	effect	of	rounding	error	in	the	CFD	calculations.	If	it	ran	to	steady	state,	then	a	restart	copy	with	a	shorter	finish	time	is	recommended	for	faster	results.	The	text	output	gives	a	new	estimate	of	the	mean	and	standard	deviation	σ:	about	0.01	feet	(3	mm)	for
both.	Click	the	Capture	button	to	accept	the	selection.	That	data	is	stored	in	the	mesh	file.	Return	to	Single	plots	and	click	on	the	Format	button	in	the	upper	right-hand	corner.	Double-left-click	to	place	the	trackball	center	at	the	clicked-on	point.	The	Z-Max	boundaries	could	be	Symmetry	or	Wall;	it	doesn’t	matter	as	long	as	fluid	never	touches	them.
Re-check	the	output	with	netfabb	Basic	and	qAdmesh:	both	programs	should	agree	that	the	part	is	fixed.	tan	θ	=	∆x/∆z	=	(0.995378	+	0.0970524)/(11.9914	–	10.3757)	=	0.676.	AGU	39,	702-707.	Open	the	Z-Max	boundary	condition.		Estimate	the	Reynolds	number	Re.	Decide	if	turbulence	physics	are	necessary.	GRAVITY	Because	the	media	vessel	is
arranged	vertically,	we	might	assume	that	gravity	must	be	included.	Loads	YES.	Check	the	output	against	that	shown	below.	If	it	is,	it	will	also	be	a	unique	color	in	the	display.	Set	the	downstream	boundaries:	a.	%	concentration	of	air	in	the	mixture	=	QV,A/QV,MIX	=	96.1/(1055	+	96.1)	=	8.3%	by	volume	crossing	the	flux	plane	at	t	=	5	seconds.	In
that	case	use	a	64bit	software	like	MeshLab	or	a	professional	version	of	netfabb.	Graphics	similar	to	following	will	appear	on	the	Display	tab.	Select	weir1_repaired2.stl	and	click	Open.	2006.	Cylinders	are	defined	around	the	z-axis.	Right:	recommended	1-inch	Poisson-disk	subsampling	6)	Use	the	TOPO2STL	utility	to	convert	to.stl.	17.	This	strongly
suggests	that	the	.stl	file	was	made	in	units	of	feet.	Select	File	>	Open	>	Open	DEM	to	open	and	view	the	new	files.	The	next	step	will	be	to	generate	a	2-D	plot	along	the	weir	centerline	to	show	the	initial	fluid	pressure	and	location	with	the	mesh.	A	line	should	appear	showing	the	streamline	from	t	=	0	to	the	selected	time	in	the	Available	Time
Frames	list.	Figure	9:	MKE	relates	to	velocity	3.	If	not,	consider	adjusting	the	mesh	resolution.	characters.	There	are	five	sources	of	data	in	FLOW-3D:	Restart:	All	cell-by-cell	flow	variables	necessary	for	a	complete	solution,	plus	any	Additional	Output.	At	a	number	of	points	in	the	process,	you’ll	be	asked	to	save	your	work	with	a	different	file	name.
First	make	a	copy	of	MiddleRioGrande.txt	and	rename	it	MiddleRioGrande.asc.	You	could	do	this	in	two	ways:		Deactivate	cells	by	adding	a	solid	component.	Select	to	accept	the	new	point	cloud.	Stability	limit	&	time	step	size:	Compares	the	time	step	stability	limit	(the	smallest	time	step	required	in	any	cell	to	meet	any	explicit	solver	that	is	active)
and	dt,	the	actual	time	step	being	Page	13	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	used.	Use	MeshLab	to	import	and	re-export	the	data:	MeshLab	is	a	powerful	and	free	opensource	tool	for	working	with	meshes	and	point	clouds.	Page	2	of	16	Water	&	Environment	Training
on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Figure	2.	Mass-Averaged	Kinetic	Energy:	MKE	here	is	the	sum	of	total	kinetic	energy	in	all	cells	divided	by	the	mass	of	fluid	in	the	simulation.	Selected:	User-selected	cell-by-cell	flow	variables.	Open	the	tree	for	Mesh	Block	4	and	rename	it	CONFORMING	MESH	BLOCK.	Tan-1	(0.676)	=	34°,	the
internal	angle	of	the	blade.	Few	data	sets	require	micrometer	precision,	so	the	formatting	method	will	usually	depend	on	factors	like	file	size,	data	column	order,	and	type(s)	of	bad	values	that	must	be	removed.	6	Model	the	case	of	interest	............................................................................................................................	There	are	now	three	layers:	two
horizontal	planes	(one	at	-2	m	and	one	at	571	m),	and	one	layer	of	USGS	topography.	No	Velocity	Vectors.	Please	send	suggestions	to	[email	protected]	Select	a	problem	with	known	results	for	proof-of-concept	testing	Whenever	you	must	model	a	new	class	of	problems	using	CFD,	it	is	good	practice	to	check	whether	you	can	set	up	a	CFD	model	that
gives	expected	results.	Page	7	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	Figure	9.	The	nappe	will	have	strong	gradients	(direction	changes)	in	the	X-	and	Z-directions,	and	some	contraction	in	the	Y-direction.	Find	TIME	=	5	seconds	(the	last	output	time).		Numerical	uncertainty	The
results	from	mesh-dependency	study	described	above	can	be	used	to	calculate	numerical	uncertainty,	order	of	convergence,	Grid	Convergence	Index,	and	extrapolated	results.	Click	Save	and	on	the	next	dialog	deselect	Normal	so	that	the	file	saves	with	only	three	coordinate	values	per	line	(instead	of	six).	5	On	the	Model	Setup:	Output	tab
................................................................................................................	e.		3-D	o	Pros:	inlet/outlet/wall	effects	and	non-axial/radial	symmetric	flow	can	be	modeled.	Cylinder	inner	radius	=	undefined,	Cylinder	outer	radius	=	0.0085	cm.	The	results	are	given	as	text	output:	qAdmesh	identifies	about	5,400	facets	with	disconnected	edges,	about	2.73
million	incorrect	normal	vectors,	and	two	identified	surface	shells	(which	are	called	parts	in	qAdmesh).	The	data	is	from	a	joint	project	of	the	U.S.	Bureau	of	Reclamation	and	Colorado	State	University,	and	is	provided	as	a	courtesy	by	Dr.	Amanda	Cox.	Select	spatial	resolution.	Cells	where	FAVORize	will	have	known	problems	will	be	highlighted	in
orange.	Add	history	probes	for	point	measurements,	and	9.	From	the	left,	start	at	I	=	78	and	count	up	to	82.	Check	that	you’ve	added	all	the	definitions.	The	CFD	model	may	not	match	the	physical	model.	Click	Yes	when	prompted	to	change	the	extension.	set	Z	Max	=	Pressure	(P)	with	stagnation	pressure	option	activated),	c.	Choose	Selected	data.
This	is	the	missing	facet.	Use	2-D	Plots	to	Diagnose	Errors	1.	If	the	mean	radius	is	increased	from	0.5	mm	to	1	mm,	the	entrained	air	flow	rate	increases	by	a	factor	of	3.75!	The	sensitivity	of	this	input	increases	uncertainty	in	the	model.	This	is	acceptable.	Rule	of	Thumb	A	typical	estimate	of	the	actual	turbulent	length	scale	is	in	the	range	of	7%	to
18%	of	either	the	flow	depth,	wake	width	(abutments),	or	wake	half-width	(piers/jets).	This	is	the	best	representation	of	the	system,	because	no	matter	how	many	air	bubbles	are	present,	they	are	still	separated	by	thin	liquid	films.	Calculate	and	plot	2nd-order	polynomial	fitting	equations	for	both	sets	of	data.	Translate	the	grid	to	position.	This	speeds
up	the	solution	and	makes	it	more	stable	at	the	cost	of	a	(usually)	slight	degree	of	accuracy.	Pressure-type	(with	stagnation	pressure	option	activated),	c.	8.	Choose	Extensions	from	the	list	on	the	left.	The	spatial	and	time	extents	should	be	selected	with	care	as	the	text	files	can	become	very	large.	Set	the	Transparency	slider	all	the	way	to	the	left	so
the	weir	is	opaque.	o	Yes:	consider	free	surface	or	sharp	interface	tracking	o	No:	consider	no	sharp	interface	tracking	(fluid	separation	is	diffuse	or	the	whole	domain	is	submerged)		Is	the	flow	viscous?	The	physical	model	data	includes	measurement	uncertainty.	Particle	Count:	The	number	of	particles	in	the	simulation	stays	constant	at	1,330
particles.	TOPO2STL	output	(1-inch-spacing,	pre-decimated-and-filled)	in	netfabb	Basic	Select	Extras	>	Repair	Part	to	create	a	new	Part	Repair	branch	in	the	tree.	Choose	Explicit	approximation	c.	Restart	data	and	Selected	data:	cell-specific	values	of	flow	variables,	plotted	for	a	single	spatial	point	over	time	when	using	Probe	history.	Select
Subcomponent	>	Box	from	the	view	pane	menu.	Make	notes	of	any	values	that	you	are	unsure	of.		Post-process	the	results.	This	implies	that	at	flow	rates	near	zero,	the	pressure	will	increase	from	the	inlet	to	the	outlet.	Exceptions	increase	uncertainty	in	the	results,	but	may	be	necessary.	Toggle	between	views	and	zoom	in	as	needed.	The	no	sharp
interface	option	treats	the	interface	between	fluids	as	a	mixture,	and	forces	all	open	volume	to	be	full	of	fluid	at	all	times.	Activate	general	moving	objects	(GMO)	model	b.	Compare	Results	to	Physical	or	Empirical	Data	At	this	point,	you	should:	1.	Check	the	Mesh	>	Show	option	so	the	mesh	is	displayed,	and	select	Mesh	>	View	Mode	>	Grid	Lines.
Are	all	initial	fluid	values	(e.g.,	depth,	velocity,	pressure,	density)	as	expected?	Intersect	the	faces	and	then	delete	the	unneeded	bottom	faces	and	rectangle	sides.	Click	OK	to	accept	the	changes	and	Save	your	work.	Also	try	adjusting	the	transparency	of	the	other	entities	(solid	and	fluid	surfaces),	Page	4	of	13	Water	&	Environment	Training	on
FLOW-3D	v11	Exercise	5:	Analysis	3.	The	first	test	of	the	raw	data	is	visual	examination.	Less	than	one	means	the	pressure	solution	converged,	greater	than	one	means	it	did	not.	The	text	output	can	be	written	to	a	file	by	selecting	the	Save	As	button	(don’t	forget	to	name	the	file).	The	FAVOR	dialog	will	appear.	This	doesn’t	look	like	a	problem	with	a
boundary	condition,	because	the	Z-min	boundary	is	Wall	type.	Click	Render	in	the	lower	left	to	generate	the	graphics.	This	is	because	the	initial	water	level	behind	the	St.	Francis	Dam	was	559.4	m	(1,835	ft)	per	Outland	(1963),	as	cited	in	Sanders	(2007).	Page	26	of	26	Exercise	10:	STL	Topography	from	Google	Earth	Water	&	Environment	Training
on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	MAKING	STL	FILES	FROM	GOOGLE	EARTH	USING	SKETCHUP	AND	CAD2STL	INSTALL	NECESSARY	SOFTWARE	You	will	need	to	install	the	following	programs:				SketchUp	Make	2014	(	)	TIG	Extrude	Tool	2.5	(	Cad2Stl	v1.4	(users.flow3d.com)	The	TIG	Extrude	Tool	plugin
will	come	in	handy	later	so	you	won’t	have	to	manually	draw	each	.stl	face.	True	turbulence	(eddies)	in	porous	media	begins	at	approximately	ReP	=	100	to	500.	Click	Convert	to	begin.	Uses	1	GB	of	memory,	then	entire	file	into	crashes.	Typical	examples	are	global	quantities	and	component-specific	quantities.	Another	dialog	will	appear	asking
whether	to	explode	extruded	faces.	Select	multi	as	the	plot	type	and	then	select	the	time	frames	for	t	=	0.35	and	t	=	0.73	seconds	from	the	list	at	the	right.	Control	+	mouse	wheel	to	move	“near”	clipping	plane.	Page	10	of	11	FLOW-3D	Version	11	Simulation	Setup		Check	each	section	in	Diagnostics	>	Preprocessor	Summary	(prpout.xxx).	This	step	is
optional.	Adjust	the	camera	and	make	a	selection	that	includes	all	the	extruded	faces	and	the	rectangle.	The	parameter	is	also	added	to	the	Selected	Data	list	in	the	center	of	the	screen.	The	options	for	Integrate,	Differentiate,	and	Moving	Average	become	inactive,	as	they	are	only	available	for	graphical	output.	Select	and	add	parameters	to	be	output
more	frequently	than	the	default,	4.	Mouse	wheel	to	move	the	part	and	coordinate	system	along	line	of	sight	relative	to	the	trackball.	Select	the	Analyze	>	Probe	tab.	It	can	be	global	and	constant	(which	requires	some	understanding	of	the	limiting	mixing	length),	or	calculated	in	each	time	step	(dynamically)	for	each	cell	based	on	empirical
formulations.	Viscous	Flow	physics	should	be	used.	Merge	the	plane	and	river	data.	Unzip	each	file	into	a	new	temporary	working	folder	located	on	the	root.	Digitizing	topographic	data	for	use	in	FLOW-3D	combines	both	definitions:	the	process	of	recreating	accurate,	detailed	surface	features	requires	both	art	and	practice.	Page	18	of	21	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	12.	Move	the	torus	subcomponent	into	position	by	translating	it	0.015	cm	in	Z.	Available	in	EditPad	Pro	only.	Will	the	simulation	finish	in	your	lifetime?	In	general,	do	not	change	these	settings	without	understanding	what	the	adjustment	does	and	having	justification
for	the	change.	Activate	Show	Units	on	Plots.	Torus	Minor	radius	=	0.0075	cm	3.	Go	to	the	3-D	sub-tab.	Page	9	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Now	the	grid	lines	in	X	and	Y	match	exactly	and	align	to	the	most	important	geometry	exactly.	Add	a	mesh	block	and	define	the	2-D
cylindrical	mesh	to	enclose	the	geometry	and	align	the	grid	lines	(using	X	Mesh	Planes)	with	the	outside	edges	of	the	piston	and	nozzle	as	shown	on	the	next	page.	Check	the	following:	Page	8	of	11	FLOW-3D	Version	11	Simulation	Setup		Boundaries	should	usually	be	located	far	enough	from	the	region	of	interest	that	increasing	the	boundary	distance
further	does	not	change	the	results	in	the	region	of	interest.		Define	all	boundary	conditions	Follow	the	annotated	diagram.	This	exercise	introduces	FLOW-3D’s	TOPO2STL	utility	for	creating	.stl	parts	from	large	point	clouds.	o	In	section	/PARTS/,	were	any	fluid	history	probes	eliminated	unexpectedly?	A	quicker	way	is	to	FAVORize	the	geometry.	
Viscosity	of	Phase	#1	is	the	viscosity	used	in	the	in-cell	evaluation	of	relative	(separation)	velocity	between	the	continuous	and	dispersed	phases.	The	two	plots	closest	in	time	to	the	error	should	be	similar	to	the	ones	on	the	next	page.	13	STEP	11	–	FIX	FACET	NORMALS	..................................................................................................................	Loads
entire	file	into	memory.	Delete	a	set	of	points.	Click	on	the	icons	to	hide	and	compare	the	original	point	cloud	and	new	plane	layers.	Page	10	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	a.	Y	=	-1.524	and	Y	=	1.524	to	resolve	the	crest	edges,	and	c.	Open	the	Geometry	>	Component	1:	weir	>
Subcomponents	>	Subcomponent	1:	weir	plate	>	Transformations	>	Magnifications	branch	of	the	tree	in	the	Geometry	Window.	Check	and	fix	any	errors	in	the	.stl	using	tools	like	pyAdmesh	or	netfabb	Studio.	Entrained	air	will	be	modeled	as	a	massless	scalar,	as	a	miscible	scalar	with	mass,	and	as	a	drifting	dispersed	phase	with	both	density	and
bubble-drag	effects.	Schematic	enlargement	of	rectangular	sharp-crested	weir	(Bos	1989)	Page	8	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	Scale	Weir	Subcomponent	From	Feet	to	Meters	1.	This	is	not	ideal,	but	since	the	parts	are	fully	closed	and	have	no	inverted	normals	it	should	not	affect	the	FLOW-
3D	model.	Adjust	and	check	the	mesh	until	the	following	criteria	are	satisfactory:	o	geometry	resolution	o	resolution	of	flow	sections	o	total	cell	count	(as	a	function	of	desired	run	time)	o	grid	line	matching	between	neighboring	blocks	o	aspect	ratios	for	single	cell	sides	o	aspect	ratios	between	neighboring	cells	(due	to	stretching)	o	aspect	ratios
between	cells	in	neighboring	blocks	o	Open	area	mismatch	(from	the	preprocessor)	Make	note	of	the	meshing	methodology	and	rationale.	Render	the	plots	graphically,	using	multi	plots	to	look	at	the	data	side-by-side.	The	Type	of	Moving	Object	setting	must	be	set	in	the	Geometry	Window	under	the	Component	itself.	Santa	Fe,	NM:	Flow	Science	Inc.
Are	the	dimensionless	numbers	(Re,	Fr,	We,	etc.)	similar	between	the	cases?	Existing	file	types	are	flsplt.xxx	and	prpplt.xxx	which	contain	non-alterable	plots	that	are	predefined	in	the	prepin	file	(i.e.,	the	simulation	instructions).	Rotate	(right	mouse	button)	and	pan	(center	mouse	button/wheel)	the	view	until	the	front	face	of	the	weir	is	visible.	Set
Gravity	component	gx	and	gz	given	above	on	the	Physics	panel.	Find	Additional	Output	on	the	left.	Select	Continue	to	close	the	text	output.	This	time	there	should	be	a	few	(around	3)	pressure	iteration	failures	at	the	very	start	of	the	simulation,	and	after	that	there	should	be	none.	button	at	the	bottom.	Global	>	Pressure	=	Uniform	Pressure	b.	The
default	max	iterations	for	the	Successive	Under-Relaxation	Viscous	Solver	is	iter	=	20,	which	you	raised	to	50.	This	is	so-called	limited	compressibility.	Set	a	single	streamline	starting	point	and	edit	it’s	appearance:	a.	Repair	algorithms	are	implemented	differently	in	software	packages,	and	almost	always	produce	slightly	different	results.	Adjust
Transparency	so	you	can	see	the	circular	source	at	the	origin.	Page	1	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	Add	an	Example	Simulation	1.	The	segmentation	tool	opens	with	a	new	toolbar.	o	Check	nested	blocks	are	inside	their	containing	blocks	(they	may	share	edges).
Check	the	Solver	Text	for	the	implicit	solver	convergence	performance:	pressure	res/epsi	should	be	small	(around	1E-7	to	1E-2)	and	viscous	stress	res/epsi	should	be	on	the	order	of	E-1.	FWTools	provides	the	functionality	to	read	the	USGS	formats.	Specify	Pressure	=	0.	It	is	used	in	Incompressible	flow	simulations	(like	this	one)	to	allow	the	cell
pressure	to	vary	as	if	density	was	changing	due	to	compression.	Check	the	Define	as	Flux	Surface	option.	It	can	also	be	defined	as	“the	art	or	practice	of	graphic	delineation	in	detail	…	of	natural	and	man-made	features	of	a	place”	(MerriamWebster	2013).	i.	multi-processor	efficiency	ratio	%PE,	as	percent	Loading	Results	While	the	Solver	is	Running
The	results	of	a	simulation	can	be	viewed	while	the	simulation	is	running	or	after	the	simulation	is	complete.	Click	and	hold	the	right-mouse	button	and	move	the	mouse	in	the	window.	Select	Flow	Depth,	Free	Surface	Elevation,	Depth-Averaged	Velocity,	and	Froude	Number,	and	click	OK	to	accept	the	variables	for	plotting.	No	point	is	recorded	when
you	click	on	blank	space.	Now	you	will	use	FLOW-3D	to	find	the	dimensions	of	the	weir,	although	you	could	do	so	more	easily	back	in	netfabb	Basic.	Let	z2	be	the	outlet	reference	elevation	and	z1	be	the	inlet	elevation:	they	will	be	0.4	m	apart.	K	is	the	fluid	bulk	modulus,	ρf	is	the	fluid	density,	and	W	is	the	adiabatic	speed	of	sound.	TKE	appears	to	be
quasi-steady	by	about	10	seconds,	but	there	are	too	many	oscillations	to	be	certain.		Each	baffle	region	has	one	definition	and	as	many	limiters	and	transformations	as	necessary.	Select	Solid	Volume	to	plot	the	solid	components	(weir).	The	run	will	usually	take	between	8	and	10	hours,	depending	on	your	computer’s	power.	Change	the	type	if	you
made	a	mistake.	Click	Import	Values.	This	is	not	strictly	required,	since	flux	surfaces	cannot	be	completely	solid,	and	will	default	to	porosity	=	1	if	the	default	0	is	left.		Are	there	two	pure-phase	liquids	with	different	densities	and	viscosities	along	with	a	free	surface	and	a	gas	phase?	Select	All	(	Ctrl+A)	and	then	right-click	the	selection	and	select
Make	Group	from	the	context	menu.	Use	the	Select	Vertexes	tool	where	necessary	to	make	sharp	edges	in	the	selection	and	manually	clean	up	any	points	that	escape	the	first	attempt	(see	Figure	8	below).	Special	considerations:		1st-order	should	be	used	with	wave	boundaries	(along	with	Split	Lagrangian	VOF).		Can	gravity	and	reference-frame
motion	be	ignored?	Apply	then	Close	the	filter.	STEP	11	–	FIX	FACET	NORMALS	Figure	22.	Example	Calculation	for	Flux	Plane:	1.	Using	what	you	know,	plot	Probe	>	Selected	data	for	Pressure	and	Z-Velocity.	Use	the	eye	logo	Notice	the	warning	label	detectable	problems.	The	upstream	and	downstream	initial	depths	should	match	the	free	surface
elevation	at	the	boundaries.	The	baffle	now	defines	the	plane	at	x	=	0.	Proc.	The	next	exercise	in	this	series	describes	how	to	remove	large	sections	at	a	time	with	CloudCompare,	which	is	more	useful	for	records	from	large	digital	elevation	databases.	Figure	8.	This	step	is	optional,	but	highly	recommended	when	time	and	resources	allow	it.	The
number	of	surface	points	in	TOPO2STL	output	is	a	function	of	the	area	of	the	rectangular	bounding	plane	and	the	square	resolution	stencil.		The	number	of	fluids	refers	to	where	momentum	equations	are	to	be	solved.	Quality	Control	statistics	for	different	conversion	methods	and	spacing	CONCLUSIONS	AND	SUMMARY	An	approach	for	converting
large	topographic	point	clouds	to	3-D	.stl	parts	has	been	recommended.	Please	send	suggestions	to	[email	protected]	Before	starting		Draw	and	annotate	a	diagram	of	the	physical	problem	The	diagram	should	include:		A	consistent	unit	system	(e.g.,	SI,	CGS,	slug/foot/second)	that	matches	the	scale	of	the	problem	(very	small	and	very	large	numbers
can	increase	rounding	error),		Geometric	dimensions,		Locations	of	fluid	and	free	surfaces,		Notes	on	body	forces	(like	gravity)	and	boundary	forces	(like	shear	stress),		All	heat	and	fluid	fluxes	and	sources,		All	solid	moving	objects	and	their	velocities,	locations,	and	travel	paths		Unknown	variables	and	the	locations	where	you	want	to	them.	Select
Clear.	There	are	144,385	active	cells	out	of	202,498	total	cells;	both	counts	include	boundary	cells.	Check	this	by	making	the	geometry	transparent	and	viewing	the	grid	lines	in	the	Cartesian	directions.	Do	not	rotate	the	view.	Note	also	that	when	the	simulation	is	post-processed,	even	the	unused	parts	of	Block	4	will	contribute	to	the	memory	usage	of
the	post-processor.	Use	as	few	blocks	as	possible.	The	tool	sometimes	extrudes	reversed	faces.	Detailed	experimental	uncertainties	are	ideal,	approximate	evaluations	(e.g.,	±2%)	are	common	in	practice.	Simple	errors	can	be	fixed	quickly	with	.stl	repair	tools.	Select	Render	>	Color	>	Per	Vertex	from	the	menu	bar	to	display	the	colored	results.
Identifying	the	problem	cell	is	useful	when	there	are	many	errors	in	a	row.	Change	the	Simulation	Units	to	SI.	Double-click	the	wall	subcomponent	in	the	view	to	select	it	(it	will	turn	green).	Final	point	cloud,	filtered	to	below	570	m	and	segmented	Reload	the	point	cloud	with	the	new	recommended	shift,	rounded	by	order	of	magnitude.	Select	View	>



Draw	Axis	>	Origin	from	the	menu	above	the	display	to	set	the	axis	at	the	origin.	Set	Fluid	Fraction	=	0	(meaning	the	boundary	is	void/air,	and	will	remove	water).	Drift	Model	for	Two-Component	Flows.	Play	with	Transparency	and	viewing	the	mesh	Grid	Lines	while	you’re	looking	Page	6	of	24	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	at	this	view.	1	STEP	1	–	DOWNLOAD	USGS	DATA	FOR	THE	REGION	OF	INTEREST	..............................................................	The	most	robust	and	widely	applicable	turbulence	model	is	the	k-	ε	RNG	(Renormalized	Group)	model.	Select	Shapes	>	Rectangle	and	draw	a	large	rectangle	on	the
canvas	to	completely	surround	the	topography.	This	indicates	that	the	bubble	concentration	cannot	be	modeled	as	if	it	were	molecularly	dissolved	in	the	water.	Many	General	History	variables	are	integrations	of	cell-by-cell	values.	The	Video	Compression	dialog	will	open.	Convert	the	surface	to	.stl	format.	complete	YES	(loads	into	memory	first).	All
the	data	shown	here	is	also	available	as	General	History	data	in	the	output	flsgrf	file.	Select	Filters	>	Color	Creation	and	Processing	>	Colorize	by	Vertex	Quality.	Non-cubic	cell	aspect	ratios	may	diffuse	momentum.	Simple	geometry	can	be	build	with	primitives	in	FLOW-3D.	Locate	the	large	display	window	showing	the	model	and	domain	illustrated
below.	You	should	decide	D’Arcian	model	and	the	two	quadratic	models	on	the	basis	of	the	pore	Reynolds	number,	ReP:	where	ρ	is	the	fluid	density,	μ	is	the	fluid	dynamic	viscosity,	Dp	is	the	characteristic	pore	diameter,	and	Up	is	the	mean	microscopic	(or	pore)	velocity	of	the	fluid.	The	above	two	options	are	time-consuming	and	are	appropriate	when
quantitative	results	are	needed,	like	the	exact	volume	of	entrained	air.	Additionally,	TOPO2STL‘s	ASCII	output	is	five	times	larger	than	binary	format.	STDY	TOTAL	VELOCITY	TRANSIT	STATE	TIME	Umacro	tfront	tsteady,est.	Import	the	Fixed	Weir	.stl	File	1.	Fill	Fraction:	the	simulation	is	about	53.5%	full	of	fluid	for	the	second	half	of	the	simulation.
Select	Tools	>	Projection	>	Export	Coordinate(s)	to	Scalar	Field(s)	and	export	X,	Y,	and	Z.	Remove	the	plane	vertices	that	overlap	the	point	cloud	edges.	Remember	from	Exercise	1	how	to	open	the	simulation	directory	from	inside	the	Simulation	Manager	tab?	Select	the	Model	Setup	>	Meshing	&	Geometry	tab	and	show	the	Mesh	Window	.	Check
your	work.	Fluid	flow	through	packed	columns.	Test	the	sensitivity	of	the	results	to	constant	vs.		Repeat	the	process	for	any	other	empirically-based	physics	models	that	have	numerical	knobs	that	can	be	shown	to	affect	the	model	results.	Since	Density	Evaluation	physics	are	not	activated,	the	density	of	the	mixture	is	the	density	of	pure	water.	Flux
Surfaces	are	a	special	kind	of	baffle	which	measure	flow	parameters	and	can	be	completely	open	to	flow	(100%	porous).	FSI-09-TN83Rev.		If	the	baffle	is	porous	(0	<	porosity	<	1),	specify	baffle	drag	coefficients.	Their	edges	are	always	parallel	to	the	coordinate	system.	Microscopic	velocity	is	almost	never	measured	Page	4	of	19	Water	&	Environment
Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	directly	due	to	the	difficulty	of	inserting	probes	between	grains.	Right-click	Mass	Momentum	Sources	and	select	Add	a	Mass	Momentum	Source.	We	can	demonstrate	this	using	the	Extended	Bernoulli	Equation:	if	the	fluid	is	incompressible,	this	relation	holds	true	for	any	two	points	1	and
2	along	a	flow	path:	Here	E	represents	energy.		Add	and	define	baffles	and	flux	surfaces	Follow	the	annotated	diagram	to	locate	solid	(flow-deflecting)	baffles	and	measurement	planes.	Choose	the	Install	Extension...	When	you	click	OK,	the	Limits	sliders	will	reset	to	show	the	I	J	K	cell	number	in	the	selected	block	at	their	sides.		Check	the	mesh	and
geometry	resolution		Check	the	mesh:	o	Visually	check	the	grid	line	matching	between	neighboring	mesh	blocks.	Start	the	simulation	by	selecting	Simulate	>	Run	Simulation	>	Local	from	the	menu	bar	at	top.	Selected	data	is	useful	for	creating	smooth	animations	and	seeing	detailed	flow	patterns	develop	and	change.	Each	grid	cell	retains	a	single
coordinate	point	out	of	all	the	original	points	in	that	cell;	the	points	that	are	not	retained	are	thrown	away	and	do	not	appear	in	the	.stl	output.	Find	the	blade	angle	using	trigonometry:	a.	Surfaces	that	are	not	flat	are	well-resolved	in	FLOW-3D	without	any	effort	on	your	part!		Move	block	boundaries	by	starting	at	the	required	mesh	plane	location	and
adding	or	subtracting	the	largest	cell	size	repeatedly	until	the	value	is	close	to	the	desired	boundary	location.	The	restart	options	define	what	information	is	taken	from	the	results	and	what	information	is	reset	to	the	current	simulation	initial	conditions.	The	top	of	the	domain	is	open	to	the	atmosphere	(Pressure-type	with	Fluid	Fraction	=	0),	and	the
bottom	of	the	domain	is	a	solid	surface	(Wall).	It’s	clear	from	these	and	the	χ2	tests	that	the	signed	error	is	uniformly	distributed	about	the	mean	and	that	the	.stl	surface	error	(relative	to	the	point	cloud)	is	nearly	unbiased	(neither	higher	nor	lower	on	average).	If	We	is	less	than	or	close	to	1,	consider	surface	tension	physics	(computationally
expensive).	Save	the	final	point	cloud.	Use	Clear	and	try	again,	if	necessary.	Set	func	q	=	-z	(you	may	have	to	use	the	Tab	key	to	gain	access	to	the	input	box),	and	activate	map	into	color.	Select	File	>	Geo-Location	>	Add	Location...	There	is	an	enormous	amount	of	information	in	this	preprocessor	summary,	which	documents	every	step	taken	by	the
preprocessor.		Apply	transformations	to	the	subcomponents:	magnifications,	rotations,	and	translations.	On	average,	the	size	of	the	TOPO2STL	ASCII-format	.stl	output	in	megabytes	(MB)	can	be	estimated	as:	Binary-format	.stl	files	have	the	identical	data	but	are	5.42	times	smaller	than	ASCII	format:	The	above	estimates	are	accurate	within	15%	of
the	actual	size.	9	STEP	7	–	SIMPLIFY/RECOMBINE	FACETS	.....................................................................................................	Include	any	shapes	that	will	be	mass	sources.	The	Implicit	option	is	usually	better	when	a	moving	object	will	have	coupled	(as	opposed	to	prescribed)	motion.	Right-click	Mesh	Block	1	and	select	Mesh	Information…	b.	Page	20	of
21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	cell	summary:	total	number	of	cells	(active	and	passive)	fluid	sub-domain	cells	solid	sub-domain	cells	cells	common	to	both	solid	&	fluid	sub-domains	=	2221792	=	783824	=	66570	=	52888	active	cells	include:	real	cells	(used	for	solving	flow	equations)
open	real	cells	fully	blocked	real	cells	external	boundary	cells	inter-block	boundary	cells	=	652642	=	619659	=	32983	=	33336	=	111528	d.	Name	the	new	fluid	region	Upstream.	Once	you	have	tested	one	or	more	representative	cases	for	a	problem	type	you	can	skip	this	step	for	new	problems	of	the	same	type.	Create	a	new	simulation	named	Weir
Geometry.	In	MicroDEM,	Set	Options	>	Directories	>	FW	Tools	to	the	bin	folder	of	the	installation	(e.g.,	C:\Program	Files	(x86)\FWTools2.4.7\bin).	Custom	file	types	are	flsgrf.xxx	(created	by	the	solver	during	a	run)	and	prpgrf.xxx	(created	by	the	preprocessor)	that	require	you	to	select	output	options	yourself.	Run	the	Simulation	You	already	pre-
processed	the	simulation	in	Exercise	3.	If	you	have	not	completed	Exercise	4	yet,	please	ask	your	instructor	for	a	copy	of	the	results	file.	This	indicates	that	the	first	cell	in	the	domain	is	actually	the	second	cell	in	the	mesh	block	created	by	Page	9	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example
Simulation	the	solver:	the	first	cell	at	J	=	1	is	a	ghost	cell	(outside	of	the	domain)	used	to	compute	boundary	conditions.	However,	it’s	always	a	good	idea	to	eliminate	inter-block	grid	line	mismatch.		Choose	solver	precision	and	number	of	processors	to	use	A	good	practice	is	to	leave	at	least	one	core	(either	1	or	2	processors,	depending	on	whether
hyper-threading	is	active)	for	the	operating	system	and	background	programs.	Most	air	entrainment	experiments	characterize	the	flow	by	a	depth	and	Froude	number	at	the	control	point	at	the	pipe	bend.		Specify	source,	sink,	and	flow	rate	properties.	You	can	switch	between	views	and	information	by	clicking	on	different	branches	of	the	tree.	Some
calibrations	are	discussed	in	the	General	Project	Workflow	Checklist.	a.		Check	the	online	resources	for	similar	cases	Some	classes	of	problems	(ogee	spillways,	for	example)	have	already	been	thoroughly	validated	against	physical	experiments	with	FLOW-3D.	The	conforming	mesh	block	you’re	about	to	create,	however,	is	a	powerful	capability
introduced	in	FLOW-3D	v11.	You	can	also	read	the	diagnostics	files	in	any	text	editor.	Solid	surfaces	and	fluid	free	surfaces	are	drawn	using	all	available	data,	and	are	more	accurate	than	in	3-D	plots.	Make	sure	you’re	not	using	the	old	results	from	the	last	simulation!	2.	Then	Render	again.	Instead,	you’ll	have	to	decide	which	is	more	important:	(1)
resolving	the	corners	of	the	weir	opening	blade	exactly	at	cell	corners,	or	(2)	resolving	the	channel	wall	edges	exactly	at	cell	faces.	Fluid	1	a.	Page	2	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	b.	Right-click	Mesh	-	Cartesian	and	select	Mesh	Block	Summary	Information…	2.	Check	that	you	have	9
subcomponents	in	3	components,	and	that	#2,	#3,	#7,	and	#8	are	the	holes,	as	shown	below.	Launch	qAdmesh	from	FLOW-3D	by	navigating	to	the	Model	Setup	>	Meshing	&	Geometry	tab	and	selecting	Tools	>	qAdmesh	from	the	menu	above	the	viewing	pane.	If	other	flow	quantities	such	as	density	or	scalar	concentration	had	also	been	initialized,
they	could	be	checked	by	selecting	them	in	the	Contour	Variable	dropdown	list	back	on	the	Analyze	>	2-D	tab.	Figure	5:	Finished	mesh	Run	#1:	Scalar	Air	Entrainment	1.		Decide	where	to	place	the	origin.	Initial	Fluid	Elevation	=	0.0149	cm	above	Z	=	0.	Check	the	following	rules	of	thumb	(for	single-machine	parallel	processing):		cell	counts	in	the
hundreds	will	run	in	seconds		cell	counts	in	the	thousands	will	run	in	minutes	Page	6	of	11	FLOW-3D	Version	11	Simulation	Setup							hundreds	of	thousands	of	cells	run	in	hours	or	days		millions	of	cells	take	days	or	weeks	to	run	FAVORize	the	domain	and	check	the	geometry.	Are	they	acceptably	resolved?	These	Selected	Data	sets	are	written	in
addition	to	the	Restart	data.		Give	each	valve	a	descriptive	name,	and	mark	it	on	the	diagram.	Add	the	relevant	engineering	information	for	each	of	these	options	to	the	diagram.	Select	extruded	faces	and	the	rectangular	plane	together.	This	has	not	been	demonstrated	for	all	cases.	At	the	top	of	the	folder	window	select	Organize	>	Folder	and	Search
Options	>	View	tab.	solid	or	gas).	Select	File	>	Geo-location	>	Show	Terrain	to	three-dimensionalize	the	terrain	map.		Note	a	rationale	for	each	value	entered	or	left	at	default	setting.	memory.	Under	Selected	Data,	check	the	boxes	for:	a.	If	there	is	an	error,	edit	the	Mesh	Plane	coordinate	manually	in	the	Mesh	Block	tree,	or	right-click	the	incorrect
Mesh	Plane	and	select	Delete,	then	Add	it	again.	If	not,	try	to	explain	why	or	make	the	model	better.		Check	the	pre-processed	output	in	2-D	slices						Are	fluid	and	geometry	initialized	in	the	correct	locations?	This	step	permanently	shifts	the	saved	cloud	coordinates.	Don’t	worry	about	entering	the	values	right	now,	just	try	to	follow	the	ideas:	a.	Select
Data	Source	=	Selected.	Two	common	methods	are	Clustered	Vertex	subsampling,	which	reduces	the	data	via	a	one-per-gridded-cell	approach	(either	averaging	the	point	coordinates	in	a	cell	or	taking	the	single	point	closest	to	the	center),	and	Poisson-disk	subsampling,	which	uses	a	stochastic	method	to	retain	points.	There	are	many	other	features
of	netfabb	Basic	that	you	can	explore	on	your	own.	Adjust	Transparency	so	you	can	see	the	entire	plane.	Select	Add	and	browse	to	select	your	.3ds	or	.obj	file.	Use	Ctrl+left-click	to	zoom	back	out.	View	and	Interpret	the	3-D	Results	1.	Then	select	Filters	>	Sampling	>	Vertex	Attribute	Transfer.	Whenever	a	higher-order	method	gives	significantly
different	results,	you	must	make	a	choice	as	to	whether	or	not	to	use	it.	If	they	work,	the	solver	will	run	more	slowly,	but	accuracy	will	either	be	improved	or	will	not	be	affected.	The	weir	is	40	units	wide	(centerline	at	y=0),	17	units	tall	(base	at	z	=	0),	and	about	1.1	units	wide	(upstream	face	at	x	=	-0.1).	Note	that	the	message	below	stays	open:	do
not	click	OK	on	it	again.	There	are	4	choices	which	always	need	to	be	made	on	this	tab.	Creating	a	3-D	Animation	The	next	step	will	be	to	create	an	animation	of	the	3-D	fluid	surface.	The	remaining	edges	of	all	three	blocks	must	be	shifted	slightly	now	to	make	all	distances	even	multiples	of	the	cell	size.	You're	Reading	a	Free	Preview	Pages	49	to	52
are	not	shown	in	this	preview.	f.	Page	3	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	VISCOSITY	AND	TURBULENCE	Walls	are	free-slip	surfaces	when	flow	is	modeled	as	inviscid.	If	you	were	to	do	this	now,	you	would	use	a	text	import	function	to	separate	the	space-delimited	values	and	some	method	of
averaging	the	later	quasi-steady	results.	Copy	the	completed	simulation	into	the	new	folder:	a.	If	it’s	not,	right-click	the	topo	subcomponent	and	Reassign	it	to	a	new	component.	3)	The	long:short	aspect	ratio	of	any	single	cell	should	be	no	greater	than	3:1.	In	this	exercise,	mesh	planes	could	be	omitted	altogether,	except	that	it’s	important	you	learn
how	to	use	them.	From	this	visualization	it	is	clear	that	the	majority	of	the	error	magnitudes	are	much	less	than	0.03	feet	(less	than	1	cm).	Chem	Engrg.	Model	time	to	steady	state	also	depends	on	the	mesh	resolution:	for	example,	meshes	that	are	too	coarse	or	have	very	poor	aspect	ratios	may	not	converge	to	steady	state	at	all.	Rather,	it	is	meant	to
be	a	checklist	with	a	middling	level	of	detail.	Select	the	other	Color	Variables	from	the	dropdown	in	the	upper	left	corner	of	the	interface.	You	may	need	to	right-click	the	History	Probe	and	Baffle	to	adjust	their	transparency	and	the	probe’s	size.	Note	that	there	is	no	solid	geometry	in	this	simulation.	A	hydraulic	jump	forms	in	the	downward	bend	of
the	pipe,	as	shown	in	Figure	1,	below.	Page	6	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	Figure	4.	LIMITED.	Read	the	analysis	in	the	Context	Area	and	find	where	it	reports	that:	(a)	the	surface	is	not	closed,	and	(b)	there	is	1	hole	with	3	boundary	edges	and	0	bad	edges.	7	This	project	workflow
guide	is	not	an	exhaustive	decision-tree	for	all	elements	of	a	project.	Consider	subsampling.	Look	for	the	extent	and	characteristics	of	the	entrained	air.	o	No:	consider	a	two-fluid	model	and	decide	if	the	gas	can	be	treated	as	nearly	incompressible	or	must	be	treated	as	fully	compressible	(costs	more	resources).	the	geometry	to	1.	The	experimental
results	reported	are	purely	a	function	of	the	inlet	and	outlet	pressures	in	the	absence	of	gravity.	Select	(click	to	highlight)	the	workspace	Hydraulics	Examples	in	the	Portfolio.	You	should	already	know	how	to	do	this	from	previous	exercises.	Make	the	upstream	(x-min)	boundary	velocity-type:	a.	Do	not	include	the	generated	2-D	grid	that	was	added	to
make	the	upper	surface	of	the	.stl.	Add	Mass/Momentum	Sources	to	the	Pipes	Mass/momentum	sources	and	sinks	are	flat	planes	that	add	or	remove	fluid.	Scroll	down	in	the	Data	Variables	list	and	select	the	following:	a.	This	plots	the	solids	as	well.	The	offending	cell	number	is	i,	j,	k	=	82,	34,	17.	Draw	a	selection	box	to	select	the	surfaces	below	the
rectangle	and	Delete	the	extended	surfaces,	including	the	rest	of	the	rectangle	that	extends	past	the	topography.	If	you	look	carefully	at	the	mesh,	you’ll	see	that	the	coarse	blocks	do	not	satisfy	this	(they	have	~	1.5	cells	across	the	weir),	and	the	fine	block	has	only	3	cells	across	the	weir.	Activate	Model	Setup	>	Physics	>	Density	Evaluation	>	First
Order	Approximation	to	Density	Transport	Equation.	Select	the	Mesh	checkbox	to	overlay	the	mesh	on	the	results.	13,305	geodetic	controls)	15-m	TOPO2STL	spacing	-0.10	m	3.6	m	2.4	m	2.6	m	(.stl	surface	vs.	Try	out	the	transparency	options.	Click	the	Grab	button	to	lay	the	selected	topography	image	on	the	SketchUp	map.	Click	Apply.	This	makes	it
easier	for	the	solver	to	converge	(faster	runtime),	and	allows	pressure	waves	(e.g.,	water	hammer)	to	propagate.	Figure	25.	Learning	Objectives	In	this	exercise	you	will	learn	techniques	to:	1.	FAVORize	again	and	check	your	work	against	the	picture	below.	Adding	two	points	per	velocity	gives	us	the	desired	profile,	which	looks	like	this:	Figure	7:
Desired	velocity	profile	At	each	step	in	the	velocity	profile,	the	elapsed	time	between	the	lower	step	and	the	upper	step	is	arbitrarily	selected	to	be	one	second,	since	FLOW-3D	requires	that	each	boundary	condition	time	step	Page	13	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	have	only	one	associated
value.	Make	sure	that	Weir	Mesh	is	the	highlighted	project	on	the	Simulation	Manager	tab.	7	Report	results................................................................................................................................................	Each	approach	uses	different	coefficients	and	is	valid	for	a	specific	set	of	conditions.	Report	results	for	the	variables	of	interest	from	the	design	mesh
resolution.	This	is	one	method	of	sampling	(decimation).	Check	&	Fix	the	.stl	File	The	starting	point	for	developing	a	new	simulation	is	making	the	geometry.	Now	turn	Geometry	Surface	0	back	on	to	see	the	contrast	between	the	embedded	geometry	iso-surface	and	the	original	defined	subcomponents.	Page	4	of	7	FLOW-3D	Version	11	CFD	Project
Overview		Adjust	the	finish	time	(if	desired).	If	the	answers	to	the	above	questions	are	yes,	the	simulation	is	configured	adequately.	Given	the	above	table,	FLOW-3D	will	generate	an	inflow	velocity	profile	that	looks	like	Figure	6	below:	Page	12	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Figure	6:
Incorrect	interpolation	of	velocity	profile	This	is	not	desired!	The	model	should	match	the	experiment.	The	display	switches	automatically	to	the	Display	tab,	and	a	new	Streamline	Edit	dialog	appears.	Leave	the	rest	of	the	boundaries	in	Block	1	as	Symmetry	(S)	for	now.	Right-click	the	prepin.Weir_Geometry	file	and	Rename	it	to	prepin.Weir_Mesh.
Mass-averaged	mean	kinetic	energy	and	Mass-averaged	mean	turbulent	energy:	the	domainaveraged,	time-mean,	kinetic	and	turbulent	kinetic	energies.	Note	that	too	much	simplification	can	make	a	watertight	surface	impossible.	Click	Units	at	the	bottom	right	of	the	screen.	Save	the	output.	The	sharp	crest	of	the	weir	indicates	the	mesh	resolution	is
probably	adequate	for	capturing	the	important	geometric	features,	and	Page	10	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	that	the	rounded	edges	in	the	FAVORize	view	were	due	to	poor	iso-surface	fitting.	If	the	cell-to-cell	viscosity	varies,	consider	borrowing	the	solidification
variables	as	discussed	in	the	lecture	on	Multiphase	Flow.	This	setup	will	be	used	in	future	exercises	to	simulate	flow	over	the	weir	as	well	as	outfall	from	pipes	at	the	base	of	the	weir.	Select	Subcomponent	>	Geometry	File(s)	from	the	dropdown	menu	above	the	display	pane.	Turn	on	Mesh	>	View	Mode	>	Grid	Lines	if	necessary.	Toggle	between
coordinates	by	changing	the	Active	dropdown	selection	in	the	Properties	pane	>	Scalar	Fields	section.	Select	Component	Iso-Surface	Overlay	=	Solid	Volume.	Import	an	Existing	Simulation	File	The	starting	point	for	this	exercise	will	be	the	simulation	created	in	Exercise	2.	The	curve	parameters	are	given	above	the	chart.	Does	the	mentor	suggest	an
implicit	method?	2012).	The	only	run-time	error	reported	in	this	simulation	is	a	single	convective	flux	error	which	does	not	affect	solver	accuracy.	Repeat	as	necessary.	They	can	be	solid	or	porous.	In	rivers	Tu	often	exceeds	10%!	The	brackets	give	us	two	more	possible	values:	Estimation	Method	Full-pipe	Tu	≈	1%	Full-pipe	Tu	≈	0.16Re-1/8	≈	1.6%
Full-pipe	Tu	≈	5%	kT	(cm2/s2)	7	17	165	εT	(cm2/s3)	8	33	998	*****	Note	that	there	is	no	widely	agreed-on	method	of	deducing	upstream	turbulent	parameters,	and,	as	shown	in	Figure	3	below,	the	effect	of	an	arbitrary	value	can	be	significant!	For	this	reason,	some	CFD	modelers	prefer	to	model	upstream	turbulence	explicitly,	even	if	it	requires	more
than	one	simulation.	This	exercise	applies	and	expands	the	techniques	introduced	in	Exercise	1.	Point	clouds	are	one	of	the	most	common	ways	that	topographic	data	is	recorded.	The	view	in	the	interface	will	automatically	switch	to	the	Simulation	Manager	tab	and	the	preprocessor	will	start,	followed	by	the	runtime	solver.	Page	13	of	16	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	Add	Subcomponent	Holes	to	Represent	Pipe	Outfalls	We	will	now	add	the	final	pieces	of	the	geometry	by	creating	two	cylindrical	holes	in	the	weir	face.	The	most	recent	point	probe	value	is	also	shown	in	the	bottom	left	margin	of	the	FLOW-3D	window.	Browse	and	pick
MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833.xyz.	Consider	defining	transformation	centers	for	subcomponents	that	need	multiple	transformations.	Locate	Compressibility	and	set	it	to	4.55e-10	Pa-1.	Select	the	following	plots	from	the	list	on	the	left	of	the	screen:	a.	Click	Render.	Clicking	anywhere	except	on	the	part	will	deselect	it.	Save	your
work	so	far.	If	there	are	non-manifold	holes,	first	close	and	re-launch	the	Fill	Holes	tool:	sometimes	it’s	wrong.		Determine	the	physics	packages	that	are	part	of	the	modeling	approach	Now	decide	which	physical	mechanisms	are	important.	Comments	and	experiences	should	be	addressed	to	the	author	([email	protected])	or	Flow	Science	support	staff
([email	protected]).	Select	File	>	Export	>	3D	Model...	Some	of	the	most	common	artifacts	are	small	holes,	disconnected	edges,	triangles	with	bad	aspect	ratios,	and	inverted	facets.	endsolid	indentation	must	be	with	spaces	(no	tabs)	are	facet	normal	vector	components	in	single	precision	float	and	may	be	negative.	The	MeshLab	simplification	and
repair	procedure	with	qAdmesh	finishing	is	recommended	for	general	use	because	it	can	be	performed	on	parts	that	are	too	detailed	to	load	with	the	other	methods,	and	it	further	reduces	the	final	.stl	file	size.	k.	1-inch	resolution	.stls	with	(right)	and	without	(left)	data	pre-conditioning	Page	2	of	26	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	9:	Converting	Topography	to	.stl	2)	Use	TOPO2STL	to	convert	the	point	surface	to	a	3-D	.stl	file:	a.	This	selection	is	unimportant	since	there	will	be	no	heat	transfer	in	this	simulation.	1.	65.13487244	183.29547119	99.29799652	Table	2.	The	grid	is	made	of	square	stencils	of	the	specified	side	length.	Pressure	iteration	count:	The	number	of
iterations	of	the	pressure	solver.	Examples	of	some	of	the	available	plot	types	will	be	generated	in	the	next	step.	Here	we	will	check	whether	gravity,	surface	tension,	viscous	flow,	turbulence,	and	porous	media	physics	are	needed.	In	the	DB	Tree,	un-check	the	Mesh	part	to	hide	it	and	then	select	the	Cloud	entity.		Refine	the	mesh	uniformly	in	all
directions	by	the	selected	refinement	factor.	Increasing	mesh	resolution	will	usually	improve	the	match	between	iso-surface	and	original	geometry.	Save	your	work!	Now	the	fourth	mesh	block	will	include	even	finer	cells,	but	only	within	a	distance	of	one	meter	of	the	weir	plate.	On	the	theoretical	derivation	of	Darcy	and	Forchheimer	formulas.
Geometry:	defined	in	the	Geometry	Window	.	the	known	%loss	due	to	convective	flux	error	and	inter-block	interpolation	error	10.	Therefore,	the	thickness	of	the	nappe	could	be	used	to	estimate	the	maximum	turbulent	length	scale,	but	perhaps	the	most	turbulent	region	is	the	pipe	outfall	after	all!	Since	we	do	not	know	enough	to	confidently	specify
the	maximum	mixing	length,	we	will	ask	FLOW-3D	to	determine	the	maximum	turbulent	length	scale	for	us.	No	density	variation	due	to	entrained	air	is	included.		Are	all	specified	baffles	in	the	expected	location?	Fill	Fraction,	Volume	of	fluid	1,	and	Fluid	1	surface	area:	self-explanatory.	This	is	important	information,	since	the	number	of	active	cells
directly	relates	to	the	simulation	run	time.	Compare	the	results	to	the	physical	experiment,	as	shown	below.	Are	there	any	lines	where	res/epsi	>	1,	and	an	asterisk	*	is	written	next	to	res/epsi	to	mark	a	failure?	TOPO2STL	generates	a	network	of	triangular	facets	using	the	vertices	as	corners.	6.	The	first	and	last	output	times	should	be	similar	to
these:	6.	View	the	results	in	2-D	using	Restart	Data	and	Contour	Variable	=	Macroscopic	Density.	The	only	implicit	solver	in	our	model	is	the	pressure	solver,	so	this	suggests	that	the	pressure	solver	is	working	well.	They	can	be	made	to	move	with	solid	objects	or	float	freely	in	the	flow.	Select	Units	>	CGS	to	avoid	converting	the	output	units.	12	STEP
9	–	CLOSE	TRIVIAL	HOLES	...................................................................................................................	It	is	preferable	to	find	input	uncertainty	using	the	design	mesh,	but	using	a	coarse	mesh	is	much	faster.	Experiment	with	the	buttons	above	the	view	pane.	Select	the	Part	Repair	branch	and	click	Automatic	Repair	at	the	bottom	of	the	information
display.	The	rule	of	thumb	is	that	solids	need	at	least	2	full	cells	and	liquids	need	at	least	4	full	cells	across	their	narrowest	thickness.	Activate	the	Select	Vertexes	on	a	Plane	tool	and	roll	the	mouse-wheel	to	set	the	HopThru	size	to	less	than	0.5.	Hold	Control	and	click-drag	the	mouse	to	add	and	size	selections.	Request	Hydraulic	Data:	Select	the
Model	Setup	>	Output	tab.	If	they	are	reversed,	select	Yes.	Clear	and	close	the	probe	points	dialog.	See	that	the	boundary	layer	develops	rapidly	and	observe	the	pattern	and	magnitude	of	scalar	air	entrainment.	Check	the	volume	and	surface	area	of	the	part.	Y	low	=	-4,	Y	high	=	-3.	Check	the	boxes	for	weir1_repaired2.stl	and
Topo_Example_04_fixed.stl	to	copy	the	geometry.	Each	triangle	(facet)	which	makes	up	the	surface	is	described	by	three	Cartesian	vertices	and	a	normal	vector	pointing	outward	from	the	enclosed	volume.	Use	the	Quadric	Edge	Collapse	filter	to	reduce	the	bounding	box	facet	count	with	a	target	of	90%	fewer	facets	and	the	other	options	shown	in
Figure	16	below.	Page	2	of	10	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	iv.	Fig	6.	You	have	the	options	of	Import	Tables	to	Prepin	or	Link	External	CSV	Data	to	Prepin.	Find	a	good	setting	for	the	Transparency	slider.	Practice	the	.stl	import	process	by	importing	Topo_Example_04_fixed.stl	as	follows:	a.	Each
time	frame	will	be	rendered	to	the	Display	window	and	bitmaps	will	be	written	(and	then	deleted)	in	the	simulation	directory.	The	inner	radius	is	like	pipe	inner	diameter;	it	must	set	it	in	the	tree	under	Limiters	and	with	the	undefined	outer	radius	will	make	everything	outside	the	inner	radius	solid.	This	makes	the	piston	solid.	Make	sure	you’re
plotting	with	SI	units.	The	time-averaged	flow	rate	can	be	found	by	copying	and	pasting	the	data	into	a	spreadsheet.	Component-	and	Subcomponent-specific	Transparency:	these	can	be	set	in	the	Geometry	tree	(toggle	).	solver	process	that	requires	the	limiting	time	step,	as	a	two-letter	code	(cx	=	x-direction	convective	fluid	flux,	for	example)	6.	If	the
calibrated	values	are	far	from	physically-realistic	values,	be	prepared	to	explain	why	(e.g.,	the	physics	model	used	is	Page	6	of	7	FLOW-3D	Version	11	CFD	Project	Overview	mesh-dependent,	and	a	physically-realistic	input	value	requires	a	mesh	resolution	that	is	not	feasible	for	the	project	time	constraints).	Click	OK	to	finish	importing.	FLOW-3D
always	assumes	that	flow	in	porous	media	is	Laminar,	but	turbulence	may	be	included	for	free-water	regions	above	and	below	the	media.	Rule	of	Thumb	A	conservative	measure	of	the	time	for	a	free-surface	fluid	system	to	reach	steady	state	is	10	to	20	times	that	required	for	a	fluid	packet	to	pass	through	the	system.	Save	your	work.	It	is
recommended	that	you	use	qAdmesh	after	netfabb	Basic	as	a	final	check.	Loads	entire	file	into	NO.	Make	sure	the	Extrude	Tools	plugin	is	active	in	System	Preferences	and	click	OK.	Make	a	simulation	copy	and	perform	a	restart.	A	refinement	factor	of	2	is	common	(increasing	the	cell	count	by	a	factor	of	8),	but	any	ratio	larger	than	1.3	is	acceptable.
Re-check	it	with	qAdmesh	and	verify	there	are	no	artifacts.	Extrude	in	-z	axis.	Open	the	data	in	CloudCompare.	If	the	file	is	small	enough	(<	420	MB),	re-check	the	saved	final	.stl	with	the	netfabb	Basic	Standard	Analysis.	The	student	will	set	up	the	first	model	from	a	set	of	specifications	as	an	exercise	in	critical	thinking.	Go	through	all	four	blocks.	In
this	simulation,	FLOW-3D	added	0.21	m3	of	volume	and	the	total	open	volume	in	the	mesh	is	383	m3.	In	the	new	source,	change	only	Geometries	>	Translation	>	Y	=	-1.		Turbulence	at	inlet	boundaries	can	affect	some	models.	Locate	the	cell	at	I	=	82,	J	=	34,	K	=	17:	a.	Total	time	about	3	minutes.	Edit	the	cutoff	values	in	the	Properties	pane	>	SF
Display	Params	section	to	help	visualize	the	elevation	gradients.	Name	the	file	weir1_repaired.stl,	and	make	sure	it’s	being	saved	into	the	Weir	Geometry	project	folder.	Right-click	on	Mesh	–	Cartesian	in	the	tree	and	select	Add	a	Mesh	Block.	When	prompted,	shift	each	cloud	by	-300,000.00	m	in	x,	3,000,000.00	m	in	y,	and	0.00	m	in	z.	2	STEP	3	–	USE
CloudCompare	TO	COMBINE	AND	TRIM	TOPOGRAPHY	.........................................................	This	will	require	a	fine	mesh	to	resolve.	6)	The	ideal	cell	size	ratio	across	an	inter-block	interface	is	2:1.	The	purpose	of	this	step	was	to	demonstrate	the	poor	fit	of	most	empirical	correlations.	Select	View	>	Probe	Points	List	…	from	the	display	pane	menu.
Click	on	the	color	palette	next	to	Mesh	Block	1	and	experiment	with	different	grid	line	and	mesh	plane	colors.	Global	Transparency:	The	Global	Transparency	slider	in	the	toolbar	controls	the	transparency	of	all	objects	in	the	display	window.	If,	however,	you’re	interested	in	the	nappe	impingement	and	its	effect	on	the	downstream	topography,	then
the	model	has	a	problem	and	should	be	re-meshed	to	enclose	the	nappe	in	a	single	block.	Set	X-axis	=	0	and	repeat	the	process	for	Y-axis.	Create	Upstream,	Downstream,	and	Nested	Overlapping	Mesh	Blocks	The	region	near	the	weir	will	be	characterized	by	sharp	changes	in	momentum	(especially	at	the	overflow	nappe)	and	thin	geometry	(the	weir
is	only	about	a	foot	thick).	However,	the	rest	of	the	exercise	will	assume	that	you’ve	entered	the	values	as	shown	below.	o	Initial	Pressure	=	Hydrostatic	Measurement	Stations	o	Flux	Surface	Baffle	w/	Porosity	=	1	at	X	=	95	cm	o	History	Probe	at	X	=	60	cm,	Y	=	0.5	cm,	Z	=	7.5	cm	o	Sampling	Volume	from	X	=	60	to	X	=	95,	Y	=	0	to	1,	Z	=	0	to	15	cm
Set	up	the	model	and	check	each	bullet	off	as	you	go.	The	list	remains	populated	until	you	select	Clear	Probe	Points.	Constant	fluid	volume	and	surface	area	are	two	indicators	that	the	simulation	has	reached	steady	state.	After	the	meshblock	mismatch	errors	discussed	in	There	is	one	warning,	which	is	displayed	below.	Gray	region	is	outside	2
standard	deviations.	Look	at	Diagnostics	>	Solver	Errors	to	find	the	IJK	locations	of	the	failures.	Delete	the	overlapping	points	on	the	plane	grid,	and	then	raise	the	plane	back	to	571	m.	You	do	not	need	to	color	the	surface	by	a	flow	parameter	right	now.	Check	that	Geometry	Surface	=	Solid	Volume	and	ISO	Surface	Value	=	0.5	(more	or	less).	Process
was	10.7	GB	ASCII	.stl	10.7	GB	ASCII	.stl	manually	terminated.	Click	and	hold	the	left	mouse	button	somewhere	to	the	upper-left	of	the	weir	and	color	bar,	and	drag	the	selection	box	that	appears	so	it	encloses	the	weir	and	color	bar.	10	Run	the	simulation	......................................................................................................................................	Use	Edit	>
Apply	Transformation	and	enter	the	calculated	values	for	the	Tx	and	Ty	entries	in	the	transformation	matrix.	1-D:	Flow	parameters	and	other	data	can	be	viewed	along	a	line	of	cells	in	the	X,	Y,	or	Z	direction.	Volume	stays	constant.	Edit	Fluid	Parameters	and	Add	Limited	Compressibility	1.	The	format	is	raw	and	unstructured,	meaning	that	the
elements	of	the	surface	can	be	recorded	in	any	order.	Global	>	Fluid	Initialization	=	Use	Initial	Fluid	Elevation	d.		Define	how	to	restart	the	simulation	from	existing	results	(optional)	Restart	options	allow	initialization	from	an	existing	results	file.	Each	boundary	has	a	one-	or	two-character	identifier	that	can	be	clicked	on	to	change	it.	The	results	are
shown	in	Figure	18.	Check	that	the	Time	Frame	Min	and	Max	cover	the	entire	duration	of	the	run.	Place	the	plane	so	it	cuts	through	the	extruded	faces.	Select	Fill	and	wait	for	the	Accept	check-boxes	to	appear:	mark	all	the	boxes	and	click	Accept	at	the	bottom	of	the	Page	16	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:
Converting	Topography	to	.stl	tool	dialog.	The	project	has	now	been	imported	into	the	Hydraulics	Examples	workspace.	If	yes,	consider	using	viscous	flow	physics	(almost	always	used).	12.	Open	the	new	Weir_Mesh	folder	and	use	Ctrl+V	to	paste	the	three	files	into	the	new	simulation	folder.	The	resolution	of	both	blocks	is	too	coarse,	so	now	set
uniform	cell	sizes	in	each	block.	Make	sure	the	source	mesh	is	the	point	cloud	and	the	target	mesh	is	the	new	plane.	Check	that	you’ve	made	the	selections	above	(marked	below	for	reference)	and	click	Render.	Specify	Selected	Data	output:	Selected	data	are	user-specified	output	parameters	that	are	written	to	the	results	more	frequently	than	Restart
data.	This	is	an	instantaneous	value	in	an	oscillating	flow;	the	time-average	is	better	for	reporting	and	is	6.6%	by	volume	over	the	final	2.5	seconds.	Also	set	in	the	subcomponent	Limiters;	this	bevels	the	outer	surface	of	the	torus	so	it’s	straight	perpendicular	in	z.	Save	the	fused	cloud	as	ASCII	.xyz	format	with	the	options	shown	below.	iv.	FLOW-3D
Learning	Objectives	In	this	exercise	you	will	learn	techniques	to:	1.	Check	Import	from	Simulation	Directory	to	tell	the	interface	where	to	start	browsing.	This	is	the	cell	specified	by	the	warning	message.	They	can	also	be	used	to	remove	fluid	if	they	are	placed	so	they	are	always	underwater.	l.	Page	8	of	24	Water	&	Environment	Training	on	FLOW-3D
v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	The	3-D	subtab	will	be	displayed	initially	when	the	Analyze	tab	is	selected.	Page	5	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	5.	the	fraction	of	the	open	domain	volume	that	is	filled	with	fluid	frac,	11.	You	can	safely
deactivate	the	cells	above	a	reasonable	Z-elevation.	Two	USGS	1-degree	tiles,	converted	to	DEM	with	MicroDEM	and	FWTOOLS	MicroDEM	has	the	option	to	simultaneously	open	&	merge,	but	memory	limitations	in	the	executable	prevent	this	from	being	useful	for	large	data	sets.	These	will	be	placed	along	geometry	surfaces	to	better	resolve	them.
retrieved	3/7/2013.		Volume	Fraction	of	Phase	#2	at	Inversion	Point	is	the	maximum	volumetric	fraction	of	air	in	a	cell	before	the	continuous	and	dispersed	phases	switch	so	that	air	is	considered	continuous.	netfabb	Basic,	MeshLab,	and	qAdmesh	(which	comes	with	FLOW-3D)	are	free	tools	for	repairing	.stl	files.	Specified	intervals	are	in	units	of	time
between	outputs.	Use	CloudCompare	to	import	and	re-export	the	data:	CloudCompare	is	a	useful	free	tool	for	working	with	large	point	cloud	files.	Running	the	Simulation	1.	Set	the	file	format	type	to	ASC	(ascii	triplets	of	points)	and	open	MiddleRioGrande.asc.	Plot	results	at	the	center	of	the	top	(inlet)	of	the	cylinder	(I	=	2,	K	=	22).	In	onefluid
models	momentum	is	solved	in	regions	where	F	>	0.	New	blocks	are	created	at	the	origin	and	are	1	m	x	1	m	x	1m.	The	lines	remain.	Press	Ctrl+Del	to	delete	vertexes	(or	select	Filters	>	Selection	>	Delete	Selected	Vertices	from	the	menu	or	from	the	Action	toolbar).	The	progress	bar	at	the	bottom	will	fill	several	times	as	various	importation	steps	are
completed.	Hold	Shift	and	click	on	the	seeding	plane	in	a	corner	near	the	bed,	and	then	in	the	opposite	corner	near	the	surface.	This	is	just	above	the	bottom	of	the	domain.	Page	23	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	C.		Select	number	of	fluids,	interface	tracking,	and
flow	mode	options	Use	the	annotated	diagram	as	a	guide.		Can	experimental	uncertainty	be	quantified	for	the	test	case?	Save	the	simulation.	This	makes	the	baffle	slightly	larger	than	the	opening,	which	may	be	important	when	the	baffle	moves	to	the	nearest	grid	lines.	Adjust	the	model	setup	if	necessary	and	repeat	the	check.	Feel	free	to	suggest
how	this	model	could	be	improved	to	your	instructor.	Search	again	for	area/vol.	Adding	planar	data	to	blank	regions	speeds	up	the	conversion	by	a	factor	of	50	to	100.	………..	The	default	settings	of	these	coefficients	are	often	acceptable,	but	can	be	calibrated	to	better	match	experiment.	Middle:	1-inch	clustered	vertex	subsampling	(emphasizes	1-inch
contour	lines).	The	cell	size	that	gives	most	closely	approximates	a	square	is	then	dx	=	0.16764	and	dy	=	0.16933333.	At	every	time	step,	pressures	and	velocities	are	solved	in	all	cells	with	fluid	until	the	residual	Ū	(a	measure	of	potential	error)	in	each	cell	is	less	than	some	small	cutoff	value	epsi.	Note	how	a	supercritical	jet	expands	away	from	the
wake,	while	the	rest	of	the	pool	is	subcritical.	Locate	the	new	Subcomponent	2	added	to	Component	1	in	the	Geometry	tree.	Add	Streamlines	1.	Click	Apply	Repair	and	then	choose	to	Remove	Old	Part.	The	remaining	parameters	are	selected	based	on	knowledge	of	the	physical	case.	The	estimate	of	Max	Relative	Error	gives	the	likely	error	of	the
distance	results	themselves	as	a	function	of	the	distance	d	between	any	point	and	the	.stl.	The	status	listed	under	Final	indicates	no	errors,	so	the	file	has	been	fixed.	o	Specify	the	Cartesian	or	Cylindrical	coordinate	system.	Drag	coefficients	will	be	determined	from	experimental	data	given	by	Abood	(2009).	For	this	case,	select	Import	Tables	to
Prepin.	The	physics	models	are	in	alphabetical	order	from	top	to	bottom,	left	to	right.		Give	each	spring/rope	a	descriptive	name,	and	mark	it	on	the	diagram.	Approximate	region	of	interest,	viewed	at	STEP	2	–	USE	MicroDEM	TO	CONVERT	DATA	TO	POINT-CLOUD	FORMAT	Download	MicroDEM	from	Professor	Peter	Guth’s	page	at	the	U.S.	Naval
Academy	website:	.	There	are	a	number	of	choices	for	turbulence	models.	Remember	to	Render	again	after	adding	a	point.	Control	+	Shift	+	mouse	wheel	to	move	“far”	clipping	plane.	Note	that	the	Drift	Flux	model	requires	1st	or	2nd	order	Density	Evaluation	physics.	Select	Mesh	>	View	Mode	>	Mesh	Planes	to	view	only	the	specified	planes.	Check
the	Geometry	tree	to	make	sure	the	topography	is	part	of	Component	3.	Curve-Fitting	Experimental	Data	The	drag	model	equation	is	given	below	in	simplified	form	for	fitting	experimental	data:	(	)	A	and	B	are	coefficients	fitted	to	the	experimental	data.	This	allows	you	to	edit	the	simulation	name,	which	is	the	extension	to	the	prepin.xxxx	file.	The	view
will	change	to	the	Simulation	Manager	tab,	and	the	solver	text	will	show	the	steps	as	they	are	completed.	These	boundaries	will	be	reset	to	‘inter-block’	type	by	the	preprocessor.	Z	low	=	undefined	(blank,	not	zero),	Z	high	=	0.15	cm	2.	This	is	a	time-consuming	algebraic	exercise,	which	is	why	it’s	often	skipped.	Review	Solver	Warnings	.	Uncheck	the
default	values	option	and	enter	the	values	shown	below.	There	will	likely	be	some	flow	curvature	near	the	weir	corners,	so	although	it	may	not	help	(and	will	definitely	slow	down	the	run)	we	will	add	a	higher	order	momentum	advection	method.	Open	the	Limiters	branch	of	the	tree	fluid	region	tree.	If	it	does,	use	values	that	correspond	to	physically-
realistic	turbulence	intensities	at	the	boundaries.	Three	methods	of	fixing	Page	12	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	and	converting	the	part	are	demonstrated	here;	the	third	also	introduces	post-conversion	simplification	of	unnecessary	surfaces.		Rotate	the	mass-momentum	source	to	get
the	desired	flow	direction	normal.	Compare	the	model	results	to	the	physical	or	empirical	results.	The	total	and	fluid	counts	are	both	around	50,000	cells.	If	your	output	doesn’t	change	significantly,	then	use	the	more	robust	and	faster	default	option.	The	interface	will	prompt	you	to	Save	the	FAVORize	selections	you	made	(click	Yes)	and	will	then
switch	back	to	the	Simulation	Manager	and	the	preprocessor	will	run.	Figure	5:	Check	the	mesh,	geometry,	and	boundaries	Page	11	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Specify	a	Time-Dependent	Velocity	Boundary	The	time	for	a	fluid	packet	to	pass	through	the	simulation	can	be	found	from	the
domain	length	and	the	superficial	velocity	of	the	fluid	(t	=	L/Umacro).	Eos,	Trans.		Keep	the	values	that	minimize	disagreement	It’s	important	to	remember	that	these	design	values	are	valid	only	for	the	given	mesh,	geometry,	flow	velocity,	and	dimensionless	numbers	(e.g.,	Re,	Fr,	We,	k+).	Experiment	with	probing	surface	coordinates	with	Shift+click.
Leave	Create	Subdirectory	Using	Simulation	Name	checked.	First	de-select	Geometry	Surface	0	to	turn	off	the	FAVORized	iso-surface.	For	your	Page	4	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	future	reference,	the	equation	is:	Limited	Compressibility	RCSQL	=	1/K	=	1/(ρf	W2).	In	a
completely	saturated	loose	media	ηeff	can	be	assumed	to	be	the	same	as	bulk	porosity	η	(0.50	in	this	case).	Neutral	File:	Restart	and	Selected	Data	can	be	interpolated	to	give	results	at	a	set	of	user-defined	points.	Set	Add	to	Component	=	2:	channel	for	both	copies.	Frictional	losses	will	be	zero	when	there	is	no	flow,	and	the	above	equation	then
indicates	that	the	static	pressure	head	at	the	outlet	will	be	greater	than	the	static	pressure	head	at	the	inlet	by	0.4	m.	The	negative	sign	points	the	gravity	vector	downward.	The	goal	is	to	minimize	the	X	and	Y	extents	of	the	topography.	Recommended	CloudCompare	Save	options	Figure	5.	Shift+left	click	and	drag	to	remove	the	faces	or	vertices	in
the	box	from	the	already-selected	group.	Check	units	and	values	carefully.	This	makes	the	appropriateness	of	the	downstream	boundary	unclear.	The	same	process	can	be	applied	to	the	Z	direction,	where	the	important	geometry	is	the	bed	and	the	weir	crest.	When	this	branch	is	selected,	individual	facets	and	points	can	be	added	and	deleted	and
automatic	repairs	can	be	applied.	Repeat	the	Shift	+	click	process	for	the	other	two	corners,	to	make	an	X	with	24	points.	Component	2	>	Component	Properties	>	Type	of	Moving	Object	>	Edit	Moving	Object	Properties	>	Initial/Prescribed	Velocities	tab	>	Tabular	Z	Translational	Velocity	Components	per	the	table	below	(see	next	page).		Add	and
define	mass-momentum	sources	Mass-momentum	sources	are	boundary	conditions	located	inside	the	mesh	(as	are	mass	sources,	valves,	and	vents).	Select	the	Model	Setup	tab	and	then	the	Meshing	&	Geometry	tab	below	that.	Over-Relaxation	Factor	OMEGVS	=	0.8	6.	Page	6	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting
Up	Geometry	7.	The	example	describes	converting	an	area	of	interest	from	1/3-arc-second	resolution	USGS	data	in	ArcGrid	format	to	DEM,	point	cloud,	and	finally	.stl	formats.	Check	whether	turbulence	occurs	in	free-water	regions:	the	media-filled	pipe	is	0.24	m	in	diameter,	and	the	maximum	free-stream	velocity	is	0.02	m/s.	Page	1	of	10	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	Define	Fluid	Parameters	Only	the	fluid	density,	viscosity,	and	surface	tension	properties	are	needed	for	this	simulation.	Note	that	MicroDEM	is	under	heavy	development	as	of	Fall	2013,	so	refer	to	its	Help	file	for	more	current	instructions.	They	measure	flow	accurately	only
when	certain	approach	and	downstream	conditions	are	met	and	when	their	construction	follows	established	guidelines.	If	you	need	to	reset	the	view,	you	can	select	Windows	>	View	From	>	Front.	This	gives	a	well-fit	correlation	as	shown	below.	This	value	may	not	be	physically	realistic!		Select	parameters	to	calibrate	or	keep	fixed	When	possible,
adjust	only	one	parameter	for	each	physics	model	(e.g.,	surface	roughness	for	turbulence,	Critical	Shields	Parameter	for	sediment	scour,	rate	coefficient	for	air	entrainment).	Select	prpgrf.Flow_Over_A_Weir	in	the	dialog	box,	and	OK	to	load	the	file.	Select	and	delete	all	of	the	points	inside	the	originally-scanned	data	area.	The	final	surface	combines
ocean,	bounding	box,	and	topography	layers	Page	8	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	STEP	5	–	ESTIMATE	THE	MINIMUM	STL	RESOLUTION	Use	rules	of	thumb	to	find	the	minimum	resolution.	Run	the	simulation	again.	This	would	cause	poor	printer	performance.	Right-click	the	.chm	file	and
select	Properties	>	Unblock	to	allow	it	to	work	in	Windows	7.	Several	ways	of	accomplishing	each	step	will	be	given.	The	plane	will	be	built	with	both	points	and	facets	on	a	new	layer	named	Grid	Generator	(see	Figure	6	below).	Close-up	of	the	final	15-m	.stl.	13.	TOPO2STL	generates	a	rectangular	sampling	grid	around	the	minimum	and	maximum
horizontal	extents	of	the	point	cloud.	Statistical	fitting	of	the	signed	error	distribution:	normal	(left)	and	Weibull	(right)	Page	21	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	Table	6	below	shows	comparative	mean	error	magnitude	(MAE)	results	for	various	sampling	spacing	and	pre-conditioning
approaches.	A	careful	modeler	would	preprocess	the	simulation	again	now,	but	throw	caution	to	the	wind	and	run	the	model	anyway!	1.	Make	.avi	videos	and	.bmp	images	of	the	results,	9.	Determine	Upstream	Velocity	from	Froude	Number	and	Depth	The	flow	accelerates	and	things	as	it	crests	the	bend	of	the	pipe.	Also	includes	output	for	moving
objects,	history	probes,	flux	planes	(measurement	windows),	control	volumes,	history	particles,	and	more.	You	need	to	know	the	dimensions	of	the	plate	itself,	the	width	and	elevation	of	the	crest	notch,	and	the	angle	of	the	blade	edge	to	guarantee	proper	flow	measurement.	Other	conversion	settings.	Understand	the	options	for	post-processing	in	1-D,
2-D,	and	3-D,	7.	Many	point	sets	only	include	data	in	a	region	of	interest	(like	a	river	bed).	Left:	original	point	cloud.	Describe	the	problem,	the	purpose	of	the	simulation,	the	case	number,	the	approach,	etc.	Set	plotting	extents	for	Block	4:	a.	ttotal	(m/s)	(s)	(s)	(s)	0.020	0	0.020	25	50	50	0.019	26	53	103	0.018	28	56	158	0.017	29	59	217	0.016	31	63
280	0.015	33	67	346	0.014	36	71	418	0.013	38	77	495	0.012	42	83	578	0.011	45	91	669	0.010	50	100	769	0.009	56	111	880	0.008	63	125	1,005	0.007	71	143	1,148	0.006	83	167	1,314	0.005	100	200	1,514	0.004	125	250	1,764	0.003	167	333	2,098	0.002	250	500	2,598	0.001	500	1,000	3,598	Table	3:	Determining	runtime	of	each	velocity	for	the
boundary	profile	This	is	the	basis	for	the	Finish	Time	that	was	given	above.	Your	instructor	is	available	to	answer	any	questions	you’d	like	to	discuss!	Page	13	of	13	Exercise	5:	Post-Processing	&	Analysis	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	Hydraulics	Exercise	5:	Analysis	Problem	Description	&	Objectives	The	results
from	the	simulation	you	built	in	the	previous	four	exercises	will	be	analyzed.	The	solver	takes	care	of	the	problem	by	restarting	the	time	step	with	a	smaller	dt.	Here,	the	continuous	phase	will	always	be	water.	TIME	0	49	50	102	103	157	158	216	217	279	280	345	346	417	418	494	495	577	578	668	669	768	769	879	880	1,004	1,005	1,147	1,148	1,313
1,314	1,513	1,514	1,763	1,764	2,097	2,098	2,597	2,598	3,597	W	-0.020	-0.020	-0.019	-0.019	-0.018	-0.018	-0.017	-0.017	-0.016	-0.016	-0.015	-0.015	-0.014	-0.014	-0.013	-0.013	-0.012	-0.012	-0.011	-0.011	-0.010	-0.010	-0.009	-0.009	-0.008	-0.008	-0.007	-0.007	-0.006	-0.006	-0.005	-0.005	-0.004	-0.004	-0.003	-0.003	-0.002	-0.002	-0.001	-0.001	Table	4:
Time-step/velocity	entries	saved	as	.csv	file	Import	the	table	as	follows:	Page	14	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	1.	Browse	if	necessary	and	open	the	BoundaryVelocities.csv	file.	Select	Copy…	b.	Average	TKE	is	not	shown	in	this	case	because	the	flow	is	being	modeled	as	laminar	according	to
the	selections	on	the	Model	Setup	>	Physics	tab.	The	parameters	may	need	to	be	recalibrated	for	each	new	case,	unless	they	are	similar.	Launch	qAdmesh	from	the	FLOW-3D	user	interface	(Model	Setup	>	Meshing	&	Geometry	>	Tools	menu).	Page	10	of	10	Exercise	8:	Intro	to	Saturated	Porous	Media	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	8:	Saturated	Porous	Media	Hydraulics	Exercise:	Saturated	Porous	Media	Problem	Description	&	Objectives	The	flow	of	water	through	a	crushed	coal	media	filter	will	be	simulated	using	the	Saturated	Porous	Media	physics	model.	For	this	step,	you	will	need	to	know	the	location	of	the	edges	and	interfaces.	Discuss	model	comparisons	and
possible	sources	of	error.	Open	Baffle	Region	1	>	Definitions.	Enter	New	Mesh	Plane	=	-3.048.	Navigate	to	the	Model	Setup	>	Physics	tab.	Fully	blocked	real	cells	are	cells	that	are	filled	with	solid	geometry	but	are	still	active	for	heat	transfer:	there	are	none	here.	If	the	dialog	doesn’t	appear,	return	to	the	Analyze	tab,	activate	Plain	Streamline
Seeding,	and	Render	again.	Demonstrating	this	means	the	solution	is	“verified”.	There	are	four	types	of	time-dependent	data	that	you’re	likely	to	use.	It	is	perfectly	OK	to	skip	entering	the	values,	which	are	given	on	the	next	page.	Only	Restart	and	Selected	data	can	be	output	as	Text	Output.	1	would	be	optimal.	The	Flow	Science	support	staff	hopes
you	find	this	guide	helpful.	Add	it	to	component	1:	weir.	The	default	frame	rate	is	10	frames	per	second.	If	the	boundary	is	outside	the	geometry,	consider	extending	the	geometry	to	the	boundary.	Name	the	part	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833_netfabb.stl.	Select	the	Specified	Pressure	button.	It	treats	regions	where	F
=	0	as	either	compressible	(ideal	gas	law)	or	incompressible.	3	Minimize	&	quantify	the	mesh	dependency	.................................................................................................	They	are	completely	porous	to	flow	approaching	from	behind	them,	and	are	used	to	represent	nozzles,	pipes,	intakes,	vents,	and	other	devices.	Plot	limits	can	be	applied	both	spatially
and	in	time.	Add	the	first	wall	as	another	solid	box	like	before	but	with	the	following	specifications:	a.	A	green	check	mark	now	appears	next	to	Gravity.	When	it	shows	"Preprocessor	Done",	the	results	are	ready	to	view.	MeshLab	grid	generation	options	Use	the	Translate	filter	to	move	the	grid	so	it	overlaps	the	topography	extents	and	is	at	elevation
284.915	m,	midway	between	the	maximum	570	and	minimum	-0.17	m.	MeshLab	can	be	downloaded	from	meshlab.sourceforge.net.	Select	Diagnostics	>	Preprocessor	Errors	to	view	the	prperr.Weir_Mesh	file.	Find	FFLUX1	(the	Fluid	1	Flow	Rate	at	the	Flux	Plane)	=	1050	(cm3	air-water	mix)/s.	QV,AIR	=	FPSCL1	=	82	cm3	air/s,	5%	greater	than	in	the
density-evaluation	only	model.	selecting	a	later	time	frame	(for	a	time	when	fluid	is	moving),	iii.	Click	Next	to	advance	through	the	frames.	420	MB	is	the	approximate	maximum	binary	file	size	that	can	be	repaired	with	32-bit	STL	tools	like	qAdmesh	and	netfabb	Basic,	so	the	15-m	resolution	file	will	need	to	be	repaired	with	a	64-bit	tool	like	MeshLab
or	a	professional	version	of	netfabb.	Mass-Averaged	Turbulent	Energy:	This	integral	is	the	sum	of	time-mean	TKE	in	all	cells,	weighted	in	each	cell	by	the	fluid	mass.	The	final	step	is	to	visually	and	numerically	compare	the	repaired	.stl	to	the	original	artifact-clean	point	cloud	to	determine	if	the	conversion	process	was	accurate.	You	may	see	two,	in
which	case	the	one	of	interest	is	the	lower	one.	Of	the	three	saturated	porous	drag	models,	only	Permeability-Dependent	Saturated	Drag	is	written	in	terms	of	macroscopic	velocity	Umacro;	the	rest	use	pore	velocity	UP.	Even	if	the	user	interface	(GUI)	crashes,	the	solver	will	continue	to	run	and	write	all	the	important	output	files.	TOPO2STL	also
subsamples	the	data	during	the	conversion,	so	the	purpose	of	this	step	is	to	prepare	the	data	by	making	it	more	uniform.	The	purpose	of	this	exercise	is	to	practice	setting	up	and	parameterizing	a	saturated	porous	media	problem.	Also	note	the	contraction	of	the	jet	as	it	falls;	the	degree	of	contraction	in	the	CFD	model	depends	on	the	momentum
advection	method,	volume-of-fluid	(VOF)	method	for	free-surface	tracking,	and	the	geometric	resolution	of	the	weir	crest.	Pressure	boundaries	are	best	for	subcritical	tailwater,	while	Outflow	boundaries	are	best	for	supercritical	flow.	o	Grid-overlay	boundaries	are	used	to	interpolate	a	flow	solution	from	a	previous	simulation	as	a	spatially-varied,
time-constant	velocity	profile.	Page	17	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	SPATIAL	RESOLUTION	¼-inch	(0.0208	feet)	qAdmesh	repair	netfabb	Basic	repair	MeshLab	simplification	&	repair	w/	qAdmesh	finish	1E5	target	facets/	Fixed:	4	vertices,	2	holes,	21599	normals/	1	shell	output/	Too
many	facets	to	fix	in	qAdmesh	and	949	MB	binary	.stl	netfabb	Basic	without	prior	simplification.	Toggle	the	button	until	the	y-axis	vector	points	to	the	left.	Walls	will	be	defined	as	boundary	conditions.	Visualize	the	error	magnitude.	Draw	a	rectangle	to	surround	the	topgraphy.	You	may	need	to	move	the	mouse	somewhat	until	it	extrudes	by	the	blue
axis.	For	one	successful	example,	see	Abd	ElHady	Rady	(2011)	“2D-3D	Modeling	of	Flow	Over	Sharp	Crested	Weirs”,	Journal	of	Applied	Sciences	Research.	Click	Cancel.	The	first	two	blocks	will	be	the	upstream	and	downstream	coarse	grids.	The	simplified	file	size	can	be	estimated	from	the	averages	of	past	projects:	The	estimate	is	usually	within
20%	of	the	actual	size	of	the	final,	simplified,	binary-format	file.	Page	10	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	1.	Note	that	mm	just	means	‘unit	of	length’:	most	.stl	tools	assume	you	are	making	.stl	files	for	3-D	printing.	Plot	only	the	last	output	time,	which	is	when	the	multi	block	error	was	at
maximum.	Source	code	and	theory	for	Admesh	are	available	at	.	Page	10	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	5.	Requires	multiple	tries.	o	Cons:	slowest	run-time,	most	difficult	analysis	(requires	spatial	and	temporal	averaging).	Page	18	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running
&	Post-Processing	an	Example	Simulation	3.	Ideally	the	approach	is	consistent	in	all	respects	with	the	turbulence	model	and	flow	geometry.	If	there	were	many	trivial	holes,	re-export	the	mesh	in	case	MeshLab	crashes	later.	12	STEP	10	–	REPAIR	THE	BACK	FACE	..............................................................................................................	The	real	world
doesn’t	move	so	it’s	numerically	agreeable.	The	geometry	looks	decently	resolved.	The	15-m	.stl	file	(Figure	25)	shows	the	least	error,	and	will	be	used	in	subsequent	FLOW-3D	simulations.	Pre-filling	also	speeds	up	the	.stl	conversion	time	by	a	factor	of	100	or	more!	a.	The	time	average	is	6.7%	by	volume	over	the	final	2.5	seconds,	similar	to	the
scalar-only	physics	results.	Repeat	the	process	for	Topo_Example_04_fixed.stl.	The	actual	turbulent	mixing	length	is	the	characteristic	turbulent	length	scale,	a	mathematical	factor	that	roughly	corresponds	to	the	size	of	the	smallest	turbulent	eddy	that	needs	to	be	resolved	in	terms	of	turbulent	transport;	eddies	that	are	smaller	than	the	length	scale
are	approximated	as	an	average	and	dissipate	to	heat.	Figure	23.	Back	in	MeshLab,	select	the	Edit	>	Select	Vertexes	tool	from	the	menu	or	from	the	Edit	toolbar	above	the	display.	We	want	both	sliders	to	be	at	Y	=	0.25,	the	cell	center	of	the	first	cell	inside	the	domain.	It’s	important	to	use	subsampling	algorithms	that	preserve	the	data	integrity	(i.e.,
that	don’t	create	new	points)	and	that	evenly	distribute	points	(e.g.,	that	don’t	cause	higher	point	density	near	contour	lines).	Plot	Fraction	of	Fluid.	4.	You	should	add	initial	fluid	to	the	simulation	to	speed	up	the	time	to	steady	state.	Since	the	flow	is	delivered	to	the	tubes	via	small-diameter	pipes,	it	is	probably	entering	the	tubes	with	some	turbulence
for	most	flow	rates.		Check	results	sensitivity	to	physics	model	coefficients	Physics	models	may	include	numerical	coefficients	(as	opposed	to	physically-based	input	values)	that	affect	the	results.	Locate	the	Object	List	pane	in	the	lower	left.	Select	Laminar	as	the	turbulence	option	because	the	flow	is	expected	to	have	a	low	Reynolds	number.		There	is
some	anecdotal	evidence	that	1st-order	momentum	advection	may	give	more	accurate	diffusion	for	highly	turbulent	flow	than	2nd-order,	monotonicity-preserving	momentum	advection.	Plots	charts	or	text	of	values	vs.	making	sure	that	the	point	you	added	isn’t	inside	the	bed	(no	flow	there).	Because	we	assume	air	bubbles	will	always	be	discontinuous
(separated	by	films),	1	is	appropriate.	A	more	descriptive	name	is	always	recommended.	Calculate	the	required	shift	values	so	that	the	number	of	significant	digits	is	minimized,	and	all	coordinates	are	positive.	Leave	them	as	Symmetry-type.	Except	for	the	purposes	of	this	exercise,	you	can	safely	ignore	isolated	errors.		Estimate	the	valve	loss
coefficient	and	external	pressure	for	each	valve	(see	User	Manual).	Copy	BoundaryVelocity.csv	to	the	project	folder	(Saturated_Porous).	Use	your	measurements	to	find	the	edge	coordinates	of	the	crest	notch.	Change	the	Y	Translation	from	negative	to	positive	1.	20.3	x	106	points)	30-m	TOPO2STL	spacing	-0.28	m	7.9	m	5.5	m	5.7	m	(.stl	surface	vs.
Name	the	new	subcomponent	LH	hole.	On	the	Model	Setup:	Meshing	&	Geometry	tab		Import	and	create	geometry		Add	subcomponents	to	create	the	solid	geometry	described	in	the	annotated	diagram	using	.stl	files	and	primitives.	Some	possible	model	elements	have	been	omitted	(electromechanical	physics	models,	for	example).	Navigate	to	the
Model	Setup	>	General	tab.	Therefore	do	not	use	Gravity	and	Non-Inertial	Reference	Frame	physics.	Some	of	the	shapes	(subcomponents)	are	solids,	and	some	are	holes	to	cut	away	the	mitered	edge.	This	is	because	the	distance	between	all	mesh	planes	(within	and	between	blocks)	is	an	even	multiple	of	the	largest	cell	size,	and	the	largest	cell	size	is
an	even	multiple	(x2)	of	the	smaller	cell	size.	Create	a	new	workspace	and	add	an	example	project	file	included	with	the	software,	2.	Interblock	Boundary	Volume	Error	(%	Lost):	the	total	volume	lost	due	to	interpolation	at	inter-block	boundaries	is	about	2.5%,	and	follows	the	same	criteria	above.	Page	3	of	16	Water	&	Environment	Training	on	FLOW-
3D	v11	Exercise	2:	Setting	Up	Geometry	You	can	load	multiple	parts	at	once	and	toggle	between	them	using	the	tree	to	check	that	they	are	oriented	correctly	and	in	the	same	coordinate	system.	An	experienced	FLOW-3D	modeler	will	be	concerned	instead	with	the	resolution	of	the	weir	crest.		Add	and	define	springs	and	ropes	and	valves	and	vents	
Spring/rope	objects	connect	moving	components	to	each	other	or	to	stationary	anchor	points.	where:	Tu	=	initial	intensity	of	turbulence	(dimensionless,	equation	is	empiric	for	fully-developed	pipe	flow),	Re	=	pipe	Reynolds	number	(dimensionless),	Aw	=	wetted	area	(cm2),	DH	=	characteristic	hydraulic	length,	taken	to	be	the	pipe	hydraulic	diameter
(cm),	h	=	depth	of	2-D	flow	(cm),	kT	=	mean	turbulent	kinetic	energy	per	unit	mass	(cm2/s2),	εT	=	rate	of	dissipation	of	turbulent	kinetic	energy	per	unit	mass	(cm2/s3),	LT	=	turbulent	length	scale,	aka	turbulent	mixing	length,	about	7%	of	pipe	diameter	(cm),	Pw	=	wetted	perimeter	(cm),	U	=	mean	fluid	velocity	(cm/s),	μ	=	fluid	dynamic	viscosity
(g/cm/s),	ρ	=	fluid	density	(g/cm3),	Page	3	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	The	upstream	depth	of	flow	is	5	cm,	velocity	is	210	cm/s,	density	is	1	g/cm3,	and	viscosity	is	0.01	g/cm/s.	Typically	assumed	to	be	the	viscosity	of	the	continuous	phase,	so	here	it	is	the	viscosity	of	water.	Select	Tools	>
Distances	>	Cloud/Mesh	Dist	.		Minimum	Volume	Fraction	of	Phase	1	is	the	irreducible	fraction	of	water	allowed	in	a	cell.	Experiments	suggest	that	bulking	begins	to	affect	the	flow	when	the	entrained	air	is	between	1%	and	3%	by	volume.	Step	through	the	Available	Time	Frames	and	observe	the	early	oscillations	of	the	streamlines	and	how	they
eventually	become	steady.	Save	your	work	again.	Cad2Stl	will	save	the	.stl	file	in	same	folder	and	same	name	as	the	original	file	by	default.	Select	File	>	Save	All	from	the	menu	at	top	to	save	the	new	name	in	the	prepin	text	and	in	the	Workspace	file	that	specifies	the	project	paths.	Selections	made	here	will	be	added	to	Restart	Data	and	History	Data
(time-dependent	data	recorded	for	the	flux	surface	and	history	probe).	An	efficient	mesh	may	be	developed	by	some	or	all	of	the	following	methods:		Picking	cell	sizes	to	resolve	the	geometry	and	flow	features	according	to	rules	of	thumb,		Specifying	grid	lines	to	resolve	the	surfaces	of	flat	geometry,		Adding	domain-removing	components	to	eliminate
unnecessary	cells,		Using	symmetry	boundaries	at	the	centerline	to	halve	the	domain	size,		Using	nested,	linking,	and	conforming	mesh	blocks	to	selectively	resolve	flow	regions,		Checking	the	geometric	resolution	of	the	mesh	with	multiple	methods,		Mesh	dependency	studies:	reducing	cell	sizes	in	multiples	of	2	until	the	results	converge.	If	there	are
any	mistakes,	fix	them	with	the	following	steps:	a.		Check	sensitivity	to	the	VOF	method	Models	with	free	surfaces	have	several	options	for	volume-of-fluid	methods.	Histogram	of	point-cloud	to	15-m	.stl	facet	error.	Answers	on	the	next	page…	Page	11	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	Luckily	for	you,	the
diffusion	and	volume	loss	appear	to	occur	after	the	critical	control	at	the	weir	crest.	You	can	access	a	list	of	probed	points	by	selecting	View	>	Probe	Points	List…	in	the	menu	above	the	view	pane.	Activate	viscous	flow	and	RNG	Turbulence	physics.	Convective	flux	errors	are	associated	with	sudden	accelerations.	The	bottom	of	the	box	will	be	deleted
as	well,	since	all	facets	in	it	share	the	same	four	corner	vertices.	Page	7	of	7	Guide	2:	CFD	Simulation	Workflow	Guide	FLOW-3D	Version	11	Simulation	Setup	Simulation	Setup	Guide	Table	of	Contents	Before	starting	..............................................................................................................................................	Page	21	of	21	Exercise	4:	Fluid,	Physics,	&
Initial	Conditions	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	Hydraulics	Exercise	4:	Fluid,	Physics,	Initialization	Problem	Description	&	Objectives	Continuing	from	the	previous	exercise,	a	fluid	(water)	will	be	specified	for	the	simulation	and	fluid	regions	will	be	initialized	within	the	domain.
Figure	2.	When	you	click	the	mouse	button,	the	XYZ	coordinate	of	the	solid	surface	at	that	point	appears	in	the	lower-left	corner	of	the	GUI.	The	error	magnitude	distribution	is	shown	in	Figure	24:	it	is	best	described	as	a	Weibull	distribution.	separate	tests.		Identify	the	spring/rope	type	to	be	used	(see	User	Manual	for	details)		Identify	the	Hookean
spring	coefficient	for	each.	Return	to	the	Analyze	>	3-D	tab.	Refer	to	for	details	on	NED	data,	including	formats,	accuracy,	and	methods	of	collection.	Once	a	plot	type	(tab)	is	selected,	the	next	step	is	to	choose	the	data	source.	In	this	case	because	the	tubes	are	uniform	diameter,	the	velocity	is	constant	(conservation	of	mass),	and	the	velocity	and
hydraulic	machinery	terms	can	be	omitted.	Subscript	Z	is	the	potential	(elevation)	energy,	P	is	the	pressure	energy,	and	V	is	the	kinetic	(velocity)	energy.	Check	that	Iso-Surface	=	Fraction	of	Fluid	so	you	plot	the	water/air	and	water/solid	interfaces.	Select	Second	Order	Monotonicity-Preserving	momentum	advection.	Adjust	the	Transparency	slider.
Deselect	all	default	attributes	and	select	Transfer	Selection.	1	Set	up	and	run	a	coarse	test	case	.................................................................................................................	If	you	have	successfully	completed	Exercise	3	you	may	choose	to	simply	make	a	new	copy	of	that	simulation	as	described	below.	Visualization	of	error	magnitude	with	blue	=	0	and	red
=	0.06	feet.	FLOW-3D	interpolates	linearly	between	tabular	data	points.	Click	on	Search	at	the	top	of	the	dialog	and	search	for	mesh.	Expand	the	Mesh	Blocks	in	the	tree	and	check	against	the	image	on	the	next	page.	It	will	warn	you	that	different	resolutions	are	causing	different	open	areas	between	blocks.	Repair	the	.stl	file	using	netfabb	Basic.
Mesh	Display:	It’s	important	to	examine	the	mesh	to	assess	resolution.	Do	not	use	Mesh	Dependent	History	data,	as	it	will	only	report	the	specified	air	volume	fraction	in	the	ghost	cells	(zero),	and	not	the	calculated	volume	crossing	it.	The	text	output	is	given	with	the	variable	titles:	TIME	(s),	HYFD	(m),	and	FFLUX1	(m3/s).	A	rule	of	thumb	is	to	try
Split	Lagrangian	VOF	and	compare	the	results	to	the	default	One	Fluid,	Free-Surface	VOF.	The	steps	are:	1.	Slide	the	Z	Limits	sliders	so	that	K	=	2	to	32.	Figure	20.	Page	24	of	24	Exercise	2:	Setting	Up	Geometry	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	Exercise	2:	Setting	Up	Geometry	Problem	Description	&
Objectives	The	next	three	exercises	focus	on	building	a	sharp-crested	weir	simulation.	Check	if	the	flow	has	reached	steady	state	by	looking	at	the	runtime	plots.	The	next	step	will	be	to	rotate	and	move	it.	They	do	not	specify	velocity	(except	for	tangential	components).	Render	the	Probe	>	General	History	data	variables	above	as	Text.	List	any	non-
standard	numerical	methods	(and	note	if	only	default	values	were	used).	Invert	the	selection	and	Delete	the	land	points.	The	Flow	Science	support	staff	hopes	you	find	this	guide	helpful.	Repeat	the	coordinate	checking	process	to	verify	and	record	the	new	extents.	Try	changing	the	display	shape	to	Ribbons,	adjusting	the	transparency,	and	changing
the	color	and	weight	(ribbon	scale	percentage)	of	the	streamline.	If	convective	flux	errors	recur	frequently,	they	will	at	best	slow	down	the	simulation,	and	at	worst	cause	it	to	terminate	before	completion.	The	dirt	particle	will	move	freely	with	the	fluid.	The	remaining	subcomponents	are	holes	that	cut	bevels	into	the	visible	subcomponents.	The	part
should	be	two-manifold	and	composed	of	a	single	component.	Reflect	results	around	a	plane	of	symmetry,	8.	To	improve	the	visual	effect	of	animations,	it	is	recommended	that	a	common	color	scale	be	applied	to	all	frames.	Delete	points	in	the	new	plane	that	are	within	0.5	feet	of	the	river	data	f.	Search	the	User	Manual’s	Input	Variable	Summary
chapter	for	the	variable	code	to	identify	the	definition,	default	value	(if	left	blank)	and	units	of	the	selection.	Hold	Shift	and	left-click	on	the	plane	at	a	point	near	the	bed	and	approximately	on	the	centerline	of	the	flow.	MeshLab	will	start	to	close	the	hole	and	incorrectly	report	that	there	are	no	more	holes	to	fill.	15.	Hold	the	left	mouse	button	and
drag	around	the	points	to	select	them.	Open	Cad2Stl	by	running	run_cad2stl.bat.	FLOW-3D	Learning	Objectives	In	this	exercise	you	will	practice	techniques	to:	1.	Save	again.	Post-conditioning	can	reduce	the	output	file	size.	Topographic	data	is	downloaded	for	free	from	the	USGS	National	Elevation	Dataset	(NED)	at	.	These	may	not	be	detected	by
FLOW-3D	but	can	cause	bad	solutions.	Check	your	work	against	the	final	time	step	shown	below.	A	good	rule	of	thumb	is	that	.stl	output	files	are	about	1	GB	for	every	11	million	points	(including	converting	the	output	to	binary	.stl	format).	Select	File	>	Export	Mesh	As,	set	Files	of	Type	=	XYZ	Point	Cloud,	and	name	the	file
MiddleRioGrande_MLASCtxt.xyz.	Check	the	Simulation	Units:	Select	the	Model	Setup	>	General	tab.	The	transformation	matrix	is	a	4x4	record	of	movement	(scaling,	rotation,	translation)	of	the	mesh.	Locate	your	region	of	interest	in	SketchUp.	MAKE	A	WATERTIGHT	SURFACE	FROM	THE	TOPOGRAPHY	USING	SKETCHUP	1.	The	remaining
parameters	will	be	entered	on	the	Model	Setup	>	Fluids	tab.	The	raw	point	data	may	be	digitized	from	contour	maps,	exported	from	GIS	(geographical	information	system)	software,	or	may	be	the	output	of	LiDAR	(Light	Detection	and	Ranging),	TLS	(terrestrial	laser	scanning),	or	satellite	profiling	equipment.	These	extra	three	effects	are	modeled	by
Drift-Flux	physics.	The	maximum	turbulent	mixing	length	is	an	upper	stability	bound	to	prevent	the	turbulence	model	from	over-estimating	the	length	scale.	Non-default	options	for	controlling	the	pressure	solution	are	rarely	needed	or	desirable,	but	are	available	on	the	Model	Setup	>	Numerics	tab	and	will	be	discussed	in	a	later	lecture.	In	this	case
the	failure	is	of	a	type	that	can	usually	be	ignored,	especially	since	it	occurs	only	once.	Check	Solver	Warnings:	there	are	many	F-packing	errors	at	the	toe	of	the	jump.	Check	in	the	Min/Max	tree	for	the	subcomponent	as	before:	the	new	extents	show	the	scaling.	Repeat	the	process	with	Mesh	Block	=	2:	a.	Select	OK	to	create	the	subcomponent	copy.	
Label	the	fluids	in	the	problem	(e.g.,	air,	water,	oil),		For	liquid/gas	systems,	can	local	gas	velocities	be	ignored?	This	creates	the	upper	surface	of	the	.stl	part.	Export	the	flattened	layer	with	no	normals	as	MiddleRioGrande_MLASCtxt_clean_fill.xyz.	The	conforming	mesh	will	only	appear	as	defined	in	2-D	plots,	like	those	found	from	preprocessing	the
simulation.	Take	the	setting	that	gives	results	that	are	closest	to	the	experiment.	Expand	the	Transformation	branch	and	then	the	Rotations	and	Translations	sections.	Do	you	see	any	multi-block	problems?	Activate	Render	>	Show	Non	Manif	Edges	and	Render	>	Show	Non	Manif	Vertices	to	visualize	where	the	problems	are.	Standard	methods	exist
for	quantifying	experimental	uncertainty;	most	involve	estimating	measurement	uncertainties	and	combining	Page	5	of	7	FLOW-3D	Version	11	CFD	Project	Overview	them	to	find	result	uncertainties.	Click	Render	to	generate	a	time	sequence	of	2-D	plots	of	pressure	in	the	plane.	Save	your	work!	Set	Higher-Order	Momentum	Advection	The	default
momentum	advection	is	quite	robust	and	usually	very	accurate	for	linear	flow.	Pressure	FLUID	REGION	2	P	=	6000	g/cm/s2	Fluid	Fraction	=	1	FLUID	REGION	1:	Z-High1	=	5	cm,	U1	=	210	cm/s	x	Z-min	=	0	cm,	Boundary	=	Wall	Figure	4:	2-D	definition	sketch	w/	initial	fluid	regions.	Check	velocity,	free-surface	elevation,	temperature,	and	turbulence.
Generate	the	.stl.	Page	7	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Figure	11.	Simulations	that	are	running	or	waiting	to	run	can	be	paused	,	terminated	or	rearranged	in	the	queue	in	the	lower	left	window:	Page	12	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-
Processing	an	Example	Simulation	Checking	and	Diagnosing	the	Running	Simulation	The	Simulation	Manager	tab	can	be	thought	of	as	a	dashboard	for	the	run.	MeshLab	can	be	used	to	reduce	the	size	of	.stl	files,	which	is	particularly	important	for	those	created	with	a	fine	resolution.	Does	the	test	case	include	the	same	physical	processes	as	the	case
of	interest?	Define	the	baffle	location	and	parameters:	a.	Check	the	final	time	step	output	against	Figure	6	below	before	proceeding.	Click	the	Render	button	at	the	lower	right.	Mark	the	Select	check-boxes	for	holes	with	only	three	edges	(if	any	exist)	and	activate	the	Trivial	Holes	fill	option.	Select	Simulate	>	Preprocess	Simulation	>	Local	from	the
menu	at	the	top.	Notice	that	the	repaired	part	still	has	2	shells.	Water	can	be	present	without	air	in	it,	so	1	is	appropriate.	4	Quantify	the	validation	uncertainty..............................................................................................................	Nozzle	i.	Convert	pressure	loss	∆P/∆x	to	head	loss	∆H/∆x.	Left	Button	–	Rotate.	o	Check	Mesh	Block	Summary	Information
for	total	number	of	real	cells	in	all	blocks.	Toggle	Mesh	>	Hide	All/Show	All	to	make	the	geometry	easier	to	see.	It’s	important	to	match	grid	lines	between	blocks	or	risk	increasing	the	interpolation	error.	Z	=	1	and	Z	=	3.6576	for	the	bed	and	crest	elevations.	Add	appropriate	boundary	conditions.	Experiment	with	the	options	there,	especially	the
Vector	Size	options.	Page	7	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Optional:	Tweak	the	Mesh	to	Minimize	Inter-block	error	The	simulation	will	run	with	the	mesh	you’ve	already	added.	o	Adjust	mesh	block	edge	locations	so	that	the	side-to-side	total	length	of	each	block	is	an	even	multiple	of
the	largest	expected	cell	length	in	all	blocks	in	the	same	direction.	Viewing	Preprocessed	Geometry	and	Initial	Fluid	Configuration	in	3-D	and	2-D	The	Analyze	panel	will	now	be	displayed.	The	units	for	FPSCL1	are	tricky:	they	represent	a	scalar,	so	FLOW-3D	reports	them	as	g/s.	Page	19	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise
3:	Meshing	&	Boundary	Conditions	Set	Fluid	Density	This	step	is	required	to	be	able	to	preprocess	the	model.		Does	the	model	run	in	a	reasonable	amount	of	time?	.stl	files	are	exported	from	computer-aided	design	(CAD)	programs	and	contain	a	closed	surface	of	triangular	facets.	Get	measurement	station	output	as	text:	a.	Select	Complement	of
Volume	Fraction	so	the	surface	that	is	plotted	is	the	interface	between	solid	geometry	and	open	space.	The	Geometry	tree	now	has	two	components,	each	with	one	subcomponent.	FLOW-3D	normally	adjusts	these	by	adding	‘virtual’	volume	to	cells	with	A/V	ratio	greater	than	a	specified	threshold	called	AVRCK	(by	default	3.1).	Set	Subcomponent
Name	=	weir	plate	and	then	click	OK.	If	the	mesh	is	too	coarse	the	geometry	and	flow	may	not	be	resolved	enough	and	the	simulation	will	not	give	good	results.	Middle	Buttom	or	Wheel	–	Zoom.	Page	11	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	4.	Select	Filters	>	Quality	Measure	and	Computations	>
Compute	Topological	Measures.		Sketch	the	block	edges	where	they	are	not	in	regions	of	rapid	change	(high	gradients	of	pressure,	velocity,	or	temperature).	10	On	the	Model	Setup:	Numerics	tab	............................................................................................................	Left-click	the	mouse	button	and	then	press	and	hold	Shift.	They	are	valid	for	all	ReP	up



to	the	onset	of	true	turbulence,	and	fit	many	experimental	data	sets.	They	would	be	equally	valid	for	horizontal	flow	through	the	same	media.	Convective	volume	error	(%	lost)	and	Multi-block	volume	error	(%	lost):	Represents	the	amount	of	fluid	gained	(negative	value)	or	lost	(positive	value)	due	to	advection	errors	or	interblock	interpolation	errors,
in	percent.	Select	Contour	Variable	=	Velocity	Magnitude.	the	ratio	res/epsi	of	pressure	solution	maximum	residual	(any	cell)	to	convergence	criteria	epsi	8.	Open	Baffle	Region	1	>	Limiters.	Apply	the	filter,	and	then	set	the	Z-Axis	=	0	again	so	the	grid	doesn’t	rise	another	99.3	feet	next	time	you	click	Apply.	Check	the	effect	of	the	additional	limiters
by	FAVORizing	the	geometry:	use	a	Renderspace	with	extents	-0.02	to	0.02	in	all	directions	and	0.0005-cm	“cells”.	The	camera	view	may	wobble	a	little	during	this	process:	this	is	a	known	issue	and	will	be	addressed	in	a	later	exercise	on	using	FlowSight	postprocessing.	Reactivate	the	Mesh	entity	to	see	the	.stl.	Page	24	of	26	Water	&	Environment
Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	APPENDIX	B	-	COMPARISON	OF	TEXT	EDITORS	FOR	LARGE	POINT	CLOUDS	It	is	helpful	to	have	a	text	editor	which	includes	the	following	capabilities:					Opens	large	(up	to	2	GB	or	larger)	ASCII	files	Finds	and	converts	tabs,	commas,	and	spaces	using	regular	expressions,	Finds
and	converts	DOS,	Unix/Linux,	Macintosh,	and	Netscape	line-end	characters,	Includes	a	column-edit	method	for	block	editing.	If	you	are	interested	in	flow	rate	over	the	weir,	the	multi-block	error	won’t	affect	your	results.	The	exercise	is	now	complete.		Ergun,	S.	Density	=	1	g/cm3	c.	Check	that	there	are	no	known	issues	when	the	relative	Tolerance
=	0	and	100.	Select	the	newly	repaired	part	in	the	tree	and	perform	a	new	Standard	Analysis	on	it.	Open	the	Global	>	Fluid	Initialization	branch	and	set	Fluid	Initialization	=	Use	Fluid	Elevation	and	Initial	Fluid	Elevation	=	1.5	m.	Porosity	for	each	media	was	determined	from	the	packed	column	volume	and	mass	and	the	known	microscopic	media
density.	It’s	usually	better	to	select	too	many	than	not	enough.	Keep	the	default	name	and	Create	subdirectory	using	simulation	name	option.	The	goal	is	to	be	able	to	explain	each	property	value	used	by	the	selected	physics	of	the	simulation.	If	not,	select	the	Open	Results	File	button	at	the	bottom	left	of	the	Analyze	tab.		If	your	model	has	a	free
surface,	try	2nd-order,	monotonicity-preserving	momentum	advection.	Select	View	>	Show	Layer	Dialog	from	the	menus	or	on	the	Standard	toolbar.	Given	that	the	media	is	saturated	at	all	times	during	the	experiment,	we	will	disregard	the	Unsaturated	Flow	model,	and	the	three	drag	models	associated	with	it.	Are	the	boundary	conditions
appropriate	and	realistic?	Select	the	Simulation	Manager	tab.	You’ll	be	shown	a	column	list	for	each	cloud	where	you	can	check	the	precision	of	the	MicroDEM	output.	Figure	3.	Find	approximate	min/max	coordinates.	Get	preliminary	comparison	statistics.	Figure	18.	to	toggle	part	visibility.	They	do	not	transmit	information	back	into	the	domain,	so
they	are	appropriate	when	the	flow	is	faster	than	gravity	waves.	Entrained	air	transport	models	must	use	the	transport	equation	option.	It’s	much	easier	to	use	air	entrainment	physics	when	all	you	need	are	qualitative	results.	Each	line	must	contain	three	numbers,	separated	by	spaces,	so	that	the	first	number	is	the	X	coordinate,	the	second	number
is	the	Y	coordinate,	and	the	third	number	is	the	Z	(elevation)	coordinate.	Click	Apply	and	Close	to	exit	the	dialog.	Note	that	the	sliders	in	the	center	of	the	screen	reset	so	that	the	full	extents	of	the	X	and	Z	domain	is	plotted,	and	the	Y	sliders	come	together	so	that	by	default	only	one	slice	is	displayed	(at	y	=	5.25,	the	geometric	center	of	the	y-domain).
from	the	menus	at	the	very	top	of	the	interface.	This	will	cause	the	fluid	elevation,	fluid	depth,	and	Froude	number	to	be	computed	and	stored	in	the	results	file.	Experiment	with	setting	a	pivot	point	with	Ctrl+click	(or	toggle	the	button)	A	gray	lozenge	marks	the	pivot	point,	which	can	be	hidden	by	toggling	View	>	Hide	(or	Show)	Pivot	Point	in	the
menu	above	the	view	pane.	Report	any	conclusions	drawn	or	lessons	learned	from	the	simulation.	Saving	your	work	with	different	file	names	is	important.	Right-click	on	a	component	name	or	open	the	Subcomponents	list	and	right-click	on	a	subcomponent	to	adjust	the	transparency.	Extrude	the	surface	downward	following	the	blue	(z)	axis	and	check
and	fix	reversed	faces.	Set	Skip	Lines	=	2	to	ignore	the	headers,	and	then	set	the	three	column	labels	at	the	top	to	coord.	No	other	changes	are	required.		Vary	the	calibration	parameters	and	record	the	results	When	possible,	adjust	only	one	parameter	per	run.	Page	19	of	19	Exercise	9:	STL	Topography	from	LiDAR	Water	&	Environment	Training	on
FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	CREATING	STL	FILES	FROM	TOPOGRAPHIC	POINT	CLOUDS	USING	TOPO2STL	AND	FREEWARE	INTRODUCTION	Topography	can	be	defined	as	“the	configuration	of	a	surface	including	its	relief	and	the	position	of	its	natural	and	man-made	features”.	General	History:	Non-cell-specific	data.
Activate	the	No	Contour	Smoothing	checkbox	to	turn	off	the	aesthetic	blurring	of	cellcentered	values.	It	appears	that	the	flow	rate	reaches	approximate	steady	state	around	20	seconds.	Select	the	bounding	.stl	surface	in	MeshLab	Figure	16.	Location	is	NO.	The	Approximate	Results	are	chamfer	distances	and	not	reliable	for	small	d	(Girardeau-
Montaut	et	al.		Write	the	edge	coordinates	of	the	blocks.	Right-click	the	selected	subcomponent	to	bring	up	a	context	menu.	Check	the	box	for	Hydraulic	Data	under	Additional	Output.	This	will	make	it	so	there’s	no	stretching	and	grid	lines	match	exactly	in	X.	An	experienced	CFD	modeler	who	is	used	to	body-fitted	meshes	might	have	a	slight	concern
because	the	weir	plate	faces	and	wall	surfaces	are	in	the	middle	of	cells,	and	not	exactly	on	a	cell	face.	Page	15	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Check	the	Total	Cell	Count	with	the	Mesh	Block	Summary	Information	Tool	1.	A	message	appears	indicating	that	the	prpgrf	file	no	longer
exists.	Only	half	of	the	weir	structure	is	being	modeled	and	only	that	half	is	displayed.	It	was	built	using	FLOW-3D	primitives	(simple	shapes).	iii.	Examine	the	Extents,	Min,	and	Max	coordinates	of	the	weir	subcomponent.	All	the	subcomponents	are	visible	in	this	view,	regardless	of	whether	they	are	solids	or	holes.	Look	for	outlying	points,	strange
stretching	(indicating	that	units	are	not	the	same),	noise,	and	other	problems.	The	sources	will	add	flow	without	needing	to	extend	the	pipes	to	a	domain	boundary,	so	you	don’t	need	to	make	the	pipes	extend	very	far	into	the	weir	and	upstream	floor.	Are	the	initial	conditions	appropriate	and	realistic?	More	significant	figures	can	be	displayed	in	the
Settings	options.	Change	Density	=	998.21	kg/m3.	The	basic	processes	and	principles	will	be	the	same	regardless	of	software.	This	step	is	optional	but	recommended	whenever	the	coarse	test	runs	quickly	and	there	is	sufficient	time	in	the	budget.	If	not,	consider	adjusting	the	mesh	resolution.	These	data	sets	are	called	Restart	data	because	they
include	all	of	the	information	necessary	to	describe	the	flow	field	and	can	be	used	as	the	initial	and/or	boundary	condition	configuration	of	a	new	simulation	called	a	Restart	simulation.	o	In	section	/PARTS/,	is	the	total	number	of	particles	generated	less	than	the	maximum	number	of	particles	requested	(max	possible)?	Select	Tools	>	qAdmesh.
Includes	global	output	like	time	step	size,	epsi,	and	mean	kinetic	energy.	Here	you	will	create	a	fixed	point	probe	that	will	act	as	a	staff	gauge	for	measuring	the	flow	depth.	Prog.	SURFACE	TENSION	The	Surface	Tension	physics	model	is	never	active	inside	porous	media	components,	since	surface	tension	effects	are	included	empirically	in	the	Porous
Media	physics,	including	capillary	action.	X	=	0.3048	for	the	downstream	face	of	the	weir,	b.	The	default	option	includes	the	most	robust	surface	reconstruction	method,	but	higher-order	methods	are	available	that	may	be	more	accurate.	Enter	values	for	both	Mesh	Planes	in	the	X	Direction,	Y	Direction,	and	Z	Direction	as	shown	on	the	left	side	of	the
image	below.	Click	the	Conform	To	Components	button	and	uncheck	boxes	so	only	Component	1	is	active.	Plot	Pressure	and	Plain	Velocity	Vectors.	Set	Overlap	Length	=	1.	Locate	the	minimum	and	maximum	extents	of	the	raw	data.	Display	units:	a.	Open	Mesh	block	1:	UPSTREAM	>	Boundaries.	Uncheck	the	Hide	Extensions	for	Known	File	Types
option.	Check	your	work	by	showing	both	layers	together	and	individually	(see	Figure	9	below).	Surface	tension	and	viscosity	are	also	used.	There	are	two	boundaries	that	are	appropriate	for	downstream	in	channels.	Impinging	jets	often	exhibit	bidisperse-normal	distribution	of	bubble	radius,	which	complicates	the	estimate	of	a	single	mean	radius.
The	ratio	between	high-resolution	topography	and	the	entire	surface	can	be	estimated	by	checking	the	number	of	points	in	each	layer	during	Step	4	above:	The	file	size	reduction	is	a	function	of	the	area	of	the	upper	surface,	the	area	of	the	bounding	plane,	and	the	aggressiveness	of	the	simplification	algorithm.	limiting	time	step	required	for	stability
by	any	explicit	solver	process	dtstbl,	5.	Manually	edit	fluid	properties,	including	limited	compressibility,	6.	Find	the	range	of	CFD	output	and	develop	uncertainty	bands	around	the	mean	results.	Select	the	folder	that	contains	the	ArcGrid	data	(e.g.,	n35w119_13sec_ArcGrid_a).	Page	2	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:
Air	Entrainment	Technically,	h	is	the	hydraulic	mean	depth,	equal	to	the	wetted	area	Aw	divided	by	top	surface	width	T.	Go	to	the	Simulation	Manager	tab.	Add	mesh	planes	to	resolve	flat	geometry,	5.	Select	OK,	then	OK	again,	then	Close	the	database.	the	real	world	that	is	similar	to	the	uncertainty	generated	by	converting	the	NED	data	to	.stl
format	with	15-m	spacing.	Use	3-D	plots	to	check	the	results	qualitatively.	If	moving	solids	with	prescribed	motion	are	used,	consider	running	the	simulation	without	fluid	to	check	the	movement	definition.	Page	11	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Page	12	of	21	Water	&	Environment
Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	The	generalized	way	to	determine	the	optimal	location	of	grid	lines	(for	your	later	reference):		Place	internal	mesh	planes	(internal	means	they	are	not	the	ends	of	the	blocks)	only	where	absolutely	necessary	to	resolve	geometry.	Check	the	text	display	that	appears.	A	few	iteration
failures	are	unlikely	to	damage	the	simulation	accuracy,	especially	when	they	are	isolated	or	occur	at	the	beginning	of	the	run.	This	will	make	perfectly	aligned	gridlines	between	blocks	and	minimize	interpolation	error.	.stl	bottom	before	(left)	and	after	(right)	removing	non-manifold	vertices	and	filling	holes	Finally,	apply	Filters	>	Normals,
Curvatures	and	Orientation	>	Recompute	Face	Normals	and	then	Filters	>	Normals,	Curvatures	and	Orientation	>	Normalize	Face	Normals.	Try	to	place	baffles	normal	to	the	axes	to	avoid	“stair-stepping”.	Click	the	Select	arrow	icon	from	the	main	toolbar	and	a	dialog	will	appear.	Specify	X	Coordinate	=	0.	Most	pipe	flows	exhibit	Tu	between	1%	and
5%.	Removing	some	point	artifacts	4)	Fill	in	empty	regions	with	a	flat	plane.	Determine	Weir	Subcomponent	Dimensions	and	Unit	System	Sharp-crested	rectangular	weirs	are	a	relatively	well	understood	method	of	measuring	flow	in	channels.	Enter	Z	Component	=	-9.81.	Observe	that	the	colored	results	are	only	the	values	at	the	surface;	changing
transparency	does	not	allow	you	to	see	the	velocity	profile	inside	the	flow.		Run	and	post-process	the	finer-mesh	cases		Set	Simulate	>	Set	Max	Simultaneous	Simulations	=	1	if	the	refinements	are	restarts.		If	the	results	are	sufficiently	similar	and	the	implicit	method(s)	are	noticeably	faster,	consider	using	the	implicit	method	for	the	rest	of	the
project.	Figure	8:	Parameters	for	air	bubbles	and	water	for	drift-flux	model	Page	10	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	A	brief	description	of	the	parameters	in	Figure	8	follows.	Double	click	anywhere	in	blank	space	to	deselect	the	wall.	There	are	a	few	messages	that	the	simulation	is	nearly	steady.	Use
Probe	>	General	History	Data	for	Measurement	Location	Output	1.	Rules	of	Thumb	1)	The	ideal	cell	shape	is	a	cube.	The	average	flow	rate	Q	over	the	weir	after	20	seconds	is	approximately	2.42	m3/s.	Very	large	.stl	files	that	exceed	the	available	graphics	card	memory	will	not	load	in	the	FLOW-3D	interface,	although	they	can	be	added	manually	to
prepin	files	that	are	run	from	the	command	line.	Press	Ctrl+C	to	copy	them	to	the	clipboard.	Translate	it	0.012	cm	in	Z.	Choose	Water_at_20_C,	and	select	Load	Fluid	1.	No	single	program	is	ideal	for	converting	large	surface	point	sets	to	3-D	geometry,	so	a	method	is	presented	here	that	combines	freeware	utilities	with	TOPO2STL	to	get	excellent
results.	Ctrl+left	click	and	drag	to	add	the	faces	or	vertices	in	the	box	to	the	already-selected	group.	Under	Mesh	block	1:	UPSTREAM,	right-click	X	Direction	and	select	Add.	Make	any	necessary	fixes.	If	you	want	to	change	the	streamlines,	select	Tools	>	Streamline	Edit	from	the	menu	above	the	display	to	reopen	the	dialog	and	seeding	plane.	Try	to
justify	why	physical	mechanisms	were	included	or	ignored	–	this	helps	catch	mistakes	early.	Rotate	(left	mouse	button),	zoom	(mouse	wheel),	and	pan	(right	mouse	button)	the	camera	to	view	the	weir.	qAdmesh	fixes	normals	more	precisely	than	netfabb	Basic,	but	generally	does	not	fill	holes	as	well.	Click	Apply	to	Default	check	(and	fix)	the	file.
Further	statistical	error	correlations	can	be	developed	from	the	point	data	and	from	the	polynomial	fitting	curves.	Practice	finding	the	Translation	branch	of	the	new	subcomponent.	Set	the	simulation	finish	time,	7.	The	button	allows	you	to	draw	a	box	and	places	a	pivot	point	in	its	center	before	zooming	to	the	selection.	The	initial	conditions	for	this
simulation	are	an	initial	depth	and	pressures	such	that	output	will	be	in	gauge	pressure	(local	ambient	atmospheric	pressure	=	0).	Control+Shift+left	mouse	button	and	drag	to	change	lighting	direction	(only	if	there	are	normals).	Enter	Weir	Finish	as	the	simulation	name.	o	Add	mesh	planes	in	containing	and	linked	blocks	to	match	the	edge	extents	of
their	nested	or	neighboring	blocks.	Component	3	>	Type	of	moving	object	=	Coupled	ii.	The	benefits	of	pre-decimating	include	more	accurate	.stl	surfaces,	faster	conversion	times,	and	more	reliable	results	when	using	software	post-condition	the	data.	Set	X-Velocity	=	210	cm/s.	Pan	(using	the	right	mouse	button)	until	the	weir	is	just	below	and	to	the
right	of	the	color	bar.	Use	a	statistics	package	or	a	spreadsheet	program	to	fit	a	2nd	order	polynomial	‘trend	line’	to	the	experimental	data.	After	the	calculation	is	complete	click	OK	to	exit	the	dialog	and	map	the	point	results	into	a	scalar	field.	Click	OK,	check	that	you’re	adding	the	new	wall	to	Subcomponent	2,	and	then	OK	again.	The	original	file
won’t	load	in	TOPO2STL	because	it	is	not	formatted	correctly.	Another	common	practice	is	to	use	an	even	number	of	cores	to	reduce	computational	overhead.	Keep	selecting,	filling,	accepting	and	relaunching	the	tool	until	no	more	holes	are	reported	when	the	tool	starts.	A	characteristic	velocity	in	the	domain	needs	to	be	estimated	to	determine	the
characteristic	(packet-transit)	time	scale.	The	plane	should	overlap	the	original	data	with	a	small	margin	on	all	sides.	Select	the	Hydraulic	Examples	workspace	and	select	File	>	Add	Existing	Simulation…	from	the	menu.	To	play	the	animation,	use	the	operating	system	to	browse	to	the	directory	where	the	simulation	is	located.	Export	the	completed
model.	Check	and	fix	stereolithography	(.stl)	geometry	files	using	netfabb	Basic	and	pyAdmesh,	Add	.stl	geometry	to	a	simulation,	Add	simple	geometry	to	a	simulation	using	"primitives",	Create	holes	in	geometry	(Boolean	operations),	Transform	geometry	(rotation,	translation,	magnification).	Close	the	dialog	to	return	to	the	normal	setup	view.	Toggle
the	Geometry	tree	using	the	button.	You	may	need	to	add	more	integration	steps	(100,000	shown	below)	to	complete	the	lines.	Common	errors	include	inverted	normals,	zero-area	facets,	non-manifold	edges,	and	holes.	Repeat	if	necessary	until	the	mouse	arrow	becomes	a	cross-hairs	when	you	hold	Shift.	VELOCITY	Umacro	(m/s)	0.000	0.001	0.002
0.003	0.004	0.005	0.006	0.007	0.008	0.009	0.010	0.011	0.012	0.013	0.014	0.015	0.016	0.017	0.018	0.019	0.020	MICRO.	Page	3	of	10	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	c.	If	an	implicit	method	will	not	result	in	a	significant	speed	up,	then	explicit	methods	are	preferred	because	they	are	more	reliably
accurate.	Go	to	the	Model	Setup	>	Meshing	&	Geometry	tab.	When	the	file	is	done	loading,	select	MiddleRioGrande	–	Cloud	in	the	DB	Tree	pane	at	the	upper	left:	this	displays	some	data	about	the	cloud	in	the	Properties	Page	4	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	panel.		Stagnation
Pressure	type	boundaries	specify	a	free	surface	elevation	and	represent	a	fluid	source	with	zero	velocity	but	known	depth	(i.e.,	a	reservoir).	Page	11	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	3.	Hide	it	on	the	View	menu	>	Baffle	Options	dialog.	Check	that	the	Data	Size	(point
count)	reported	is	about	870,000	points.	Problem	Description	and	Objectives	The	model	represents	a	simple	piston-driven	inkjet	print	head	with	a	contaminant	(particle	of	dirt)	in	the	ink.	Assume	the	pipe	is	hydraulically	smooth.	An	easy	but	time-consuming	way	to	model	upstream	turbulence	is	to	model	the	upstream	pipe	flow	explicitly,	and	then
make	a	restart	simulation	with	an	upstream	grid-overlay	(GO)	boundary	to	copy	the	calculated	TKE	to	a	new	boundary	in	a	smaller	domain.	Number	of	Fluids	=	One	Interface	Tracking	=	Free	surface	or	sharp	interface	Flow	Mode	=	Incompressible	Units	=	CGS	/	Kelvin	Finish	time	=	1E-4	seconds	Number	of	Processors	=	2	Select	Physics	Options	1.
Access	the	Streamline	Edit	dialog	or	select	Tools	>	Streamline	Edit.	o	In	section	summary	of	open	areas	at	inter-block	boundaries,	is	the	percent	difference	less	than	1%	(ideal),	3%	(typical)	or	5%	(usually	the	max	acceptable)?		Average	Particle	Radius:	typically	taken	to	be	between	0.5	mm	and	1	mm	for	air	bubbles,	but	the	data	scatter	is	significant.
Page	7	of	11	FLOW-3D	Version	11	Simulation	Setup		Valves	allow	gas	(aka	“void”)	bubble	pressure	to	escape	the	domain	in	a	realistic	way.	Intro	to	Testing	for	Uncertainty	One	interesting	test	is	to	examine	the	model	sensitivity	to	the	air	bubble	size.	Center	mouse	button	and	drag	to	pan	the	part	and	coordinate	system.	Some	possible	project	elements
have	been	omitted	(generating	geometry,	for	example).	Page	16	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:	Running	&	Post-Processing	an	Example	Simulation	Solidification:	Only	available	if	the	solidification	model	is	active.	See	Exercise	1	for	more	explanation.	Fluid	regions	overwrite	global	areas	that	they	overlap.	Cells	that
have	a	large	open	facial	area	to	volume	ratio	are	likely	to	have	high	fluxes	which	can	limit	the	time	step	(slow	down	runtime).	New	York,	NY:	Hemisphere	Publishing	Corp.	The	default	compression	for	animations	is	Full	Frames	(Uncompressed)	and	is	not	recommended	since	the	file	size	can	be	quite	large	and	difficult	to	load	in	video	players	and	slide
show	presentations.	Another	important	test	is	the	mesh	dependency	of	the	results.	Right-click	on	the	title	Mesh	Block	3:	FINER	WEIR	BLOCK	and	select	Auto	Mesh…	2.	Large	column	operations	fail.	The	US	Bureau	of	Reclamation	(USBR)	Water	Measurement	Manual	(3rd	edition	revised	2001)	and	Water	Measurement	Structures	(3rd	edition	revised
1989)	by	M.G.	Bos	are	guides.	An	ellipsoidal	obstacle	lying	on	its	side	will	be	embedded	in	the	channel	downstream	of	the	weir.	Select	Subcomponent	>	Cylinder	from	the	menu	above	the	display.		Add	and	define	history	probes	and	sampling	volumes	Follow	the	annotated	diagram	for	locations	to	measure	output	variables	and/or	check	known
variables.	Scroll	up	through	the	text	output	displayed	below	the	plots	and	find	the	same	warning.		Deactivate	cells	by	adding	a	domain-removing	component.	Color	the	layer.	Select	Fluid	Elevation	and	set	the	value	=	4.2	(measured	from	Cartesian	z	=	0).	Tables	4	and	5	illustrate	the	file-size	reduction	that	can	be	achieved	through	post-conditioning	the
.stl	part:	simplifying	the	non-important	surfaces	and	converting	it	to	binary	format.	Text	commands	used	for	this	tab	are	given	in	the	User	Manual	chapter	on	Post-Processing.	Now	Delete	all	the	layers	(on	the	Layer	Dialog)	and	Import	the	point	cloud	you	just	saved	(which	has	been	stripped	of	all	facet	data	and	will	now	be	easier	to	work	with).	Enter
Weir	Geometry	as	the	simulation	name.	Output	frequency	=	1/10th	of	the	finish	time	by	default.	If	modeling	another	liquid,	0.5	would	make	sense.	Remember	that	i,j,k	values	are	block-specific,	while	x,y,z	values	are	global.	There	are	many	other	possible	workflows	that	involve	3rd-party	commercial	software	that	may	be	faster	or	more	reliable.	Page	7
of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	13.	This	makes	all	values	less	than	the	maximum	render	as	gray,	and	values	equal	to	the	maximum	will	be	displayed	as	red.	To	create	the	animation,	select	Tools	>	Animation	>	Rubberband	Capture.	These	errors	can	cause	bad	pressure	and	velocity	solutions	in
FLOW-3D.	The	prp	prefix	means	a	file	is	preprocessor	output,	and	the	fls	prefix	indicates	flow	solver	output.		Do	the	solver	text	and	runtime	plots	indicate	that	the	time	step	sizes,	pressure	iterations,	mean	and	turbulent	kinetic	energies,	and	fluid	volume	are	appropriate?	Abbood	of	Al-mustansiryiah	University,	Baghdad,	Iraq	(published	in	the
proceedings	of	the	Thirteenth	International	Water	Technology	Conference,	2009,	Hurghada,	Egypt).	This	is	common	when	cross-boundary	aspect	ratios	are	greater	than	2:1.	3.	For	example:	Figure	7.	One	solution	for	the	Y-direction	would	be	to	move	the	walls,	but	that’s	a	trick	that’s	only	appropriate	for	testing	CFD	code.	CGS	(centimeters,	grams,
seconds)	is	selected	for	the	Simulation	Units.	More	“ghost	cells”	that	are	associated	with	boundary	conditions	will	be	added	when	you	preprocess	the	simulation,	and	cells	in	solids	and	unused	parts	of	the	conforming	block	will	be	removed,	so	this	is	a	preliminary	estimate.		Is	it	possible	to	get	the	necessary	outputs	from	post-processing?	Click	Save.
Stereolithography	file	format	(.stl)	is	a	non-proprietary	system	for	recording	3-D	surfaces.	Page	1	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	FLOW-3D	Learning	Objectives	In	this	exercise	you	will	learn	techniques	to:	1.	above	the	runtime	plots.	Visualize	the	signed	error	distribution.	Page	6	of
13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	Use	Solver	Text	Output	to	Diagnose	Errors	1.	Minimize	&	quantify	the	mesh	dependency	Your	model	is	working	as	expected	and	has	been	proven	to	run.	Translated	Area	of	Interest	Z	(m)	-0.167	to	570.000	0.00	-0.167	to	570.000	570.167	STEP	4	–	USE	MeshLab	TO	PREPARE
THE	TOP	SURFACE	Skip	the	pre-decimation	step	described	in	the	Creating	.STL	Files	from	LiDAR	exercise.	Plot	Free	Surface	Elevation	and	Fluid	Depth.	Check	for	each	expansion	that	the	cell	size	remains	the	same.	Use	2-D	plots	to	visualize	the	location	of	the	minimum	stability	criteria.	number	of	pressure	iterations	during	the	cycle	iter,	7.	Select
Simulate	>	Run	Simulation	>	Local	from	the	menu	at	the	top.	Pressure	=	0	(at	the	free	surface),	d.	Does	not	memory.	The	Reynolds	number	is	therefore	4.2E5,	so	the	flow	is	fully	turbulent.	Select	the	Model	Setup	>	Fluids	tab.	Page	1	of	11	FLOW-3D	Version	11	Simulation	Setup		Determine	the	general	modeling	approach	Decide	how	to	approach	the
problem	using	the	annotated	diagram	as	a	guide.	Review	the	meaning	and	significance	of	convective	flux	errors.	Add	a	new	mesh	block,	ignoring	it’s	dimensions	for	now.	Experiment	with	different	levels	of	Transparency.	Mesh	Planes	must	never	be	used	to	try	to	resolve	fluid	free	surfaces.	2.	Activate	the	RNG	Turbulence	Physics	Model	The	presence
or	absence	of	turbulence	can	be	determined	using	Reynolds	number	relations;	in	our	case	it	can	be	assumed	that	the	flow	is	turbulent.	So	FPSCL1	=	QV,AIR	=	96.1	cm3	air/s.	Under	Output,	select	the	Binary	STL	radio	button.	Use	right-click	Reassign	if	necessary	to	match	the	picture.	If	you	are	unsure	of	a	value	or	selection,	ask	the	instructor.	On	the
Analyze	>	3-D	tab,	find	the	Iso-surface	dropdown.		Report	validation	uncertainty	(optional)		Report	estimated	numerical,	input,	and	experimental	uncertainty	and	methodology.	If	multiple	repairs	do	not	solve	the	problems	then	re-export	the	.stl	file	from	CAD.	The	way	to	deal	with	this	is	to	quantify	the	uncertainty	of	the	CFD	results	due	to	the
uncertainty	in	the	input	parameters.	The	text	output	lists	a	summary	of	the	simulation	at	each	Short	Print	Data	Interval.	Set	point-sampling	stencil.	The	entire	part	is	selected	so	all	faces	are	green.	They	remove	volume	from	other	subcomponents	that	come	before	them	in	their	component	tree.	This	is	an	optional	step	that	reduces	the	number	of	points
in	the	data	set.	Same	dialog	>	Mass	Properties	tab:	Mass	Density	=	7.6	g/cm3	Check	your	Moving	Object	Setup	dialogs	against	the	images	on	the	next	pages.	2-D	plot	Volume	Fraction	of	Entrained	Air,	using	Contour	Limits	=	Global,	and	Vector	Type	=	No	Velocity	Vectors.	The	way	to	do	this	is	to	recombine	and	simplify	only	the	facets	of	the
surrounding	box.	Choose	Unify	Duplicated	Vertices	during	import.		If	particle	physics	are	activated,	define	particle-counting	bins	manually	in	the	prepin	file	namelist	$PARTS	(see	User	Manual	>	Input	Variable	Summary	and	Units	chapter	>	Particle	Setup:	Flux	Surface	and	Sampling	Volume	Data	section).	The	.mlp	file	stores	no	information	about	the
points	or	faces.	Check	your	work	and	correct	mistakes	with	the	following	methods:	a.		Run	and	post-process	the	coarse	case	If	deadlines	are	pressing,	only	run	a	portion	of	the	case.	Note	that	the	Particle	Type	option	grays	out	because	there	is	no	particle	data	in	the	Selected	data	set	(it	wasn’t	activated	on	the	Output	tab).	The	default	is	‘S’	for
Symmetry	boundary.	Page	17	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions		Outflow	type	boundaries	are	appropriate	when	the	flow	is	supercritical.	Save.	The	stability	limit	is	the	smallest	time	step	required	for	any	explicit	solver	(e.g.,	convection).	Precise	minimum	and	maximum	coordinates	of
original	data	from	CloudCompare	3)	Clean	the	data	by	manually	removing	artifacts.	Rigorous	uncertainty	estimation	is	an	ideal	that	is	not	always	necessary	or	feasible	in	practice	(e.g.,	when	CFD	is	used	to	qualitatively	compare	potential	designs).	Figure	14.	Will	there	be	unnecessary	splashing	on	solid	surfaces?	Click	Transform,	and	set	Translate	Y	=
7.	Select	Tools	>	Statistics	>	Compute	Stat.	Select	both	the	cloud	and	.stl	layers,	and	re-run	the	Tools	>	Distances	>	Cloud/Mesh	Dist	tool.	Export	the	subsampled	mesh	with	no	normals	as	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833.xyz.	The	button	fits	the	domain	and	geometry	to	the	view	window.	Make	sure	you	have	selected	all	time	steps
with	the	Time	Frame	Sliders	and	click	Render.	Accept	the	changes	by	clicking	Apply	Repair	to	generate	a	new	fixed	part.	Page	22	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	REFERENCES	1.	Load	the	comparison	data.	The	discrepancy	between	approaches	is	a	source	of	uncertainty.	One	last
calculation:	1.	Use	probability	distributions	that	describe	the	likely	possibilities	of	the	“real”	value	of	the	input	variables	to	reduce	the	number	of	models,	if	possible.	Select	Plane	=	XZ.	There	are	several	ways	to	approach	this.	o	Check	that	inter-block	boundaries	are	not	located	in	high	flow-gradient	regions.	Note	the	red	facet	on	the	left	side	of	the
crest.	If	no	experimental	data	is	available	with	similar	Fr	and	Re,	then	successively	vary	the	mesh	resolution,	air	entrainment	rate	coefficient,	and	bubble	size.	Save	the	simulation	from	the	File	menu	at	the	top.	This	does	not	matter	because	the	actual	extents	of	Block	4	after	it	conforms	to	the	weir	will	be	inside	Block	3,	and	the	ratio	will	be	2:1	there.
The	total	number	of	real	cells	defined	in	all	the	blocks	is	1,983,000	cells.	Export	the	simplified	part	in	Binary	Format	as	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833_MLquad.stl.	Later	you	will	add	more	Mesh	Planes	(user-specified	grid	lines)	to	resolve	tricky	parts	of	the	geometry	and	improve	interpolation	at	the	inter-block
boundaries.	Englewood	Cliffs,	NJ:	Prentice-Hall.	Divide	3.048	by	18	to	find	the	exact	cell	size.	The	problem	occurred	before	these	plots,	but	they	still	show	why.	Since	there	is	no	free	surface	in	the	model,	do	not	use	Surface	Tension	physics.	From	this	you	can	find	many	summaries,	including:					The	final	number	of	cells	including	ghost	cells	and	cell
deactivation	effects,	The	exact	location	of	all	grid	lines	and	cell	centers,	Adjustments	made	to	the	geometry	to	eliminate	“sliver	cells”	(described	in	more	detail	in	the	lectures	on	Numeric	Options	and	Troubleshooting),	and	Disagreement	between	geometry	resolution	at	inter-block	boundaries.	Find	the	number	of	points	TOPO2STL	will	either	retain	or
create	by	multiplying	the	data	extents	in	X	and	Y	(60	x	180	=	1800	ft2)	Page	11	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	and	dividing	by	the	spatial	resolution	squared	(0.08332)	to	get	the	approximate	total	number	of	points	(1.6	million).	Are	there	sliver	cells?	Use	the	X-Y	View	button	to	view	the
mesh	from	above.	Mesh	Dependent	History:	Only	available	on	the	Probe	sub-tab.	For	this	exercise,	let’s	assume	it’s	(2).	10	Final	Check	after	setup	...............................................................................................................................	Click	and	hold	the	left-mouse	button	and	move	the	mouse	in	the	Meshing_Geometry	window.	Check	that	the	mesh	tree
matches	the	next	page,	and	the	mesh	seen	from	above	matches	the	page	after	that.	The	atmospheric	pressure	(gauge	or	absolute)	must	be	specified	at	all	Pressure-type	boundary	conditions,	and	as	the	initial	void	pressure.	Load	results	files,	6.	Water	Resour.	15	INTRODUCTION	This	note	outlines	a	method	for	converting	large	topographic	data	sets	to
.stl	format	for	use	with	FLOW3D.	There	are	many	empirical	approaches	that	predict	the	velocity,	pressure,	and	fluid	fraction	of	flow	within	the	media.	to	export	the	geometry	file.	Check	that	Current	Scalar	Field	=	C2M	Distances	in	the	Properties	panel.	“Statistics	for	the	Evaluation	and	Comparison	of	Models.”	Journal	of	Geophysical	Research	90(C5):
8995-9005.	Figure	8:	Importing	velocities	from	a	.csv	file	You	could	also	enter	all	these	values	manually	in	the	table,	but	importing	from	a	.csv	file	is	much	easier.	Hirt,	C.W.	(2003,	2011).	Enter	the	values	shown	below	in	the	dialogs	and	click	OK	to	accept	the	values.	The	stretching	ratio	between	adjacent	cells	should	be	less	than	1.25	or	1.3.	o	As	much
as	possible,	the	cell	face	size	in	nested	blocks	should	be	½	that	of	the	cells	in	the	containing	block.	Select	Flow	Over	a	Weir	from	the	alphabetically-ordered	examples	list	and	Open.	Place	the	new	mesh	planes	in	the	upstream	block:	a.	You	determined	these	in	the	previous	exercise;	to	save	time	the	values	will	be	provided	in	SI	units	(remember	scaling
the	geometry?)	Rules	of	Thumb	1)	2)	3)	4)	Use	Mesh	Planes	as	sparingly	as	possible	because	they’re	likely	to	cause	stretching.	Select	the	original	point	cloud	topography	layer	and	apply	Filters	>	Selection	>	Select	All.	Later	iteration	failures	occur	at	different	locations.	3)	Post-condition	the	.stl	file:	a.	Add	Fluid	Velocities	and	Pressure	as	Selected
Data.	Create	a	sphere	subcomponent	and	assign	it	to	a	new	Component	3:	Dirt.	The	method	outlined	in	this	exercise	has	been	tested	on	a	15-million	point	river	(Middle	Rio	Grande	scale	model),	a	61-million	point	watershed	(Dalalven	river),	and	several	other	sets.	For	example:	LIMIT	Original	max/min	coordinates	Translate	New	max/min	coordinates
for	modeling	Coordinate	Extents	X	(m)	288,889.7	to	365,560.8	-286,000.00	2889.7	to	79560.8	Y	(m)	3787191.3	to	3826153.5	-3,780,000.00	7191.3	to	46153.5	76,671.1	38,962.2	Table	1.	Select	Pressure.	The	FLOW-3D	output	will	need	to	be	shifted	back	by	the	opposite	sign	of	these	values	to	get	UTM	coordinates.	The	sharp	interface	option	tracks	the
location	and	orientation	of	the	fluid	interface	within	cells,	and	permits	free	surfaces	in	one	fluid	models.	Use	MeshLab’s	Fill	Hole	tool	to	repair	any	trivial	holes	that	remain	from	simplification,	and	then	iteratively	use	the	Self-Intersection	repair	option	on	the	single	large	hole	on	the	back.	Click	Additional	Variables	below	the	Color	Variable	selection.
Comparison	of	cleaning	methods	for	MiddleRioGrande.txt	The	precision	loss	is	due	to	rounding	of	large	numbers.	The	two	values	should	be	considered	additive.	Select	Import	to	Column	=	W	in	the	lower	right	of	the	dialog.	When	the	probed	point	is	in	empty	space,	the	X-value	displayed	there	is	an	estimate	(around	-42)	of	the	domain	extent.	Text
Output:	Restart,	Selected,	and	Solidification	data	can	be	written	to	text	files	for	every	cell	within	selectable	extents	in	space	and	time.	The	third	will	overlap	and	bridge	the	two	coarse	blocks,	and	the	fourth	will	be	conforming	and	will	be	added	later.	It	comes	bundled	with	FLOW-3D.	Rearrange	the	Froude	equation	and	solve	to	find	the	mean	upstream
velocity	U	=	210	cm/s.	Expand	the	Mesh	-	Cartesian	>	Mesh	Block	1	tree	and	expand	Block	1's	X	Direction,	Y	Direction,	and	Z	Direction	subtrees.	It	can	be	downloaded	from	www.danielgm.net/cc/.	The	.stl	file	format	may	be	either	binary	(smaller	file	size)	or	ASCII	(readable	in	text	editors);	see	Appendix	A	for	the	format	definitions.	Does	not	complete
within	1	hour.	This	section	will	sharpen	your	meshing	skill.	Copy	an	existing	simulation	to	a	new	folder	in	FLOW-3D,	2.	Z	low	=	undefined,	Z	high	=	0	cm.	Right-click	on	the	new	(highlighted)	Weir	Geometry	and	select	Rename.	It’s	a	dimensionless	volumetric	fraction:	the	volume	of	air	per	volume	of	liquid.	Save	your	simulation!	Initialize	Fluid	Regions
&	Hydrostatic	Pressure	If	you	run	your	simulation	right	now	it	will	take	a	long	time	to	reach	steady-state	because	it	will	fill	the	empty	domain	before	topping	the	weir.	Set	all	Z	Min	boundaries	as	Wall	with	no	tangential	velocities.	5)	Nested/linked	blocks	should	have	cell	sizes	that	are	even	multiples	of	their	neighbors.	An	example	of	this	situation
would	be	two	liquids	(water	and	oil,	e.g.)	that	flow	as	unmixed	phases	in	different	parts	of	the	domain.	The	mesh	can	be	viewed	from	the	Mesh	menu	item.	Page	2	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Select	Physics	Models	Physics	models	should	be	considered	carefully	for	all	simulations.	Have	a
rationale	for	each	value	on	the	list.	Compare	your	results	to	Figure	9.		Richardson-Zaki	Coefficient	Multiplier:	this	should	be	1.0	for	the	standard	Richardson-Zaki	correlation,	which	describes	the	additional	effect	of	particle-particle	(bubble-bubble)	wake	interaction	in	a	concentrated	cloud	of	the	dispersed	phase.	Fused	UTM	projections	in
CloudCompare	Page	4	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Use	Edit	>	Scalar	Fields	>	Filter	by	Value	to	create	a	new	cloud	with	elevations	above	570	m	removed.	within	½	hour.	You	will	also	specify	a	hydrostatic	pressure	distribution	for	fluid	in	the	domain	at	t	=	0	and	at	the	pressure	boundaries.
Instead	of	using	algebra	to	find	the	cell	size,	you’ll	just	place	a	mesh	plane	on	the	crest	and	the	floor	instead.	Open	CloudCompare	and	select	File	>	Open.	Check	that	the	text	below	the	plot	shows	the	range	ix	=	78	to	86	and	kz	=	2	to	32.		Specify	motion	properties	only	if	the	source	moves	during	the	simulation.	Component	2:	Piston:	the	piston	will
move	in	the	z-direction	to	eject	an	ink	droplet.	In	the	image	below,	you	can	see	that	there	are	some	obvious	artifacts:	many	look	like	people	or	equipment.	o	Yes:	consider	a	one-fluid	model:	decide	if	the	gas	pressure	and	temperature	change	with	time	(meaning	one	of	the	bubble	&	phase	change	physics	models	is	needed).	In	regions	where	there
wasn’t	any	data	in	the	original	point	cloud,	this	adds	unnecessary	size	to	the	file.	Make	linked,	nested,	and	conforming	meshes,	3.	The	goal	of	meshing	is	to	resolve	the	flow	features	and	geometry	adequately	to	get	good	results.	Page	12	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	Import	the	Downstream
Bed	.stl	File	1.	There	are	a	number	of	boundary	edges	(meaning	the	part	is	not	closed),	non-manifold	vertices,	and	incident	faces.	The	numbers	on	either	side	of	the	slider	show	you	the	Cartesian	coordinate	of	the	slider.	Check	the	.stl	file	using	netfabb	Basic:	a.	Color	Options:	Colors	can	be	assigned	to	components,	subcomponents,	and	mesh	blocks.
On	the	Model	Setup	>	Physics	tab,	select	the	Viscosity	and	Turbulence	button.	Reselect	the	triangulated	surface	as	edges	in	SketchUp.	Page	5	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	Figure	7.	Add	mass/momentum	fluid	sources,	8.	General	history	data:	non-cell-specific
quantities	which	vary	with	time.	Page	9	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	Figure	12.	1)	Format	the	text	file.	Set	Minimum	Z=	-250	m	and	Spatial	Resolution	=	30	m.	Page	9	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	Specify	the
Simulation	Units	as	SI	1.	Converting	the	ASCII	TOPO2STL	output	to	binary	format	is	recommended.	Halve	the	cell	sizes	or	double	the	cell	counts	to	refine	by	a	factor	of	2.	This	will	display	one	planar	slice	along	the	cell	centers	of	Block	4.	The	experiment	models	a	bent	pipe	that	discharges	below	the	surface	of	a	standing	pool.	Find	the	text	Console
panel	at	the	bottom	of	the	screen	(press	F8	to	toggle	it).	A	minimum	of	three	grids	is	recommended.	When	it	is	close	to	epsi,	it	implies	that	the	convergence	criteria	selected	is	an	efficient	choice.	Select	OK	to	begin	the	import.	Activate	Display	Color	Scale	under	SF	Scale.	Go	to	the	Analyze	>	Probe	tab	and	select	Data	Source	=	General	History.	Return
to	the	Analyze	>	Probe	tab	and	select	Text	as	the	output	form.	Without	experimental	or	simulation	data	we	can	only	estimate	the	characteristic	velocity.	The	mean	unsigned	error	is	referred	to	as	the	Mean	Absolute	Error	(MAE).	When	you	hold	the	Shift	key	a	black	cross	target	appears	(if	it	doesn’t	try	releasing	and	re-pressing	Shift).	Page	15	of	19
Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Run	the	Simulation	and	Review	Runtime	Output	The	model	is	completely	set	up,	so	go	ahead	and	run	it.	Set	Spatial	Resolution	=	0.0833	feet.	When	stagnation	pressure	is	turned	off,	the	boundary	condition	is	called	static	pressure.		Start	by	selecting	the	largest	cell
sizes	in	X,	Y,	Z	so	that	there	are	even	multiples	of	the	largest	cells	between	every	set	of	adjacent	mesh	planes	and	important	flat	surfaces.	Select	Continue	and	a	file	selection	dialog	will	be	presented.	Estimate	the	total	number	of	surface	points.	Use	the	Geometry	Function	filter	to	set	the	elevation	of	all	points	in	the	layer	to	Z	=	-2	m.	Render,	select,
and	delete	non-manifold	vertices	STEP	9	–	CLOSE	TRIVIAL	HOLES	Use	the	Select	Borders	filter	to	identify	holes	generated	from	the	first	simplification.	There	a	number	of	ways	in	which	to	visualize	the	results	of	a	simulation.	If	yes,	consider	using	the	two-liquids	and	free-surface	workaround	(set	RHOFS	&	MUS	as	the	density	and	viscosity	of	the
second	liquid	in	the	prepin	file	namelist	$PROPS,	and	then	set	all	initial	and	boundary	condition	densities	as	liquid	mixture	densities	between	RHOFS	and	RHOF).	Select	Custom	output	files	and	the	flsgrf	file,	and	then	select	OK.	If	the	Extrude	Tools	toolbar	doesn’t	appear,	right-click	on	the	toolbar	and	select	Extrusion	Tools	from	the	list.	Open
Windows	Start	Menu	>	All	Programs	>	netfabb	Basic	>	netfabb	Basic.	Select	OK	to	close	the	text	file.	Z.	FAVOR	embeds	the	geometry	and	initialized	fluid	in	the	current	computational	mesh	using	the	same	routines	as	the	preprocessor.	Typically	less	than	1%	to	3%	loss	is	acceptable.	Because	this	is	a	2-D	model	that	ignores	the	curvature	of	the	pipe,
the	true	meaning	of	h	will	also	be	ignored	(again	contributing	to	the	results	being	“for	illustration	only”).	Clean	the	data	by	manually	removing	artifacts.	Select	the	new	layer,	then	Filters	>	Normals,	Curvatures,	and	Orientation	>	Transform:	Move,	Translate,	Center.	Open	the	Weir_Geometry	folder.	2	Select	and	calibrate	numerical	methods
......................................................................................................	Do	the	results	make	sense?	FRONT	EST.	and	enter	the	values	shown	below.	Page	1	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Figure	1:	Experimental	apparatus	from	Abood	(2009)	Select	Model	Approach	The	media	tubes	are	straight
cylinders	without	bends,	so	the	Cylindrical	coordinate	system	can	be	used.	To	load	the	results	file,	select	the	Analyze	tab.	Poor	resolution	of	the	crest	may	cause	too	little	contraction	or	nappe	spring.	Use	more	rigorous	methods	if	in	doubt.	The	solid	and	domain-removing	components	deactivated	29%	of	the	cells.		Calculate	the	mesh-sensitivity	of	the
results		The	results	should	be	converging	on	a	constant	value.	Maximum	Number	of	Iterations	ITVSMX	=	50	Run	and	Troubleshoot	the	Simulation	1.		Irmay,	S.	The	slice	will	contain	the	problem	cell.	Define	Geometry	The	general	process	for	the	Model	Setup	>	Meshing	&	Geometry	tab	will	be	to	define	the	geometry,	assign	properties	to	the
components,	define	the	mesh	and	boundary	conditions,	and	then	set	the	initial	state	of	the	fluid	and	void.		If	no	test	case	was	run	first,	or	if	the	test	case	is	significantly	different	from	the	design	case,	then	perform	a	mesh	dependency	study	as	described	above	for	the	test	case.	Name	it	Weir	Mesh.	YES.	Locate	the	Precise	Results	section.	Note	there
that	the	file	has	15,010,488	points.	Open	CloudCompare	and	load	MiddleRioGrande_MLASCtxt_clean.xyz	(set	file	type	to	ASCII)	and	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833_netfabb.stl	(file	type	STL).	Identify	the	location	point	of	each.	Color	the	points	by	elevation.		Add	all	the	simulations	to	the	run	queue	and	run	them	in
order.	Make	a	2-D	plot	with	the	following	settings:	a.	Page	9	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	The	problem	cell	is	just	inside	the	top	of	the	pipe.	The	error	mean	and	deviation	should	be	reported	in	terms	of	these	unsigned	values.	MeshLab	has	a	lot	of	little	quirks	like	this.	Give	descriptive	names	to	each
component.	Alt	+	Enter	to	enter	full	screen	mode.	Next	you	will	add	the	walls.	Carefully	Shift-click	on	the	edges	of	the	notch	at	the	points	shown.	Do	the	boundary	conditions	and	initial	conditions	match?		Bejan,	A.	Click	Continue	to	close	the	text	output	dialog.	Don’t	worry	about	inputting	numbers	yet.	Repair	data	for	TOPO2STL	output	of	pre-cleaned
&	pre-filled	point	sets	without	pre-decimation	Page	18	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	8)	Check	the	output	(quality	control).	You	can	save	the	text	file	with	Save	As.	Click	Continue	to	close	the	text	output	dialog.		Define	any	necessary	properties	of	the	interface	Define	the	properties	of
the	interface	between	regions	of	F	=	1	and	F	=	0.		Allow	Gas	to	Escape	at	Free	Surface	allows	phase	#2	to	disappear	at	free	surfaces	and	should	be	activated	for	the	best	physical	representation	of	bubbles.	Out-of-memory	error.	For	example,	results	for	three	roughness	values	can	be	fit	logarithmically	to	predict	the	value	that	will	minimize	the
model/experiment	disagreement.		Check	Probe	and	Text	outputs.	Click	OK	to	begin	the	next	step	of	the	process.	Uncompress	it	and	run	Topo2STL.exe	to	launch	the	file	selector.	The	spatial	resolution	selection	directly	affects	the	file	size.	If	it’s	set	up	as	defined	above,	there	will	be	dozens	of	consecutive	pressure	iteration	failures.	Table	3	shows	the
conversion	time	for	various	spatial	resolutions,	with	and	without	pre-conditioning	the	data	set.	The	equations	of	the	Drift	Flux	model	do	not	make	physical	sense	for	any	other	value	when	the	two	phases	are	different	states	(liquid	vs.	If	your	results	don’t	match,	try	to	determine	why,	and	then	ask	an	instructor	for	help.	If	yes,	consider	adjusting	the
history	probe	location.	Select	Browse	(next	to	the	Input	box)	and	then	find	your	local	copy	of	weir1_repaired.stl.	The	view	will	switch	to	the	Display	tab	and	101	plots	will	be	listed	in	the	Available	Time	Frames	list.	Topography	will	be	added	to	the	downstream	channel	bottom.	The	default	spatial	extents	are	set	to	the	entire	domain,	and	the	default	time
extents	are	the	last	time	step	only.	Select	Diagnostics	>	Preprocessor	Summary	to	view	the	prpout.Weir_Mesh	file	generated	by	the	preprocessor.	In	actuality,	scalars	can	be	defined	with	any	consistent	measure	of	amount	unless	Density	Evaluation	physics	are	active:	then	density	scalars	must	be	defined	as	mass/volume.	Reflecting	Results	Across	a
Symmetry	Boundary	The	simulation	was	set	up	with	a	symmetry	plane	as	a	boundary	condition	along	the	centerline	of	the	weir.	1979.	Activate	surface	tension	model	b.	“topography.”	,	retrieved	3/7/2013.	This	isn’t	a	problem	for	FLOW-3D;	the	partially	blocked	cells	will	get	area	fractions	and	volume	fractions	that	correctly	locate	the	solid	surfaces
inside	them.	POINT	POINT	CLOUD	TO	.STL	DISTANCE	MAGNITUDE	(FEET)	SPACING	FOR	RAW	DATA	SET:	CLEANED	DATA	CLEANED	DATA	SET	MESHLAB	NOT	CLEANED,	NOT	SET	WITH	EMPTY	WITH	EMPTY	PREPRE-FILLED,	NOT	REGIONS	PRE-	REGIONS	PRE-FILLED	DECIMATION	DECIMATED	FILLED,	NOT	PRE-	&	POISSON-DISK
PRE&	TOPO2STL	DECIMATED	DECIMATION	TO	SAMPLING	TARGET	TOPO2STL	SPACING	¼-inch	TOPO2STL	could	not	Max:	0.247521	Max:	0.146637	(0.0208	feet)	convert	the	raw	data	Mean:	0.004533	Mean:	0.004532	within	4	days	σ:	0.004472	σ:	0.004175	½-inch	MeshLab	could	not	Max:	0.307642	Max:	0.200105	(0.0416	feet)	simplify	non-river
Mean:	0.006653	Mean:	0.006409	facets	in	12	hours	σ:	0.006960	σ:	0.006309	1-inch	Max:	0.33902451	Max:	0.324913	Max:	0.242234	(0.0833	feet)	Mean:	0.010307	Mean:	0.010395	Mean:	0.009717	σ:	0.012193	σ:	0.012463	σ:	0.010644	2-inch	Max:	0.383123	Max:	0.379844	Max:	0.316623	(0.1666	feet)	Mean:	0.016889	Mean:	0.017011	Mean:	0.016472
σ:	0.023922	σ:	0.023929	σ:	0.019153	Table	6.	Iso-surface:	The	surface	(interface)	to	draw	in	three	dimensions.	time.	Select	OK.	Page	5	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	2:	Setting	Up	Geometry	3.	Requires	text	commands.	Other	View	Options:	experiment	with	the	following.	Open	the	Boundaries	branch	of	the	Mesh	–
Cylindrical	tree.	If	yes,	consider	no	fluid-to-solid	heat	transfer.	Additional	finish	conditions	can	be	based	on	time,	fill	fraction,	or	steadystate	criteria.		Check	the	pre-processed	text	output	files		Were	any	errors	noted	in	Diagnostics	>	Preprocessor	Errors	(prperr.xxx)?	Step	through	the	images	by	selecting	time	steps	from	the	list	at	the	right.	You	could
just	continue	working	on	the	same	prepin	file,	but	for	practice	you	will	copy	the	completed	project	and	add	it	to	the	Portfolio.	Five	different	media	types	were	studied:	crushed	sand,	crushed	coal,	glass	beads,	crushed	garnet,	and	crushed	porcilinaite.	or	select	the	icon	in	the	toolbar.	Ignore	them.	Complex	geometry	must	be	imported	in
stereolithography	(.stl)	format.	Selection	commands	(when	a	selection	tool	is	active)								Left-click	and	drag	to	draw	a	box	and	select	all	faces	or	vertices	in	it	(even	those	behind	surfaces).	The	total	error	should	usually	be	much	less	than	5%.	o	The	ratio	between	the	longest	and	shortest	side	of	each	cell	should	be	less	than	3:1.	Choose	Default	Repair
and	Execute.	Page	12	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	This	model	predicts	a	flow	rate	of	about	2.4	m3/s,	while	the	Kindsvater	and	Carter	(1957)	equations	predict	about	2.1	m3/s.	You	will	see	the	image	shown	below.	Repeat	for	all	ArcGrid	sets.	Enter	the	values	shown	below.	Convection	in	Porous	Media,	3rd
Ed.	New	York,	NY:	Springer	Science+Business	Media.		The	design	mesh	is	either	the	converged	mesh	or	the	finest	mesh	that	is	feasible.	Page	8	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	12.	Select	Part	>	Add	and	navigate	to	Libraries	>	Documents	>	FLOW-3D	>	FLOW-3D	Projects
>	Hydraulics_Examples	>	Weir_Geometry	>	Weir1.stl.	Moving	and	Simple	Deforming	Objects	a.	If	there	is	no	free	surface,	try	pure	2nd-order	momentum	advection.	Page	16	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Add	Boundary	Conditions	Upstream	boundaries	are	typically	one	of	the
following:		Volumetric	Flow	Rate	or	Velocity	type	boundaries	specify	a	free	surface	elevation	and	flow	rate	or	velocity.	The	equations	to	derive	these	values	from	known	data	are	given	below	as	a	formal	exercise,	based	on	the	equations	in	the	User	Manual.	This	ensures	that	the	gridlines	of	regular	(not	stretched)	cells	in	neighboring	blocks	will	line	up
exactly,	minimizing	interpolation	error.	Two	million	cells	is	a	lot	for	a	classroom	simulation.	Set	Mesh	Type	=	Conform	to	Blocked	Volume.	Recombining	facets	into	larger	ones	only	where	no	data	originally	existed	is	the	recommended	way	to	reduce	the	final	.stl	size.	They	are	important	for	checking	the	setup.	This	is	the	upstream	edge	of	the	nested
block.	Measurements	were	taken	from	three	flow	meters	and	four	differential	pressure	gauges.	Check	that	the	Subcomponent	Type	=	Hole.	They	do	not	specify	pressure.	Import	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833.stl	into	MeshLab.	Water	levels	above	the	specified	elevation	exit	the	domain,	and	levels	below	the	specified
elevation	(or	pressure)	draws	fluid	in.	Remove	the	plane	vertices	that	overlap	the	point	cloud	center.	Toggle	the	Mesh	display	under	DB	Tree,	rotate,	pan,	and	zoom	the	view,	and	increase	Point	Page	19	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	Size	(+)	until	you	locate	the	point	of	greatest	error.
Choose	Default	Repair	and	then	Execute.	½-inch	6.24	million	15.0	million	pts	in/	18.6	million	pts	in/	4.43	million	pts	in/	(0.0416	feet)	points	18	hours/	20	minutes/	10	minutes/	4.88	million	pts	out/	5.83	million	pts	out/	5.85	million	pts	out/	2.45	GB	ASCII	.stl	2.93	GB	ASCII	.stl	2.95	GB	ASCII	.stl	1-inch	1.56	million	15.0	million	pts	in/	18.6	million	pts	in/
0.87	million	pts	in/	(0.0833	feet)	points	3.5	hours/	10	minutes/	2	minutes/	1.22	million	pts	out/	1.39	million	pts	out/	1.37	million	pts	out/	629	MB	ASCII	.stl	714	MB	ASCII	.stl	707	MB	ASCII	.stl	2-inch	0.389	million	15.0	million	pts	in/	18.6	million	pts	in/	0.26	million	pts	in/	(0.1666	feet)	points	10	minutes/	8	minutes/	New	Analysis	>	Standard	Analysis	.
The	max	residual	is	for	the	cell	with	the	maximum	value	of	Ū	after	the	pressure	solution	has	either	converged	or	reached	the	maximum	allowed	number	of	iterations.	Use	MeshLab	for	simplification,	repair,	and	format	conversion.	Load	the	project	by	double-clicking	its	name:	Page	2	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:
Running	&	Post-Processing	an	Example	Simulation	Description	of	the	Primitive	Geometry	The	model	is	a	very	old	validation	case	of	a	sharp-crested	weir.	Activate	Base	Mesh	Subsampling	(very	important)	and	select	Explicit	Radius	(absolute	world	unit)	=	0.0833	for	1-inch	samples.	This	output	is	useful	for	plotting	time-varied	results	along	a	flow	path
that	curves	within	the	mesh.	Don’t	use	the	Save	option.	In	this	case,	let	the	Froude	number	be	3.0	and	the	depth	be	5	cm.	Specify	the	ExtrudeTools_v2.5.rbz	file.	In	this	case	|E|MIN	=	0	and	|E|MAX	=	0.242	feet	≈	7	cm.	You	can	find	this	by	dividing	the	weir	opening	3.048	by	the	already-determined	X	size	0.1674	to	find	nearly	18	cells	across	it.	The
image	in	netfabb	Basic	indicates	that	there	are	errors.	Specify	Number	of	Processors	=	4.	Start	with	the	bottom-right	cell	at	K	=	2	and	count	up	to	17.	Iso-surface	options	>	Component	Iso-Surface	Overlay:	options	for	plotting	the	interface	(surface)	of	solids.	Expand	tree	branches	to	open	Geometry	>	Component	1:	weir	>	Subcomponents	>
Subcomponent	1:	weir	plate	>	Min/Max.	Because	the	part	is	small	relative	to	the	unit	system,	the	camera	may	not	be	zoomed	in	enough	when	you	Render.	Poisson-disk	is	therefore	recommended	for	topographic	applications.	Page	16	of	16	Sometimes	a	model	will	have	splashing,	and	when	drops	hit	a	wall	or	symmetry	boundary	they	can	stick	and	drip
and	make	the	slow	down	the	solver.	We	do	not	know	the	location	of	the	greatest	turbulence:	is	it	the	pipe	outfall	or	the	weir	jet	nappe	impingement?	6	STEP	5	–	ESTIMATE	THE	MINIMUM	STL	RESOLUTION	..................................................................................	Viscosity	=	0.06	Poise	(g/cm/s)	d.	Two	holes	have	been	filled,	all	facets	have	been
connected,	and	unlike	the	qAdmesh	results,	there	is	only	one	shell.	Plotting	Options	in	2-D	1.	The	last	button	toggles	between	orthographic	and	perspective	views.	B.	This	must	be	set	in	the	subcomponent	tree	Limiters.	PROGRAM	Sublime	Text	2	TextPad	6	gVIM	7.3	32-bit	with	LargeFile	plugin	Crimson	Editor	3.70	EditPad	Lite	7	ConTEXT	0.98.6
PilotEdit	Lite	Notepad++	5.9.8	CAN	OPEN	&	CAN	OPEN	&	VIEW	445	MB	VIEW	953	MB	POINT	TEXT	FILE1,3	1,2	CLOUD	YES.		The	interface	tracking	options	define	whether	changes	in	the	fluid	fraction	should	be	sharp	or	diffuse.	Turbulence	is	known	to	be	quite	mesh	dependent,	and	since	the	physics	model	uses	TKE	to	calculate	air	entrainment,
the	volume	of	entrained	air	is	also	likely	to	be	mesh	dependent.	output	cycle	(the	number	of	time	steps	solved	to	date,	including	the	current	time	step),	3.	Cylinder	outer	radius	=	0.0105	cm.	Parameters	that	are	associated	with	inactive	physics	models	will	be	grayed	out.	This	is	already	ideal,	and	fine	for	all	kinds	of	modeling.	In	particular,	if	you	have	a
curved	free	surface	that	moves	(e.g.,	waves),	a	higher-order	option	may	be	desirable.	Page	2	of	7	FLOW-3D	Version	11	CFD	Project	Overview		Are	physics	model	and	component	coefficients	correct?	Check	the	number	of	computational	cells	in	the	mesh,	6.	This	is	often	correct	if	the	fluid	enters	from	a	resting	state	like	a	reservoir.	The	first	four	buttons
reset	the	view.	11.	Tables	3	and	6	indicate	that	better	conversion	speed	and	better	accuracy	can	be	achieved	by	pre-filling	empty	regions	and	pre-decimating	the	data	set.	Consider	adding	domainremoving	components	to	your	sketch	to	turn	off	unused	cells.	Review	the	Runtime	Plots	to	check	for	steady	state.	Intervals	are	specified	in	seconds	and	can
usually	be	left	to	the	default.	Modeling	the	bulking	mixture	effects	requires	adding	Density	Evaluation	physics.	The	meaning	is	as	follows:	a.	Accuracy	statistics	for	1/3	arc-second	data:	original	and	converted	to	.stl	As	of	June	2003,	the	USGS	NED	data	exhibits	vertical	uncertainty	vs.	Component	=	Nozzle	2.	If	not,	consider	gravity	and	noninertial
reference	frame	physics.	STEP	3	–	USE	CloudCompare	TO	COMBINE	AND	TRIM	TOPOGRAPHY	Open	the	new	files	in	CloudCompare.	Save	the	shifted	cloud	(now	with	no	scalar	fields)	and	re-open	it.	Click	Render	to	view	a	gray	iso-surface	fitted	to	the	solver-embedded	solid	geometry.	Move	the	mouse	near	the	upper-left	of	the	display	window	to
display	Point	Size	options.	Z-min	boundary	is	Wall-type.	This	time	select	Fluid	Surface	=	Fluid	1.	Notice	that	the	grid	lines	don’t	match	at	all.	The	rest	of	the	analysis	is	illustrated	below.	OVERVIEW	OF	THE	BASIC	PROCESS	The	steps	to	convert	a	point	cloud	of	XYZ	data	to	.stl	are	as	follows:	1)	Precondition	the	data	for	use	with	TOPO2STL:	Page	1	of
26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	a.	The	Freeze	Matrix	option	means	that	when	the	mesh	is	exported	it	will	include	the	transformations.	The	mentor,	for	example,	suggests	an	implicit	method	when	the	speed-up	will	be	at	least	a	factor	of	10.	Select	File	>	Import	Mesh	and	load
MiddleRioGrande_MLASCtxt.xyz.	Check	that	the	final	values	for	Mesh	Block	4	are	as	shown	below.	Page	7	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	4:	Fluid,	Physics,	and	Initial	Conditions	2.	Pressure	Iteration	Count:	the	default	pressure	solver	is	the	Generalized	Minimum	Residual	method	(GMRES),	which	should	usually
operate	between	1	and	10	iterations	per	cycle.	Select	and	calibrate	numerical	methods	In	this	step,	you	will	test	the	model	sensitivity	to	different	numerical	methods.	Time	history	plots	of	variables	are	created	here.	Go	to	the	Analyze	>	2-D	tab.	FSI-03-TN61R.	The	motion	and	compressibility	of	the	air	can	be	neglected	in	this	case,	so	use	the	one	fluid
method.	This	only	has	meaning	for	dispersed	phases	that	can	flow,	such	as	oil	droplets.	o	If	some	solids	must	have	temperatures	that	vary	in	both	space	and	time,	consider	the	full	energy	equation	option.	You	can	choose	to	leave	the	original	part	in	the	tree	or	delete	it.	Divide	the	mass	flow	rate	(g/s)	by	the	volume	flow	rate	(cm3/s)	at	the	last	time	step
to	find	the	spatially-averaged	mixture	density	ρMIX	at	the	flux	surface.	Plot	the	unit	head	losses	against	their	matching	average	velocities.	Table	B-1.	This	is	a	different	threshold	than	form	drag,	the	effects	of	which	begin	to	occur	around	Rep	=	1.	Page	8	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary
Conditions	g.	FSI/TSE:	Only	used	for	visualizing	deforming	solids	output	from	the	finite-element	stress-analysis	physics	package.	Page	2	of	11	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	Figure	3.	The	same	idea	applies	in	Y,	but	here	the	important	distances	are	between	the	walls	(6	m)	and
across	the	weir	opening	(3.048	m).	It’s	important	to	understand	that	the	way	the	solver	will	“see”	the	embedded	geometry	most	accurately	viewed	in	2-D	plots	(which	you’ll	do	later).		Viscosity	of	Two-Phase	Mixture:	the	viscosity	used	in	the	Navier-Stokes	cell-to-cell	momentum	equations,	regardless	of	phase	concentrations.	Repeat	the	process	with	15
m	resolution.	Select	Filters	>	Quality	Measure	and	Computations	>	Per	Vertex	Quality	Function.		Can	a	portion	or	all	of	the	flow	be	treated	as	depth-averaged?	They	may	be	nested	or	linked.	Delete	the	value	in	Total	Cells	(not	required,	but	makes	things	more	clear)	b.	In	this	simulation,	the	units	of	volume	are	cm3	and	surface	area	is	in	cm2.	This	step
produces	more	accurate	and	attractive	.stl	files.	Comparing	the	files:	CLEANING	METHOD	NUMBER	OF	POINTS	DIFFERENCE	IN	COORDINATE	(OUTPUT	IS	.XYZ	FORMAT)	(15,010,488	IN	ORIGINAL)	VALUES	FROM	ORIGINALS	CloudCompare	.txt	import	15,010,488	+/-	3E-6	feet	(<	1	micrometer,	μm)	MeshLab	.asc	import	15,010,488	+/-	2E-6
feet	(<	1	micrometer,	μm)	15,010,489	(excluding	the	extra	point)	MeshLab	.xyz	import	(adds	point	at	0,0,0)	Table	1.	Removing	some	cells	is	advised.	Save	the	highlighted	cloud	as	MiddleRioGrande_CCtxt.xyz.	Set	Position	=	As	Last	Subcomponent	for	both	copies.	Slide	the	X	Limits	sliders	so	that	I	=	78	to	86.	Select	Project	>	Add	Part	and	load	the
ASCII	TOPO2STL	output	file	MiddleRioGrande_MLASCtxt_clean_fill_PDSub0833_T2STL0833.stl.	.stl	binary	format	bytes	data	type	data	content	80-byte	ASCII	4-byte	unsigned	long	integer	4-byte	floating	point	4-byte	floating	point	4-byte	floating	point	4-byte	floating	point	<	v1X	>	4-byte	floating	point	<	v1Y	>	4-byte	floating	point	<	v1Z	>	4-byte
floating	point	<	v2X	>	4-byte	floating	point	<	v2Y	>	4-byte	floating	point	<	v2Z	>	4-byte	floating	point	<	v3X	>	4-byte	floating	point	<	v3Y	>	4-byte	floating	point	<	v3Z	>	2-byte	unsigned	integer	………..	Some	commonly	checked	items	are	given	for	demonstration	here:	o	In	section	/OBS/,	do	specified	component	surface	area	and	calculated
component	surface	area	agree	reasonably	well?		If	gravity	physics	are	active,	consider	the	hydrostatic	pressure	distribution	option,	which	will	also	apply	to	boundary	conditions.	Make	many	streamlines:	a.	Test	as	many	of	the	following	as	you	can.	Notice	how	Activate	Bulking	is	now	active.	Export	the	part	and	check	it	with	netfabb	Basic	(no	errors
detected)	and	qAdmesh	(about	5,400	bad	normals	detected).	Use	the	Next	and	Previous	buttons,	and/or	double-click	on	the	Available	Time	Frames	listed,	to	see	the	results	at	different	times.	2-D	plots	are	more	accurate	than	the	3-D	rendering	because	they	do	not	include	the	approximately	fitted	iso-surfaces	drawn	by	FAVORize	and	3-D	rendering.	The
first	option	will	copy	the	data	into	the	prepin	file	so	the	.csv	file	is	no	longer	needed,	but	limits	the	number	of	points	per	table	to	500.	Hydrostatic	pressure	is	specified	as	an	initial	condition,	but	it	also	applies	at	all	vertical	pressure	boundaries	for	the	entire	run.	They	occur	between	velocity	changes	at	the	boundary,	implying	that	the	duration	of	the
steps	is	sufficient	to	get	steady	flow	between	velocity	changes.		Continue	the	process	in	all	directions	until	all	mesh	planes	and	important	flat	surfaces	are	separated	by	even	multiples	of	the	largest	cell	size.	Surface	tension	a.	Specify	X	High	=	0	m	to	fill	the	upstream	channel	to	the	weir.	Delete	vertices	that	overlap	the	topography	Duplicate	the	plane
layer.	Check	the	component	placement	against	the	image	below,	and	Save	your	work.	Understanding	Plot	Types	and	Data	Sources	The	Analyze	tab	will	now	be	displayed.	Select	the	Mass-Averaged	Mean	Kinetic	Energy	runtime	plot	and	note	how	the	kinetic	energy	relates	to	the	magnitude	of	the	velocity	profile.	Select	Blanking	Variable	=	None.	To
associate	a	subcomponent	with	a	different	component,	right-click	the	subcomponent	name	and	select	Reassign.	Run	#3:	Add	Drift-Flux	Physics	(Two-Phase	Flow)	The	results	of	the	model	with	Density	Evaluation	physics	look	more	physical	than	with	scalar-only	entrainment.	If	the	faces	are	reversed	they	will	appear	gray,	as	in	Figure	7.	Select	a
Porosity	Model	Porous	media	flow	exhibits	viscous	and	inertial	drag	and	may	be	enhanced	or	retarded	by	capillary	effects.	Pre-decimate	(subsample)	the	point	data.	By	now	you	should	be	familiar	with	the	basic	set	up	methods	in	FLOW-3D.	For	this	exercise,	just	remove	a	few	artifacts.	Set	the	Time	Frame	sliders	to	include	all	output	times.	In	the	next
few	steps	you	will	activate	the	RNG	turbulence	model	and	specify	dynamically-computed	maximum	turbulent	mixing	lengths.	½-inch	1E5	target	facets/	(0.0416	feet)	Fixed:	4	vertices,	3	holes,	11054	normals/	1	shell	output/	242	MB	binary	.stl	1-inch	Fixed:	9587	facets,	Fixed:	2	holes,	5480	1E5	target	facets/	(0.0833	feet)	2759748	normals/	borders,	2
shells/	Fixed:	4	vertices,	14	holes,	2	shells/	1	shell	output/	5446	normals/	132	MB	binary	.stl	132	MB	binary	.stl	1	shell	output/	64	MB	binary	.stl	2-inch	Fixed:	4824	facets,	Fixed:	2	holes,	2760	1E5	target	facets/	(0.1666	feet)	707198	normals/	borders,	2	shells/	Fixed:	4	vertices,	11	holes,	2	shells/	1	shell	output/	2722	normals/	34	MB	binary	.stl	34	MB
binary	.stl	1	shell	output/	20	MB	binary	.stl	Table	5.	Only	one	definition	should	be	specified	per	baffle.	Click	on	Mesh	Planes	in	the	tree	to	highlight	them.		Create	a	copy	or	a	restart	copy	of	the	simulation.	You	will	activate	directions	and	fill	in	values	as	shown	below.	Zoom	in	and	pan	if	necessary	to	get	more	precise	readings	(rotating	is	not
recommended).	TOPO2STL	output	(30-m	spacing),	viewed	in	MeshLab	Page	10	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	STEP	7	–	SIMPLIFY/RECOMBINE	FACETS	Import	the	ASCII	.stl	output	into	MeshLab.	Create	a	space-delimited	ASCII	text	file	with	one	coordinate	per	line	and	no	headers.	If	the
mesh	is	too	fine	the	runtime	may	be	unnecessarily	long.	Values	entered	here	will	change	the	value	of	Fluid	1	Viscosity	on	the	Fluids	tab.	Check	that	your	model	appears	as	shown,	with	flow	vector	pointing	outward,	and	Save.	Uniform	Pressure	=	0	Barye	(g/cm/s2)	c.	j.	Though	it	will	have	negligible	effects	on	modeling	results,	the	Page	5	of	26	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	cleaned	file	with	the	least	introduced	error	should	be	used.	Set	Free	Surface	Elevation	=	5	cm.	Solidification	data	is	not	discussed	here.		Density	of	Phase	#2	is	the	density	of	the	dispersed	phase,	pure	air.	Save	the	final	combined	layer	with	no	normals.	Click	the	Select
Region	button	and	drag	the	corner	pins	to	enclose	the	area	of	interest.	The	three	repair	methods	introduced	above	are	compared	in	Tables	4	and	5	below.	The	efficiency	and	accuracy	of	the	solution	are	indicated	by	the	runtime	plots	and	solver	text	messages.	The	floor	will	be	defined	according	to	the	sketch	drawn	below	and	using	the	dimensions
determined	from	the	Min/Max	Y	coordinates	and	the	Min	X	coordinate	of	the	weir	subcomponent	found	in	the	tree.	Select	Keep	Unreferenced	Vertices	or	all	original	points	will	be	deleted!	Don’t	delete	the	existing	layers	yet.	Set	up	and	run	a	coarse	test	case		Follow	the	simulation	setup	guide	using	the	coarsest	possible	mesh	This	setup	mesh	is
purposely	kept	as	coarse	as	possible	to	make	it	run	as	fast	as	possible.	You	will	use	.stl	files	in	this	exercise	for	a	weir	plate	and	some	simple	downstream	topography.	There	is	only	one	component,	so	ignore	the	checkboxes	in	the	middle	of	the	dialog.	dynamic	TLEN.	Typical	simple	errors	are	missing	facets	(holes),	zero-area	facets,	non-manifold
vertices,	and	reversed	or	incorrect	unit	normals.	Page	4	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	Set	Uniform	Cell	Dimensions	The	domain	now	contains	the	region	we	are	interested	in.	The	most	common	artifacts	are	people	and	equipment	that	are	picked	up	by	the	recorder	and	outlying
points	that	are	added	inadvertently	(usually	when	filtering	the	data	with	software).	Click	Fill,	wait,	and	then	click	Accept.	Use	qAdmesh	for	repair	&	format	conversion.	When	prompted	if	the	output	should	be	GeoTiff	format,	select	No.	A	MicroDEM-format	DEM	file	(.dem)	will	be	created	in	the	data	subdirectory	of	the	ArcGrid	folder.	Converting	the
remaining	terms	from	energy	to	hydraulic	head	(in	units	of	feet)	gives:	where	P	and	z	are	pressure	and	elevation	at	point	1	or	2,	ρ	is	the	fluid	density,	g	is	gravitational	acceleration,	and	hf	is	head	loss	due	to	friction.	The	default	mode	of	operation	for	qAdmesh	is	to	check	a	file	and	report	any	errors	found,	without	fixing	the	errors.	This	is	output	from
the	History	Probe	you	placed	upstream.	Select	File	>	Data	Manipulation	>	Resample	>	DEM	formats	>	ADF	Directories.		If	heat	transfer	can’t	be	ignored,	consider	heat	transfer	physics,	and	make	fluid-to-solid	heat	transfer	selections	below:	o	Can	all	solid	components	be	treated	as	having	a	constant,	uniform	temperature?	Expand	the	Min/Max	tree
under	Subcomponent	3	and	verify	that	the	values	match	what	the	input	above.	Figure	10:	Pressure	drop	(Pa)	across	porous	media	at	t	=	3598	sec	Page	17	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Analyze	Results	using	Probe	1.	2)	Visualize	and	check	the	data.	You	can	usually	tell	the	difference
because	computed	values	fluctuate,	while	specified	values	are	constant.	This	corresponds	to	the	idea	that	the	free-surface	elevation	specified	is	the	total	head	(static	+	velocity).	This	software	is	a	user-interface	for	the	free	command-line	program	Admesh.	Convert	the	point	cloud	to	.stl	with	TOPO2STL	Figure	14.		A	simple	rule	of	thumb:	the	model	is
“mesh-converged”	when	refining	the	mesh	causes	the	output	to	change	less	than	3%	(for	output	with	magnitude	greater	than	1000)	and	less	than	1%	(for	output	magnitude	less	than	1000).	Mouse	Modes	&	Viewing	Options	in	Display	Panes	4.	Note	that	there	are	two	sub-folders,	one	for	each	simulation	you’ve	run	so	far.	Open	the	X,	Y,	and	Z	Limits
sliders	all	the	way.	Open	Porosity	Properties	and	set	Porosity	=	1.	This	is	because	the	.xyz	format	cannot	contain	headers	and	there	is	no	option	to	skip	initial	lines.	Set	the	Simulation	Units	=	CGS.	Res.	Navigate	to	the	Model	Setup	>	Physics	tab,	select	Fluid	Sources,	and	check	the	box	to	activate	the	physics.	Try	to	avoid	placing	axes	that	are	mostly
diagonal	to	the	flow.	The	surface	elements	are	triangles	(called	facets)	composed	of	three	points	and	a	normal	vector	pointing	away	from	the	surface.	Return	to	the	Analyze	>	3-D	tab	and	select	the	Open	Symmetry	Boundaries	checkbox.	Describe	the	mesh	dependency	study,	including	sizes	used	and	convergence	results.	The	experimental	velocity
given	in	the	paper	is	superficial	velocity	Umacro	(range	0.001	–	0.020	m/s).		Minimize	the	number	of	cells	where	there	will	be	no	flow.	Rotate	and	move	the	cylinder.	Rename	the	prepin	file:	a.	We	can	guess	that	the	impingement	point	is	the	most	turbulent	region	in	the	domain	and	also	controls	significant	flow	features.	These	three	measuring
techniques	are	the	built-in	methods	of	tracking	entrained	air.	The	component/subcomponent	list	at	the	bottom	of	the	dialog	lets	you	overlay	the	geometry	that	was	imported	with	iso-surfaces	that	are	fit	to	the	embedded	geometry.	Hold	Control	+	left-click	to	select	both	Cloud	and	Mesh	entities	in	the	DB	Tree.	Now	you	can	begin	running	the	case	on
more	accurate	meshes.	This	is	true	for	clear	water	at	20°C	and	standard	pressure	(101,325	Pa).	Are	error	brackets	known?	Therefore	the	large	cell	size	should	be	½	of	the	weir:	0.16764	in	X,	and	the	small	cell	size	should	be	½	of	that:	0.08382	in	X.	Select	the	file	from	the	list	and	click	convert.	The	default	Simulation	Units	are	Custom,	which	means
they	are	unspecified	(units	can	be	anything,	as	long	as	the	system	is	consistent	for	all	parameters).	Give	the	new	Component	1	Name	=	weir	and	select	OK	to	finish	adding	it	as	a	Solid	component.	2.5%	is	on	the	high	side.	o	Outflow	boundaries	do	not	communicate	any	information	into	the	domain,	unless	they	unintentionally	reflect	angular	momentum.
Repeat	the	process	for	Block	2:	set	the	X	Max,	Y	Min,	and	Y	Max	boundaries	to:	b.	The	total	length	of	the	mesh	domain	is	about	12	m,	so	the	packet-transit	time	is	approximately	12/7.3	≈	1.6	seconds.	It	should	appear	well-resolved,	especially	around	gaps	and	thin	sections.	Time	Step	Size:	Repeats	part	of	the	information	from	the	last	plot.	Review
Solver	Output	text	and	files	to	check	for	convective	flux	errors.	Lower	the	sea	floor	to	-2	m	in	MeshLab	On	the	original	plane	layer,	Select	and	Delete	only	the	ocean	region,	and	set	the	elevations	of	all	remaining	points	in	that	layer	to	Z	=	571	m	(above	the	flow	region).	The	external	angle	must	be	at	least	45°	as	shown	in	the	schematic	below.	The
seeding	points	are	erased,	but	the	lines	remain.	2,	665-677.	Locate	and	delete	non-manifold	vertices	with	MeshLab	Page	13	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data	Figure	21.	This	means	that	the	pressure	at	the	free	surface	is	local	“gauge”	atmospheric	pressure.		Density	of	Phase	#1	is	the	density	of
the	continuous	phase,	pure	water.	Free-surface	elevation	cannot	be	specified	at	Outflow	boundaries,	which	are	appropriate	where	Fr	>	1.	An	example	is	component	surface	roughness:	when	the	physical	roughness	is	used	the	results	become	realistic	as	the	mesh	is	refined,	but	usually	require	resolutions	that	are	not	time-feasible.	The	Volumetric	Flow
Rate	gives	2	m/s	velocity:	QV	=	U	x	A.	Record	the	results	and	compare	them	to	the	experiment.	View	the	Mesh	and	Find	The	Multi-Block	Volume	Error	Now	you	will	practice	what	you	know.	Name	=	Ink	b.	The	second	option	is	always	a	better	choice	when	case-specific	data	exists.	Select	Microsoft	Video	1	since	the	codec	is	universally	available	on
Windows	platforms.		Validation	uncertainty	Validation	uncertainty	is	the	estimated	standard	deviation	of	the	parent	population	of	the	combination	of	errors	(ASME	2009),	that	is,	a	function	of	numerical,	input,	and	experimental	data	uncertainty.	In	two-fluid	models,	F	=	0	represents	Fluid	2,	and	momentum	is	solved	in	all	open	and	partially-open	cells.
Mesh:	defined	in	the	Mesh	Window	.	Hide	the	point	cloud	layer,	select	the	plane	layer,	and	delete	the	vertices	that	have	been	selected	with	the	Delete	Current	Set	of	Selected	Vertices	Figure	7	below).		Input	uncertainty	Input	parameters	represent	physical	reality,	which	is	to	some	extent	unknowable.	Select	the	number	of	dimensions	of	the	model:		1-
D	o	Pros:	fastest	run-time,	easiest	analysis.	Add	the	box	to	Component	2:	channel.	Run	the	simulation.	The	flsgrf	file	is	the	simulation	output	file	and	contains	the	same	information	as	the	prpgrf	file,	plus	the	output	of	the	run.	Macroscopic	and	microscopic	velocities	are	theoretically	related	by	the	media	effective	porosity:	where	ηeff	is	the	average
effective	porosity.	Reload	the	data	as	points	only.		Draw	a	Cartesian	or	Cylindrical	coordinate	system	on	the	diagram		Decide	whether	to	use	Cartesian	or	Cylindrical	coordinates	based	on	the	flow	geometry.	Activate	Drift-flux	on	the	Physics	tab	and	apply	water	air	bubble	values	per	Figure	8,	below.	LOSS	(∆P/∆x)	(Pa/m)	0	472	872	1,853	2,108	2,617
3,089	3,816	4,725	5,524	6,178	7,050	7,923	8,831	9,704	9,704	11,666	12,865	14,646	15,555	15,736	Table	2:	Experimental	Head	Loss	Converted	to	Pressure	Loss	The	pore	velocity	UP	and	the	experimental	pressure	loss	(∆P/∆x)	is	now	known	and	the	permeability	coefficients	can	be	found.		If	possible,	sketch	a	single	block.	Create	a	solid	torus
subcomponent	with	the	following	dimensions:	1.	Make	sure	the	Subcomponent	Type	is	Hole.	Use	the	annotated	diagram	as	a	guide.	Gravity	is	usually	in	the	negative	z	direction,	because	some	boundary	conditions	and	hydraulic	data	output	require	it.	NO.		Post-process	the	results	and	check	that	they	appear	reasonable	Report	results		Describe	the



physical	situation	and	why	CFD	modeling	is	needed		Describe	the	test	case	&	report	results					Describe	the	physical	situation	and	experimental	data.	These	outlying	regions	should	be	filled	in	with	a	uniform	surface	elevation,	usually	one	that	is	higher	than	the	any	of	the	known	data.	This	will	make	the	mesh	irregular	(stretched).	Use	to	reset	the	view.
Note	that	the	region	will	Add	Fluid,	and	that	the	Fluid	Fraction	=	1	(100%	Fluid	1	=	water).	The	pressure	field	also	needs	time	to	come	to	a	steady-state	solution,	so	the	front	time	should	be	multiplied	by	a	safety	factor.	Start	the	Edit	>	Fill	Holes	tool	.	The	Output	location	box	is	now	activated.	In	free-surface	flows,	Pressure	boundaries	are	appropriate
where	the	Froude	number	Fr	<	1.	It	includes	visualization,	manual	and	automatic	analysis	and	repair,	and	other	options.	Zoom	in	and	out	with	the	mouse	roller	and	pan	with	the	right	mouse	button.	The	real	maximum	error	is	much	smaller	than	was	reported	by	the	Approximate	Results.	Page	14	of	26	Water	&	Environment	Training	on	FLOW-3D	v11
Exercise	9:	Converting	Topography	to	.stl	Choose	Part	>	Export	Part	>	As	STL	to	save	the	repaired	geometry	in	binary	format.	Select	Extras	>	New	Analysis	>	Standard	Analysis.	This	is	the	front	time	of	the	velocity	profile.	The	checkboxes	associated	with	individual	Components	allow	all	or	some	components	to	be	FAVORized.	The	new	file	will	be
about	197	million	points	(6.3	GB)	that	will	be	saved	with	the	original	coordinates.	This	clears	the	Blanking	Variable	Value	entry.	Click	OK	to	continue.	However,	the	total	thickness	of	the	plate	is	about	1.1	feet,	which	is	much	wider	than	recommended	for	sharp-crested	weirs.	Now	you’ll	work	on	making	the	cell	sizes	accurate.	Page	6	of	11	Water	&
Environment	Training	on	FLOW-3D	v11	Exercise	10:	Making	STL	Topography	from	Google	Earth	10.	Loading	a	Results	File	1.	Note	that	netfabb	does	not	report	incorrect	normal	vectors	like	qAdmesh,	but	it	does	correct	them	automatically.	Values	of	0.75	to	1.5	are	typical	for	sand	and	gravel.	Repair	the	.stl	until	it’s	watertight.	In	this	case	the
Netfabb	Basic	output	is	slightly	preferable	to	that	of	qAdmesh.	Set	the	Number	of	Processors	It’s	good	practice	to	leave	at	least	one	processor	available	for	the	OS	and	other	programs	to	use.		Draw	the	boundary	conditions	on	the	diagram	Write	which	boundary	condition	type	best	represents	the	physical	situation	at	each	boundary.	Re-check	and
repair	the	.stl	file	using	qADMesh:	a.	Select	File	>	Add	Example…	from	the	top	menu	or	right-click	the	workspace	name	and	select	Add	Example…	The	dialog	shown	below	will	appear.	On	the	diagram	or	an	attached	sheet,	list	all	empirical	values	and	coefficients	used.	Page	1	of	7	FLOW-3D	Version	11	CFD	Project	Overview					Are	the	test	case	results
from	a	reliable	source?	There	are	three	choices	left:	the	D’Arcian	Saturated	Drag	model,	Permeability	Dependent	Saturated	Drag,	or	the	Forcheimer	Saturated	Drag	model.	Values	for	air	bubbles	can	be	found	in	the	literature,	and	a	description	of	the	drift-flux	model	equations	that	can	be	used	to	fit	parameters	to	experimental	data	can	be	found	in	the
User	Manual	and	in	Technical	Note	83	at	users.flow3d.com.	The	surfaces	are	drawn	using	a	3-D	iso-surface	method	that	does	not	locate	them	as	accurately	as	in	2-D	plots.	Final	steps	before	running	the	model	will	include	adding	some	sampling	locations	and	specifying	output.	Select	the	Analyze	>	2-D	tab.	Usually	much	less	than	1%,	and	should
always	be	less	than	3%.	The	time	step	dt	may	be	less	than	the	stability	limit	when	an	implicit	solver	(like	pressure)	does	not	converge	to	the	error	tolerance:	then	it	will	restart	the	calculation	with	a	smaller	dt.	Update	the	program	(.exe)	and	help	file	(.chm)	builds	from	File	>	Tools,	or	download	them	from	the	MicroDEM	website.	For	this	case,	the
region	of	interest	results	in	two	compressed	files,	each	a	1	degree-square	(35	N	and	119W	through	120W),	in	1/3	arc-second	ArcGrid	format.	Review	the	information.	Select	Apply	and	Close.	Flatten	all	three	layers	in	MeshLab	to	combine	them.	Close	the	Probe	Points	list	and	toggle	the	button	to	turn	off	the	pivot	point	option.	Select	the	Mesh
checkbox	to	plot	the	grid	lines.	Set	File	Type	=	ASCII	and	select	MiddleRioGrande.txt.	√	where:	Fr	=	Froude	number,	given	as	3.0,	U	=	average	velocity	of	the	fluid,	g	=	gravity,	980	cm/s2,	h	=	mean	depth	of	the	flow,	given	as	5	cm.	Select	OK	to	accept	the	new	criteria.	Viscous	stress	solver	=	Successive	under-relaxation	4.	Unmatched	grid	lines	at
mesh	block	interfaces	are	sources	of	convective	volume	error	and	artificial	momentum	diffusion,	so	the	cell	Page	5	of	21	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	3:	Meshing	&	Boundary	Conditions	size	of	the	containing	block	should	be	an	even	multiple	of	the	smaller	mesh	block	cell	size	to	match	the	grid	lines.	2-D	plots	use	cell-by-
cell	area	and	volume	fractions	to	give	the	precise	surface	locations	computed	by	the	solver.	The	stagnation	option	means	that	the	water	velocity	outside	the	mesh	(in	the	ghost	cells)	is	set	to	zero.	Select	File	>	Save	DEM	>	ASCII	>	ASCII	XYZ	(.xyz)	and	the	following	options	for	each	of	the	DEM	files.	The	workflows	given	in	this	note	are	only	one	way
of	approaching	the	solution.	Select	File	>	Add	New	Simulation…	from	the	dropdown	menu	at	the	top	of	the	screen.	FLOW-3D	v9.4	User	Manual.	Flow	Science	Inc.:	Santa	Fe,	NM.	However,	looking	at	the	results	indicates	the	opposite:	even	at	very	low	flows,	there	is	still	a	head	loss	across	the	media.	Models	are	easier	to	visualize	during	setup	using
.stl	geometry	files,	which	will	be	covered	in	a	later	exercise.	The	first	and	last	Mesh	Plane	coordinates	for	each	direction	are	the	block	edges.	d.	The	binary	file	size	will	always	be	about	81.5%	smaller	than	the	ASCII	file	size.	The	coordinate	units	must	all	be	the	same	(e.g.,	feet	or	meters).		If	no	uncertainties	were	estimated,	justify	the	omission.	Create
the	plane.		Repeat	mesh	planes	in	all	adjacent	blocks	to	tie	the	grids	together	precisely.	2-D	plots	or	3-D	Mesh	Slices	can	be	used	to	visualize	internal	(submerged)	flow	properties.	Color	variable:	The	selection	here	will	determine	what	variable	to	color	the	fluid	surface	with.	The	colors	are	to	make	identifying	parts	of	the	simulation	easier	when
editing:	they	do	not	affect	the	solution.	There	is	a	rounding	at	the	weir	corner	that	could	be	examined	in	2-D	plots	to	see	if	it’s	an	artifact	of	the	iso-surface	approximation	or	actually	poor	geometry	resolution.	elapsed	real-world	time	and	computer	clock	time	el_time	and	clk_time	(hh:mm:ss),	12.	An	historic	overview	of	empirical	correlations	with
examples	are	given	in	the	source	paper	(Abood	2009).	11	This	setup	guide	is	not	an	exhaustive	decision-tree	for	all	elements	of	a	simulation.	Find	FPSCL1	(the	volumetric	air	concentration	at	the	plane)	=	96.1	“amount”/s.	Select	General	Settings	Begin	on	the	Model	Setup	>	General	tab.	In	general,	the	D’Arcian	model	applies	when	pore	size	is	small
and	flow	is	relatively	slow:	ReP	<	1.	If	any	answers	are	no,	consider	adjusting	the	simulation	setup	with	the	following	checklist:		Troubleshoot	the	coarse	case	if	necessary							Does	the	mesh	follow	best-possible-practices?	Select	contour	plotting	options:	a.	&	D.	If	you	have	trouble	finding	the	file,	ask	your	instructor	for	help.	Grayed-out	selections
require	physics	that	have	not	been	activated.	Several	tests	were	performed	to	ensure	the	packed	bulk	density	of	the	media	was	repeatable.	Name	the	new	Component	1:	Nozzle.	Select	Simulate	>	Preprocess	Simulation	>	Local	from	the	top	menu	bar.	Select	Mass-Averaged	Fluid	Mean	Kinetic	Energy	from	the	list	and	Render.	A	careful	check	of	the
limits	of	applicability	of	their	equation	(found	in	Bos	1989)	show	that	the	model	is	within	the	region	of	applicability	for	approach	head	depth,	crest	height	above	the	channel,	channel	size,	and	drop	length	of	the	nappe.	Turn	off	Contour	Smoothing.	Enter	the	values	shown	below,	including	Add	to	Component.	The	dirt	gets	trapped	in	the	ink	droplet	and
drag	makes	the	droplet	move	more	slowly	and	elongate	the	droplet.	Open	MeshLab	and	select	File	>	Import	Mesh.	Activate	viscous	flow	b.	You	can	draw	a	box	to	zoom	in	on	the	plots	by	holding	the	left	mouse	button	and	dragging	a	zoom	window.	Click	OK	to	exit	the	dialog.	For	this	case,	the	inter-block	area	warnings	can	be	ignored.	Real-world	time
to	steady	state	is	then	about	16	to	32	seconds.	Page	7	of	10	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	2.	Note	that	the	baffle	is	displayed	as	a	gray	solid	plane,	even	though	it’s	completely	porous.		Specify	each	mass-momentum	source’s	shape.	Check	for	instances	where	the	viscous	solver	did	not	converge.
Review	the	Physical	Experiment	The	physical	experiment	is	described	in	An	Experimental	Model	for	Flow	Through	Porous	Media	Using	Water	Filter,	by	D.	Dirt	Particle	i.	Enter	the	values	shown	below	to	rotate	and	translate	the	pipe.	The	following	empirical	upstream	boundary	turbulence	values	apply:					Tu	≈	0.0156	(1.56%)	kT	≈	16	cm2/s2	LT	≈	0.35
cm	(potential	range	0.25	–	0.65	cm)	εT	≈	30	cm2/s3.	Note	that	the	Data	Point	(location)	sliders	gray	out	because	the	values	for	this	source	are	global.	Points	colored	by	elevation	from	blue	(low)	to	red	(high)	c.	The	default	value	of	CD	is	0.5,	which	is	correct	for	dense	spheres.	14.	Other	plots	are	available	depending	on	the	physics	models	used:	these
include	thermal	energy,	number	of	particles,	and	other	output.	Click	OK	to	get	out	of	the	Boundary	Dialog	and	Save	your	work.	Search	again	for	areas	at	inter-block.	They	represent	tailwater,	and	require	an	estimate	of	the	downstream	free	surface	elevation.	The	preprocessor	generates	a	results	file	named	prpgrf.”project	name”.	Set	Position	=	As
Last	Subcomponent.	Return	to	the	Analyze	>	Probe	tab	and	select	Output	Form	=	Text	(in	the	lower	left).	Check	that	the	W	column	is	populated,	and	that	the	chart	appears	as	shown	below.	The	tab	at	top	will	change	to	the	Display	tab,	and	will	show	the	same	image	as	you	saw	in	the	FAVORize	display.	The	magnitude	of	oscillation	is	much	smaller
with	density	physics	than	with	scalars	only.	Shift+Alt+left	click	and	drag	to	remove	only	visible	faces	in	the	box	from	the	group.	The	experimental	setup	is	shown	in	Figure	1,	below.	Comparison	of	eight	text	editors	NO.	Locating	non-manifold	vertices	with	MeshLab	Apply	Filters	>	Selection	>	Select	non	Manifold	Vertices	and	then	delete	them	with
the	tool.	The	particle	size	(1	mm)	and	porosity	(0.50)	are	larger	than	in	the	soils	D’Arcy	studied,	so	it	makes	sense	that	his	model	does	not	apply	here.	7.	The	values	are	approximate.	Create	a	cylinder	subcomponent	and	assign	it	to	a	new	Component	2:	Piston.	At	the	bottom	of	the	dialog,	activate	the	Show	Issues	checkbox.	The	flsgrf	file	is	4.9	GB,	so	it
is	not	offered	for	download	or	copy.	Record	your	selections	on	the	diagram	as	you	proceed.	On	the	other	hand,	the	approach	channel	will	be	characterized	by	relatively	straight,	steady	flow,	and	can	tolerate	a	coarse	mesh	without	too	much	loss	of	detail.	Activate	the	following	check-boxes	(units	are	given	following	the	variable):						fluid	probe	#1:
volume	fraction	of	entrained	air:	cm3	air/cm3	air-water	mix	fluid	1	volume	flow	rate	@	flux	surface	1:	cm3/s	air-water	mix	x	+/-	unit	vector	entrained	air	flux	@	flux	surface	1:	cm3/s	air,	may	be	negative	x	+/-	unit	vector	sampling	volume	1:	entrained	air	volume:	cm3	air	at	time	t	entrained	air	volume:	cm3	air	at	time	t	in	the	entire	domain	including
ghost	cells	Note	that	the	outputs	above	count	only	entrained	air	scalar	and	do	not	include	resolved	void	bubbles.	The	fluid	surface	should	now	appear	open	(transparent	with	sharp	edges)	at	the	ymin	symmetry	boundary,	which	is	at	y	=	0	cm.	The	available	plot	types	are:	Page	15	of	24	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	1:
Running	&	Post-Processing	an	Example	Simulation	Custom:	a	rarely-used	way	to	get	“under	the	hood”	of	the	post-processor.	Activate	the	Range	checkbox	and	set	the	number	of	points	to	10.	A	new	Part	Analysis	branch	is	added	to	the	tree:	selecting	the	Standard	Analysis	sub-branch	displays	data	about	the	part:	it	has	two	shells,	two	holes,	an
unclosed	surface,	and	about	5,400	unjoined	edges	(called	boundary	edges	in	netfabb):	very	nearly	the	same	as	the	number	of	facets	with	Page	13	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	unclosed	edges	reported	by	qAdmesh.	Figure	10.	Systemic	errors	require	correcting	and	re-exporting	the	file
from	CAD.	Page	1	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	Determine	Component	Gravity	Parameters	We	want	to	model	the	downstream	portion	of	the	pipe	in	such	a	way	that	the	x-axis	is	parallel	to	the	pipe	walls,	and	the	z-axis	is	normal	to	the	flow	direction,	as	illustrated	in	Figure	2.	The	file	loads	and	the
GUI	switches	to	the	Analyze	>	3-D	tab	with	all	options	reset.	Notice	the	recirculation	zone	to	the	right	above	the	pipe	discharge	jet.		If	a	fluid	contains	other	phases	(e.g.,	contaminants,	particles,	or	tiny	bubbles):	o	consider	scalar	physics	if	the	contaminant(s)	can	be	treated	as	continuous	concentrations,	Page	2	of	11	FLOW-3D	Version	11	Simulation
Setup	o	if	a	contaminant	is	added	at	free	surfaces	consider	air	entrainment	physics	or	defect	tracking	physics,	o	if	contaminants	should	be	treated	as	a	finite	number	of	particles	(with	or	without	drag)	and	not	as	continuous	concentrations,	consider	particle	physics,	o	if	they	should	be	treated	as	continuous	concentrations	that	represent	many	discrete
particles	(with	drag	effects),	consider	drift-flux	physics,	o	if	they	should	be	treated	as	packable	(dense)	concentrations	that	can	take	solid	forms,	consider	granular	flow	physics,	sediment	scour	physics,	or	dissolving	object	physics.		Start	with	the	coarsest-possible	mesh		Follow	the	simulation	setup	guide	(on	this	site)	and	prove	the	case	runs		Use	the
numerical	options	and	input	parameters	from	test	case		Refine	the	mesh	to	minimize	error		If	the	test	case	and	case	of	interest	are	of	similar	scales	and	dimensionless	numbers,	use	the	design	mesh	from	the	test	case	immediately.	Rather,	it	is	meant	to	be	a	checklist	with	a	middling	level	of	detail.	Set	Density	=	1000.	1952.	The	title	of	the	menu	should
be	Subcomponent	3.	To	reduce	the	simulation	time,	only	the	downstream	portion	of	the	pipe	will	be	modeled,	using	2-D	CFD,	and	this	domain	is	illustrated	in	Figure	1.	Freeware	tools	introduced	in	this	exercise	include	VIM,	MeshLab,	CloudCompare,	Admesh,	and	netfabb	Basic.		Specify	baffle	porosity	(0	=	solid	to	1	=	transparent	to	flow).	Fill	in
surface	elevations	for	absent	data.	Calculating	as	before,	we	find	at	t	=	5	seconds:	1.	The	area	of	interest	(the	valleys	where	the	St.	Francis	flood	occurred)	has	a	very	low	error,	as	shown	in	Figure	23.		Check	that	fluid	initial	conditions,	boundary	conditions,	and	component	initial	conditions	match.	This	minimizes	interpolation	error.		For	example,	the
two-equation	turbulence	models	use	a	purely	numerical	maximum	turbulent	mixing	length	parameter	(TLEN).		Follow	the	annotated	diagram	and	specify	all	available	initial	conditions.	W.	STEP	6	–	CONVERT	THE	POINT	CLOUD	TO	.STL	WITH	TOPO2STL	Launch	TOPO2STL	from	FLOW-3D	>	Utilities	menu	>	Topo2STL.	Reset	the	displayed	sliders	to
the	minimum	and	maximum	permissible	(check	that	they	match	the	color	saturation	slider	values).	Now	re-do	the	holes	to	drill	the	rest	of	the	way	into	the	bed	(Component	2).	Figure	15.	Search	and/or	Navigate	to	find	your	location	of	interest.	Page	5	of	10	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	Page	6	of
10	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	7:	General	Moving	Objects	Define	Mesh,	Boundary,	and	Initial	Conditions	Now	add	a	2-D	cylindrical	mesh	around	the	geometry.	Finally	add	matching	mesh	planes	for	Mesh	Block	=	3:	a.	The	physical	model	was	built	at	the	Colorado	State	University	Engineering	Research	Center.
CONVERTS	TAB	TO	SPACE	IN	445	MB	FILE1,2	INCLUDES	COLUMN	EDIT	MODE	FREEWARE	?	ii.	To	adjust	the	X,Y,	and	Z	extents,	change	the	values	under	the	Limiters	branch.		2-D	o	Pros:	fast	run-time,	easy	analysis,	inlet/outlet/wall	effects	can	be	approximated.	Page	5	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis
Review	the	Runtime	Plots	1.	If	there	are	multiple	mesh	blocks,	preprocess	the	simulation	and	check	Diagnostics	>	Preprocessor	Summary	(prpout.xxx)	for	the	search	term	‘mismatch’	to	find	the	difference	in	resolved	open	area	on	either	side	of	mesh	block	interfaces.	If	you	made	a	mistake	defining	the	cylinder	size,	use	the	Limiters	branch	of	tree	to
fix	it.	Browse	to	the	Weir_Mesh	folder	and	open	prepin.Weir_Mesh.	g.	Select	Clear	to	remove	the	seed	points	and	Close	to	remove	the	plane.	If	prompted	to	select	a	file,	continue	with	step	7	below.	4)	Cells	in	regions	of	high	gradients	should	be	as	close	to	cubes	as	possible.	Conversion	times	and	other	data	for	four	TOPO2STL	resolutions	(tested	on
Intel	Core-i7	3930K	CPU	with	16.0	GB	of	RAM	&	Windows	7	Professional	64-bit)	7)	Fix	the	output	and	convert	it	to	binary	format.	The	graphical	results	reported	in	the	paper	show	a	head	loss	at	all	flow	rates.	There	are	two	ways	of	judging	how	well	a	computational	mesh	resolves	the	geometry.	Set	this	to	the	viscosity	of	water	also.	The	Console	(F8	to
toggle)	gives	a	Chi-squared	(χ2)	test	for	each	fit.	Color	the	points	by	elevation:	Tools	>	Projection	>	Export	Coordinate(s)	to	Scalar	Field(s)	>	Z.	We	can	use	this	to	determine	component	gravity:	z	15	cm	θ	gz	=	-	g	cos	θ	g	=	980	cm/s2	10	gx	=	+	g	sin	θ	θ	100	x	Figure	2:	Determining	component	gravity	from	pipe	slope	The	angle	of	the	pipe	θ	as
measured	from	horizontal	is	tan-1	(10/100)	=	5.71059°.	X,	coord.	This	is	time-consuming.	Click	on	the	‘S’	next	to	X	Min	to	open	the	boundary	dialog.	The	relatively	flat	shape	of	this	plot	suggests	that	fluid	volume	in	the	simulation	is	nearconstant,	and	therefore	outflow	=	inflow.	o	Cons:	velocity	and	pressure	profile	due	to	inlet/outlet	effects	and	wall
effects	not	modeled.	Leave	Stagnation	Pressure	checked.	Page	23	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	APPENDIX	A	–	STL	FORMAT	.stl	ASCII	format	solid	facet	normal	outer	loop	vertex	vertex	vertex	endloop	endfacet	………..	Re-activate	the	Default	Values	option	and	click	Apply	to	return	to
the	normal	color	scale.	Figure	11:	Agreement	between	experiment	and	CFD	Page	18	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	References		Abbood,	D.W.	2009.	2-D:	Results	can	be	viewed	in	an	X-Y,	Y-Z,	or	X-Z	plane.	Remember	that	FAVORize	is	only	an	approximation	because	it	has	to	fit	an	iso-surface
through	the	cells	and	ignores	the	area	fractions	at	the	cell	faces.	Page	3	of	26	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	EXAMPLE	DATA:	RIO	GRANDE	RIVER	SCALE	MODEL	The	example	point	cloud	file	(MiddleRioGrande.txt,	see	Figure	2	below)	can	be	downloaded	from	the	FLOW-3D	Users	Site	at
users.flow3d.com.	The	method	can	also	be	used	to	convert	GeoTIFF	formats	and	floating	point	formats	to	.stl.	This	is	a	very	important	tool	for	checking	your	mesh	quality:	a.		Special	consideration:	if	you	(a)	have	more	than	one	mesh	block,	and	(b)	plan	on	using	regularly-sized	cells	in	each	(no	mesh	stretching),	then	place	the	edge	coordinates	of	Page
3	of	11	FLOW-3D	Version	11	Simulation	Setup	each	block	so	that	the	x,	y,	and	z	distances	between	them	are	even	multiples	of	the	largest	cell	length	of	the	same	direction	in	all	blocks.	The	interface	line	between	the	upstream	and	downstream	coarse	blocks	should	be	in	the	middle	of	the	weir	at	X	=	(-0.03048	+	0.16764).	Remember	that	cells	should
ideally	be	as	close	to	cubes	as	possible.	Export	the	part,	and	check	Compute	Topological	Measures	again:	there	should	be	no	boundary	or	non-manifold	edges.	Again,	select	Tools	>	Symmetry	>	Y-Direction	to	mirror	the	results	across	the	Y=0	plane.	Reselect	the	part	by	clicking	on	it	or	selecting	it	in	the	Parts	tree	at	upper	right,	which	works	much	like
the	layers	in	MeshLab.	Select	Simulation	Manager	>	File	>	Add	Simulation	Copy…	2.	Select	the	X	direction	radio	button	for	the	Seeding	Plane.	The	uncertainty	uval	can	be	compared	to	the	disagreement	|E|	between	the	CFD	model	and	the	experiment:		Wherever	uval	is	greater	than	or	close	to	|E|,	the	disagreement	is	within	the	level	of	“noise”	of	the
experiment,	and	the	model	can	be	considered	“good”.	CONVERT	THE	SURFACE	USING	CAD2STL	1.	Run	the	simulation		Check	solver	text	output	and	solver	warnings		What	are	the	warning	messages?	Per	the	fourth	rule	of	thumb	above,	cubic	cells	should	be	used	in	the	overlapping	nested	block.	Congratulations	on	completing	your	first	FLOW-3D
simulation	from	start	to	finish!	Page	13	of	13	Exercise	6:	Intro	to	Air	Entrainment	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	Hydraulics	Exercise:	Air	Entrainment	Problem	Description	&	Objectives	Air	entrainment	downstream	of	a	hydraulic	jump	will	be	simulated	in	three	ways.	Will	the	simulation	run	out	of
available	particles	during	the	run?	When	simulating,	the	unused	parts	do	not	contribute	to	the	resource	demand.	Page	7	of	19	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Figure	3:	Empirical	correlations	are	not	recommended	The	chart	shows	neither	the	Idelchik	correlation	nor	the	Ergun	equation	is	a	good
fit.	The	3	repair	methods	described	in	Tables	4	&	5	gave	identical	statistics	(within	0.3	μm)	for	each	method	and	spacing,	so	the	results	shown	in	Table	6	are	true	for	all	repair	methods,	regardless	of	how	many	shells	the	method	produced.	Use	the	Close	Holes	filter	to	auto-close	all	holes	with	fewer	than	10	edge	facets.	A	test	case	may	still	be	valuable
even	if	it	doesn’t	meet	all	of	the	above	criteria,	but	there	will	be	relatively	less	certainty	in	how	to	parameterize	the	case	of	interest.	It	reaches	quasi-steady	state	around	20	seconds.	The	average	upstream	centerline	depth	h1+P	after	50	seconds	is	4.20	m.	Note	that	or	must	be	in	lowercase.	This	option	is	2nd-order	accurate	in	space	and	1st-order
accurate	in	time,	and	is	stable	in	cells	that	have	a	free	surface.	Some	physics	models	(e.g.,	Moving	Objects)	may	need	implicit	methods	for	stability.	Two	ways	to	clean	and	check	the	data	are	given	here.	Load	fluid	properties	from	the	materials	database,	5.	You're	Reading	a	Free	Preview	Pages	41	to	45	are	not	shown	in	this	preview.	Select	OK	to	close
the	dialog.	Select	Render.	Epsi	&	maximum	pressure	residual:	Epsi	represents	the	pressure	iteration	convergence	criteria	that	the	solver	uses	to	determine	if	the	pressure	solution	is	accurate.	of	the	largest	cell	size.	Start	with	7%	or	10%	of	the	controlling	length	scale	(often	max	fluid	depth)	and	increase	the	value	(e.g.,	to	15%,	30%,	50%,	100%)	until
the	results	cease	to	vary	significantly.	Model	the	case	of	interest	Use	everything	you	have	learned	from	the	test	case.	o	Velocity	and	Volumetric-flow-rate	boundaries	apply	a	uniform	velocity	below	a	free	surface	elevation,	and	do	not	specify	pressure.	The	goal	is	to	reduce	the	file	size	without	simplifying	the	data	in	the	region	of	interest.	Repeat	steps	3
–	5	using	the	values	on	the	bottom	side	of	the	image	below	to	add	the	FINER	WEIR	BLOCK	block	3.	9.	Page	2	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	4.	Add	two	more	planes	in	Y	by	copying	the	value	from	the	tree	(under	the	fine	block)	and	pasting	it	into	the	box:	Y	=	-2.37066666666667	and	Y	=	2.37066666666667.
View	the	FAVORized	geometry	using	the	computational	mesh.	Select	Window	>	Preferences	from	the	top	menu.	o	Fluid	cross-sections	should	be	resolved	by	at	least	3	or	4	cells.		Repeat	the	process	to	create	a	third	case	with	an	even	finer	mesh.	Page	7	of	13	Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	5:	Analysis	3.	If	you	wanted	more
frequent	numeric	GMO	output	(e.g.,	mass-center	coordinates,	forces	acting	on	the	object,	etc.),	you	could	set	History	Data	Interval	<	1E-6	seconds	(the	default	1/100th	of	the	simulation).	The	min	and	max	SF	scale	slider	values	are	the	minimum	and	maximum	error	magnitudes.	Find	the	Color	Variable	dropdown,	and	select	None.	Note	the	section
breaks	between	time	steps:	these	often	must	be	removed	outside	of	FLOW-3D	for	additional	post-processing.	Calibrate	mesh-dependent	input	parameters	CFD	models	often	include	some	variables	that	must	be	calibrated	after	the	design	mesh	is	selected.	This	file	contains	important	messages	when	inconsistencies	are	detected	by	the	preprocessor.
Important	considerations								The	trackball	is	the	point	about	which	the	coordinate	system	(and	part)	rotates	and	moves.	Select	Default	check,	and	click	Apply.	Create	2-D	geometry	and	mesh,	Use	component	gravity	to	create	an	angled	(with	respect	to	gravity)	domain,	Set	boundary	conditions	(including	turbulent	energy)	based	on	Froude	number
and	depth,	Use	the	Air	Entrainment	model,	and	Use	the	Density	Evaluation	and	Drift-flux	models.	All	algorithms	have	the	potential	to	produce	noise	or	error	in	the	results.	Name	it	Weir_Mesh.	Surface	tension:	i.	Select	Custom	to	display	flsgrf	and	prpgrf	files.	Select	the	Boundary	Condition	Display	button	(or	Mesh	>	View	Mode	>	Boundaries)	in	the
display	pane	to	show	the	boundary	types	in	the	display	and	check	your	work	against	the	image	below.	A	new	branch	of	the	tree	appears	in	the	Context	Area	at	the	right.	Remember	how	to	colorize?	Click	the	header	W	to	select	the	row	to	import	(there	is	only	one	row	in	this	file),	and	then	OK.	Volume	Error	(%	Lost):	the	total	volume	lost	due	to
numerical	mass	calculation	error	is	less	than	0.1%.	½-inch	1E5	target	facets/	(0.0416	feet)	Fixed:	4	vertices,	4	holes,	11079	normals/	1	shell	output/	243	MB	binary	.stl	1-inch	Fixed:	9509	facets,	Fixed:	2	holes,	5440	1E5	target	facets/	(0.0833	feet)	2733148	normals/	borders,	2	shells/	Fixed:	4	vertices,	8	holes,	2	shells	output/	1	shell	output/	5400
normals/	130	MB	binary	.stl	130	MB	binary	.stl	1	shell	output/	64	MB	binary	.stl	2-inch	Fixed:	4765	facets,	Fixed:	2	holes,	2726	1E5	target	box	facets/	(0.1666	feet)	692898	normals/	borders,	2	shells/	Fixed:	4	vertices,	6	holes,	2	shells	output/	1	shell	output/	2722	normals/	33	MB	binary	.stl	33	MB	binary	.stl	1	shell	output/	20	MB	binary	.stl	Table	4.
Consider	using	automatic	subdivision	(available	in	v11)	to	locally	resolve	the	mesh.	Converting	the	data	with	several	methods	and	comparing	the	results	is	recommended.	With	the	drift-flux	model,	you	define	the	properties	both	of	a	continuous	Phase	#1	(in	this	case,	water),	and	a	dispersed	Phase	#2	(air	bubbles).	Page	9	of	26	Water	&	Environment
Training	on	FLOW-3D	v11	Exercise	9:	Converting	Topography	to	.stl	Figure	8.	It	is	apparent	that	the	downstream	region	is	not	likely	to	be	filled	to	the	top	with	running	water.	It’s	also	important	to	be	able	to	turn	it	off	to	see	the	geometry.	It	would	be	difficult	to	claim	that	flow	is	at	steady	state.	Cylinder	outer	radius	=	undefined	(make	it	blank	after
you	build	the	cylinder)	3.	Plotting	3-D	Graphics	Select	the	Analyze	>	3-D	tab.	Mesh	Block	2	is	completely	enclosed	by	Block	1	on	the	X	and	Y	sides.	Modeling	Turbulent	Entrainment	of	Air	at	a	Free	Surface.	Hand	calculation	shows	that	ReD	outside	the	media	=	4,800.	All	cell	values	will	be	displayed,	whether	they	contain	fluid	or	not.	Page	7	of	13
Water	&	Environment	Training	on	FLOW-3D	v11	Exercise	6:	Air	Entrainment	Figure	6:	Check	your	scalar	results	visually	at	the	final	time-step	Use	Analyze	>	Probe	tab	>	General	History	data	to	check	the	results	for	the	History	Probe,	Flux	Surface,	Sampling	Volume,	and	Total	Domain.		Give	each	probe	and	sampling	volumes	a	descriptive	name	for
post-processing.	For	example:	o	Pressure	boundaries	set	reference	pressure	and	free	surface	elevation,	temperature,	contaminant	concentration,	etc.		Specify	target	cell	sizes	or	counts	for	each	block	and	direction.	C.		Define	all	necessary	component	properties	Follow	the	annotated	diagram	and	update	it	where	necessary.	X-min	Z-max	X-max	Z-min
Figure	1:	Schematic	of	Experimental	Apparatus	and	CFD	domain	FLOW-3D	Learning	Objectives	In	this	exercise	you	will	practice	techniques	to:	1.	b.	Based	on	the	above,	a	2-D	run	in	cylindrical	coordinates	is	suggested	to	model	axial	and	radial	flow	symmetrically	around	the	bed	tube	axis.	On	the	Model	Setup	>	Output	tab,	select	the	following
Selected	data:	Fluid	Fraction,	Fluid	Velocities,	Hydraulic	Data	(which	is	available	now	because	you	selected	it	as	Additional	Output),	and	Pressure.	Check	the	extents	in	the	Properties	pane	>	SF	Display	Params	section.	A	line	of	10	points	appears	between	the	points	you	clicked,	for	a	total	of	12.	FLOW-3D’s	assumption	of	laminar	flow	in	porous	media
is	valid	for	this	case.	Uses	4	GB	memory.	This	is	a	copy	of	the	hd3msg	file	that	the	solver	writes	to	the	simulation	directory	while	it	runs.		Check	sensitivity	to	recommended	implicit	methods	Implicit	methods	are	indicated	whenever	they	will	result	in	a	significant	speed-up	of	the	run	time.	These	must	be	fixed	before	using	the	.stl	file	in	FLOW3D	or
unrealistic	results	might	occur	near	the	bad	surfaces.	13.74089909	7.39987087	97.17911530	Maximum	coord.	Open	the	Mesh	tree	(	to	toggle)	and	expand	the	tree	with	the	+	icon.	Install	the	software	with	full	installation	and	default	directory	options.	Page	9	of	16	Water	&	Environment	Training	on	FLOW-3D	v11	Making	.STL	Files	from	USGS	Data
Figure	13.	A	second	way	to	approach	the	problem	is	to	put	brackets	on	the	initial	turbulent	intensity.	The	source	is	defined	around	the	origin,	with	flow	vector	pointing	toward	z-max.	Tip	Holes	replace	solids	in	their	own	component.	Change	the	Pressure	from	Uniform	Pressure	to	Hydrostatic	Pressure.	Page	8	of	19	Water	&	Environment	Training	on
FLOW-3D	v11	Exercise	8:	Saturated	Porous	Media	Figure	4:	Fit	a	2nd-order	polynomial	to	the	experimental	data	This	is	obviously	a	better	match	than	generalized	correlations.	48,	89-94.	Move	the	Y	Limits	sliders	so	that	both	Min	and	Max	J	=	34.	Name	the	new	baffle	weir	flux.	adjusting	transparency,	ii.	This	verifies	that	FPSCL1	is	the	volume
fraction	of	air	in	the	mixture,	not	g/s.	Static	pressure	allows	the	solver	to	calculate	a	velocity	in	the	boundary	ghost	cells,	and	this	can	lead	to	run-away	flow	unless	there	is	significant	back-pressure	on	the	boundary.	The	model	output	matches	the	experimental	data	with	a	high	degree	of	accuracy.	If	you	decide	later	that	you	need	a	variable	which	was
not	specified	in	the	Selected	Data	list,	the	simulation	will	need	to	be	re-run	to	get	the	output	you	need!	On	the	other	hand,	too	many	selected	outputs	will	increase	the	size	of	your	results	file.	Each	point	is	a	measurement	of	surface	location,	defined	by	three	coordinates	in	some	reference	system:	latitude/longitude/elevation,	for	example.	Consider	the
following:	o	Cubic	cells	are	the	most	accurate.	Activate	the	Horizontal	Symmetry	checkbox	and	Render.		If	you	know	already	that	linked	or	nested	blocks	will	be	necessary	to	resolve	geometry	or	flow	features,	sketch	them	now.	It’s	recommended	that	you	repeat	the	process	of	checking	and	fixing	files	until	both	netfabb	Basic	and	qAdmesh	report	no
errors.	Figure	7:	Check	your	density-evaluation	results	visually	The	Flux	Plane	is	visible	in	the	plot	as	a	dotted	line.	Some	filters	are	less	stable:	most	do	better	with	a	few	million	points	or	less.	Select	both	clouds	in	the	DB	Tree	pane	and	use	the	Fuse	tool	on	the	menu	bar	to	combine	them	into	a	single	object.	As	visible	in	Figure	16	below,	there	are	also
some	red	areas	that	appear	to	be	electrical	cable	for	the	ground-based	LiDAR	camera	and	that	were	not	included	in	the	point	cloud.	Use	restart	simulations	to	minimize	the	run	time,	if	possible.	Sources	of	error	may	include:	a.	Momentum	advection	and/or	VOF	methods	may	diffuse	momentum	and/or	free	surfaces.	Select	the	options	shown	below.	The
Layers	dialog	lists	the	text	results.	Calibrate	the	air	entrainment	rate	coefficient	and/or	bubble	size	until	you	match	the	experiment,	and	then	model	the	target	case.	The	downstream	boundary	condition	depends	in	large	part	on	the	Froude	number	of	the	downstream	flow.	Note	that	the	new	Mesh	Plane	is	highlighted	in	the	display.	Includes	boundary
condition	information	like	flow	rates.	You	can	do	this	quickly	by	going	to	the	Simulation	Manager	tab	and	clicking	on	the	path	listed	for	Simulation	Input	File.	The	measurement	units	are	feet.	Locate	these	two	options	now	for	future	reference.	Volume	of	Fluid	1:	the	flow	volume	appears	to	reach	quasi-steady	state	by	about	60	seconds,	with	an	average
near	163	m3	in	the	simulation.	The	surface	pressure	will	be	that	of	the	initial	void	pressure,	which	defaults	to	zero,	and	will	be	maintained	by	the	Z-max	pressure	boundary	(where	F	=	0).	The	Weibull	distribution	is	a	good	fit	to	the	error	magnitudes.	By	default	Selected	data	and	Restart	data	are	output	every	1/100th	and	1/10th	of	the	simulation	finish
time,	respectively.	If	an	.stl	file	is	larger	than	about	420	MB,	neither	software	will	be	able	to	open	it.	The	problematic	fluid	packet	was	moving	in	the	x-direction.	Click	the	Move	tool	icon	and	lower	the	plane	so	it	cuts	the	extruded	faces	without	cutting	the	surface.	Select	Vertices	with	the	and	tools	to	select	those	points	that	comprise	the	ocean.	Later
you	will	locate	where	this	occurs.	The	three	methods	use	the	free	programs	qAdmesh,	netfabb	Basic,	and	MeshLab.	The	third	case	may	be	set	up	as	a	restart	from	the	second	case	even	if	the	second	case	has	not	run	yet.	Specify	Y	Low	=	-1.7,	Y	High	=	1.7,	and	Z	Low	=	3.	Click	on	Gravity	and	Non-Inertial	Reference	Frame.	Use	the	same	variables	of
interest	as	in	the	coarse	test	case.	Launch	FLOW-3D®	by	double-clicking	the	FLOW-3D®	icon	on	your	desktop.	o	Check	that	linked	blocks	have	edges	that	align	exactly.	Select	3-D	Plotting	Options	1.	Justify	the	design	mesh	resolution	(e.g.,	mesh	dependency	results	or	prior	experience).	Select	the	coordinate	to	view	under	Properties	>	Scalar	Fields	in
the	lower	left:	the	numeric	coordinate	values	are	given	as	the	slider	limits	of	the	displayed	SF	Scale	(see	Figure	4	below).	Save	your	work,	and	return	to	the	Model	Setup	>	Meshing	&	Geometry	tab.	actual	time	step	delt	used	during	the	cycle	(less	than	or	equal	to	dtstbl),	4.	Name	the	subcomponent	channel	bed	and	the	new	component	channel.	This	is
a	global	parameter,	and	applies	to	wall	boundaries	and	subcomponents	that	do	not	have	a	different	contact	angle	specified	as	a	surface	property.		Add	copies	or	restarts	with	refined	meshes	The	easiest	way	to	do	this	is	to	refine	the	cell	sizes	of	all	mesh	blocks,	in	all	directions,	by	the	same	factor.	Identify	attachment	locations	for	each	spring/rope.	Set
Color	Variable	=	Froude	Number,	and	open	Tools	>	Options	from	the	menu	above	the	display	window.	Repeat	as	necessary	to	eliminate	all	problem	vertices,	which	should	all	be	in	the	simplified	area	as	shown	below.	Final	configuration	of	plane	and	river	layers,	colored	by	elevation	g.	This	note	builds	on	the	exercise	Creating	.STL	Files	from
Topography,	available	on	the	FLOW-3D	Users	Site.
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